Audacity failing to open

I have 2.1.1-98.2-x86_64 from packman installed, but it doesn’t work (simply won’t open … nor is there any message displayed when trying to start it from a terminal).

I see there was an existing thread (see: https://forums.opensuse.org/showthread.php/508802-Audacity-refuses-to-start-on-opensuse-TW) in the (now locked/archived/former) TW forum regarding this. However, in the cases reported there, they were at least getting some std output feedback/error messages.

I tried switching to the oss repo’s version, but similar result.

Ugh. lol!

Mine is:

        Information for package audacity: 
--------------------------------- 
Repository: packman-ju-multimedia 
Name: audacity 
Version: 2.1.1-98.2 
Arch: x86_64 
Vendor: http://packman.links2linux.de 
Installed: Yes 
Status: up-to-date 
Installed Size: 9.6 MiB

   

Appears to be broken! It opens here but various task bars are out of position, menus are frozen on click, and lots of error messages in terminal.

ALSA lib pcm.c:2267:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2267:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2267:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
Expression 'ret' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1733
Expression 'AlsaOpen( &alsaApi->baseHostApiRep, params, streamDir, &self->pcm )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1900
Expression 'PaAlsaStreamComponent_Initialize( &self->capture, alsaApi, inParams, StreamDirection_In, NULL != callback )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2167
Expression 'PaAlsaStream_Initialize( stream, alsaHostApi, inputParameters, outputParameters, sampleRate, framesPerBuffer, callback, streamFlags, userData )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2836
ALSA lib pcm_dsnoop.c:615:(snd_pcm_dsnoop_open) unable to open slave           
ALSA lib pcm_dsnoop.c:615:(snd_pcm_dsnoop_open) unable to open slave

<*etc. snipped many repeated lines*>

Expression 'ret' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1733
Expression 'AlsaOpen( &alsaApi->baseHostApiRep, params, streamDir, &self->pcm )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1900
Expression 'PaAlsaStreamComponent_Initialize( &self->capture, alsaApi, inParams, StreamDirection_In, NULL != callback )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2167
Expression 'PaAlsaStream_Initialize( stream, alsaHostApi, inputParameters, outputParameters, sampleRate, framesPerBuffer, callback, streamFlags, userData )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2836
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4607

A pile of… …from Packman. :Olol!

Thanks for confirming.

I have just had the 32 bit version of 2.1.1-98.5 installed - which works fine. Yet to update 64 bit version - perhaps there is a solution on the way.

While doing a zypper dup, I noticed that a new audacity build from oss was brought in (2.1.1-1.1). So I tried launching it afterwards, but same failed result.

Then on a whim I checked my home directory and decided to remane ~/.audacity-data and then tried launching it again. That was met with success! … Of course, the above build is the crippled version, so I brought in build 2.1.1-98.3 from packman and … Success once again! Yeah! lol!

I note that there seems to be some minor interface changes, so perhaps my old ~/.audacity-data file’s settings clashed with the new additions … Though an alternative explanation might be that my old file’s settings may simply have had removed what changes I’m now seeing via using a fresh/stock generated ~/.audacity-data file … Not sure, nor am I going to worry about it.