Audacity 2.2.2-1.5 fatal error :Mismatch between the program and library build versions detected

The latest version of audiacty seems to have been broken with a recent zypper dup From a terminal:

audacity Fatal Error: Mismatch between the program and library build versions detected. The library used 3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8), and your program used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8). Aborted (core dumped)

Now, there was a previous thread about audacity on Leap for an identical error 

I would like to be able to downgrade to the previous version of audacity, which according to /var/log/zypp/history is

2018-06-15 19:18:23|install|audacity|2.2.2-1.4|x86_64||repo-oss

I believe I ought to be able to do something like

sudo zypper in --oldpackage audacity=2.2.2-1.4 

However that tells me

Loading repository data... Reading installed packages... 'audacity=2.2.2-1.4' not found in package names. Trying capabilities. No provider of 'audacity=2.2.2-1.4' found. Resolving package dependencies...  Nothing to do.

So a) can I downgrade using zypper? b) do I have to download the src package and try to build it myself c) or is a non-broken version in another repo? Thanks

You might wait a few hours, then try your zypper dup again. It is likely that the mirror was not completely in sync when you tried.

Starts and runs fine here, the one from the muldimedia repo that is, so that might solve it for you.

Thanks for that, tried downloading Audacity from there, and got the following from yast as it tried to install

Error: INVALID:audacity-2.2.2-131.13.x86_64 (file-31fdc61c): Signature verification failed [4-Signatures public key is not available]
    Header V3 RSA/SHA256 Signature, key ID f23c6aa3: NOKEY
    Header SHA1 digest: OK
    Header SHA256 digest: OK
    Payload SHA256 digest: OK
    MD5 digest: OK

I can wget the rpm, I’ll have a look further tomorrow

Better add that repo:

sudo zypper ar -f -n Multimedia Multimedia
sudo zypper ref    # trust the key 'a'lways
sudo zypper dup --from Multimedia

Then try Audacity again

Thanks, that worked

Information for package audacity:
Repository     : Multimedia                         
Name           : audacity                           
Version        : 2.2.2-131.13                       
Arch           : x86_64                             
Vendor         : obs://
Installed Size : 14.0 MiB                           
Installed      : Yes                                
Status         : up-to-date                         
Source package : audacity-2.2.2-131.13.src          
Summary        : A Multi Track Digital Audio Editor 

It also updated about 35 other multimedia package, like xine, rosegarden, hydrogen, jackctl etc etc

Anyway, I now have a working audacity again

…but unfortunately xine has sound issues with videos - it plays .wav files OK

but not a “.webm” downloaded using youtube-dl that was fine yesterday. Possibly a xine and pulseaudio problem

The xine volume level keeps dropping down to zero every few seconds or so. Opening pavucontrol shows headphones plugged in, but speakers unavailable

But I don’t get sound through the headphones, so something is clearly brrken there

However, the video plays fine and with sound in smplayer

I shall investigate further, but the audacity problem is fixed, so the above will be another thread

…but after I’ve watched the IFSC Lead Climbing World Cup from Chamonix from the other week (on smplayer)

… perhaps post the output from:

zypper lr -d

Thanks for the tip to use the version of audacity from:

I had the same error message and the rpm from the multimedia repo works fine.

This error has now been corrected.