Audacious is unable to use audio device through ALSA

Since doing a fresh reinstall of Tumbleweed I get an issue with apps trying to use my wireless Logitech headphones through ALSA. Whenever I try to play a song in Audacious I get the following error:

ALSA error: snd_pcm_hw_params_set_period_time_near failed: Invalid argument.

I checked out the Audio settings where under Output Plugin I have ALSA selected, then went under its plugin settings. Both my PCM and Mixer device are set to “default” which is what I believe worked before. I tried setting them to “sysdefault:CARD=my_audio_device” and “hw:CARD=my_audio_device” respectively, however those generate another error when playing:

ALSA error: snd_pcm_open failed: Device or resource busy.

The only thing that seems to work is setting it to PulseAudio output. However ALSA should be working too and I’d much like to fix this! What should I do to fix the ALSA device?

Be sure you have the alsa-pulse library. (sorry forget exact name but easy to find in Yast)

I have alsa-plugins-pulse installed. The only similar looking one is apulse, but the description says it’s a niche library only needed for Firefox and Skype.

Note that only one application at a time can be connected to the sound port so either Pulse or ALSA not both at the same time . alsa-plugins-pulse should allow apps that require ALSA to interface but the connect is actually still through pulse. It only provides the ALSA API.

I see. The issue is that before reinstalling, it worked just fine this way too. I should have the same settings as before. How do I find what might have changed that’s now rendering the device inaccessible through ALSA?