Audacious doesn't work

I have Opensuse 13.2 and I have installed Audacious 4.3 and the plugins when I click the Icon looks like is starting the program but after few seconds, is not opening. somebody have any idea about it?

Where did you get it and how installed??

Standard trouble shooting is to start the file from the command line in a console This will show any debugger output. Most common there is a missing library. It will tell you what is missing or broken

On Fri, 30 Jan 2015 04:16:02 +0000, Dexter22 wrote:

> I have Opensuse 13.2 and I have installed Audacious 4.3 and the plugins
> when I click the Icon looks like is starting the program but after few
> seconds, is not opening. somebody have any idea about it?

It seems the latest version is version 3.6 - according to the Audacious
website.

3.5 is the one that’s in Packman for 13.2 - I would set up the packman
repo and install from there, give that a try, and see if it works.

Otherwise, as gogalthorp says, we’ll need more information about where
you got it from and how you installed it - and any error messages you get
when running from a terminal.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

On Fri, 30 Jan 2015 05:11:12 +0000, Jim Henderson wrote:

> 3.5 is the one that’s in Packman for 13.2 - I would set up the packman
> repo and install from there, give that a try, and see if it works.

I can confirm that installing that way with zypper works just fine here.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

package from software managment, all looks normal.

is just install the 3.5 from software management and still the same problems, any idea or comand line?

As advised above, call it from the commandline:

audacious

On Fri, 30 Jan 2015 05:26:01 +0000, Dexter22 wrote:

> package from software managment, all looks normal.

Which repository did the installation come from?

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

lindx:~ # audacious
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/vorbis.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/psf2.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/modplug.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/metronom.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/sndfile.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/aac-raw.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/wavpack.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/vtx.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/adplug.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/console.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/tonegen.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/madplug.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/xsf.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/aac.so is not a valid Audacious plugin.
ERROR plugin-load.cc:71 [plugin_load]: /usr/local/lib64/audacious/Input/flacng.so is not a valid Audacious plugin.
ERROR plugin-init.cc:130 [start_single]: No output plugin found.
(Did you forget to install audacious-plugins?)
Aborted
lindx:~ #

I did install the audacious-plugins from software managment

On Mon, 02 Feb 2015 05:46:02 +0000, Dexter22 wrote:

> I did install the audacious-plugins from software managment

What repository does it say they installed from?

It sounds like you might have an incorrect repository configuration - it
would also be useful to (in code tags, please, so it’s readable) include
the output of:

zypper lr -d

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

lindx:~ # zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

—±-------------------------------------±----------------------------------------------------±--------±--------±---------±-------±---------------------------------------------------------------------------------------------±-------
1 | -d | packman-multimedia | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.2/Multimedia |
2 | KF5 | KF5 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/ |
3 | Qt5 | Qt5 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_13.2/ |
4 | devel:languageserl | devel:languageserl | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_13.1/ |
5 | devel:languageserl:CPAN-A | devel:languageserl:CPAN-A | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl:/CPAN-A/openSUSE_13.1/ |
6 | download.nvidia.com-opensuse | nVidia Graphics Drivers | No | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/13.2/ |
7 | download.opensuse.org-Education | openSUSE BuildService - Education | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_13.2/ |
8 | download.opensuse.org-Extra | openSUSE BuildService - KDE:Extra | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_13.2/ |
9 | download.opensuse.org-Virtualization | openSUSE BuildService - Virtualization (VirtualBox) | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Virtualization/openSUSE_13.2/ |
10 | download.opensuse.org-games | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_13.2/ |
11 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.2/ |
12 | download.opensuse.org-packages | openSUSE BuildService - Java packages | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_13.2/ |
13 | download.opensuse.org-php | openSUSE BuildService - PHP | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/server:/php/openSUSE_13.2/ |
14 | download.opensuse.org-python | openSUSE BuildService - devel:languages python | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_13.2/ |
15 | dvd | dvd | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
16 | filesystems | filesystems | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/filesystems/openSUSE_13.2/ |
17 | ftp.gwdg.de-suse | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/ |
18 | games:tools | games:tools | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/games:/tools/openSUSE_13.2/ |
19 | graphics | graphics | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_13.2/ |
20 | home:Bumblebee-Project:Bumblebee3 | home:Bumblebee-Project:Bumblebee3 | No | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Bumblebee-Project:/Bumblebee3/openSUSE_13.2/ |
21 | home:Ledest:misc | home:Ledest:misc | No | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Ledest:/misc/openSUSE_13.2/ |
22 | home:MargueriteSu | home:MargueriteSu | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/MargueriteSu/openSUSE_13.2/ |
23 | home verman79:JDownloader | home verman79:JDownloader | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Overman79:/JDownloader/openSUSE_13.1/ |
24 | home:RedDwarf | home:RedDwarf | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/RedDwarf/openSUSE_13.1/ |
25 | home:RedDwarf:fakePackman | home:RedDwarf:fakePackman | No | Yes | 99 | NONE | http://download.opensuse.org/repositories/home:/RedDwarf:/fakePackman/openSUSE_13.1/ |
26 | home:RedDwarf:multimedia | home:RedDwarf:multimedia | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/RedDwarf:/multimedia/openSUSE_13.1/ |
27 | home:Superpeppo89 | home:Superpeppo89 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Superpeppo89/openSUSE_13.2/ |
28 | home:Vovochka404 | home:Vovochka404 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Vovochka404/openSUSE_13.2/ |
29 | home:ecsos | home:ecsos | No | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/ecsos/openSUSE_13.2/ |
30 | home patrickmcdonough | home patrickmcdonough | No | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/patrickmcdonough/openSUSE_13.2/ |
31 | home petracvv | home petracvv | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/petracvv/openSUSE_13.1/ |
32 | home:seilerphilipp | home:seilerphilipp | No | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/seilerphilipp/openSUSE_13.2/ |
33 | http-download.opensuse.org-94d946cf | hardware | No | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/hardware/openSUSE_13.2/ |
34 | http-ftp.gwdg.de-601ae649 | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/ |
35 | http-opensuse-guide.org-5b07a112 | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
36 | kde5 | kde5 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Factory |
37 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
38 | openSUSE-13.2-0 | openSUSE-13.2-0 | Yes | Yes | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-hp_CDDVDW_SN-208DB_R8Y66YBD901TSA |
39 | opensuse-guide.org-repo | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
40 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/Factory/Essentials/ |
41 | repo-debug | openSUSE-13.2-Debug | Yes | Yes | 99 | yast2 | http://download.opensuse.org/debug/distribution/13.2/repo/oss/ |
42 | repo-debug-update | openSUSE-13.2-Update-Debug | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/update/13.2/ |
43 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/update/13.2-non-oss/ |
44 | repo-non-oss | openSUSE-13.2-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |
45 | repo-oss | openSUSE-13.2-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.2/repo/oss/ |
46 | repo-source | openSUSE-13.2-Source | Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/distribution/13.2/repo/oss/ |
47 | repo-update | openSUSE-13.2-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
48 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |
lindx:~ #

This is almost unreadable. But one thing I can say. it is most probably you have an unentangable mess here :(. It is most probably you have packages from several repos that do not work together. When you repost this between CODE tags, people can try to help you in unraveling this.

Do you really need all those repos? :open_mouth:
Maybe you should clean up a bit.
I don’t want to go through all of them, but some notes:

1 | -d | packman-multimedia | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.2/Multimedia |
17 | ftp.gwdg.de-suse | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/ |
34 | http-ftp.gwdg.de-601ae649 | Packman Repository | Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/ |
40 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/Factory/Essentials/ |

You only need Packman once!
packman-multimedia is a subset of Packman, if you have the full Packman repo this is unnecessary.
And #40 is for Factory, this will only give Problems on 13.2.
So remove all of them except for #17.

2 | KF5 | KF5 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_13.2/ |
36 | kde5 | kde5 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Factory |

Again, there’s no need for duplicated repos. And #36 is for Factory, please remove that!

15 | dvd | dvd | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
35 | http-opensuse-guide.org-5b07a112 | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
37 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |
39 | opensuse-guide.org-repo | libdvdcss repository | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.2/ |

Another useless redundancy. Remove all but one.

24 | home:RedDwarf | home:RedDwarf | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/RedDwarf/openSUSE_13.1/ |
25 | home:RedDwarf:fakePackman | home:RedDwarf:fakePackman | No | Yes | 99 | NONE | http://download.opensuse.org/repositories/home:/RedDwarf:/fakePackman/openSUSE_13.1/ |
26 | home:RedDwarf:multimedia | home:RedDwarf:multimedia | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/RedDwarf:/multimedia/openSUSE_13.1/ |

Those are for 13.1, another source for problems. Better remove them, those repos don’t contain anything that isn’t available somewhere else AFAIK (Packman e.g.). In particular they contain audacious, in a different version than Packman (and for 13.1), so they might be the actual reason for your audacious problem.

And fakePackman is useless to you anyway. This contains fake (as the name implies) Packman packages (like ffmpeg) with all actual code removed, so that you can build multimedia packages on OBS (where certain multimedia stuff is not allowed due to legal reasons).
If you install those packages on your system, it can break your multimedia.

31 | home petracvv | home petracvv | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/repositories/home:/petracvv/openSUSE_13.1/ |

This is for 13.1 as well. Unfortunately this is not available for 13.2, but it shouldn’t cause any problems judging from its contents.
If you don’t need it, you’d better remove it though.

I hope I haven’t overlooked something important… :wink:

So, to sum up, remove the repos as mentioned:

sudo zypper rr 1 34 40 36 15 35 39 24 25 26

Then switch all packages to their Packman version:

sudo zypper dup --from "Packman Repository"

This should (hopefully) fix your problem with audacious.
The current Packman version works fine here at least…

On Mon, 02 Feb 2015 06:46:12 +0000, Dexter22 wrote:

> lindx:~ # zypper lr -d

As Henk said, this is nearly unreadable because you didn’t use code tags,
as requested. But you’ve got so many repos here, it’s no wonder you’re
having problems.

To use code tags, click “#” in the toolbar in the post editor, then paste
the text between the tags.

That will help us help you a lot.

I also asked which repository you installed from - saying that you
installed it from “software management” doesn’t answer that question -
this list of repositories is huge, and there are probably several repos
that it could have come from. We need to know which repository the
software management tool says it installed the audacious and the
audacious plugins packages from.

You can also tell that from a command like using:

rpm -qi <packagename>

Replacing <packagename> with the name of each of the relevant packages.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Thanks for your help guys, I am going to check everything that you mention here, I am not sure what repo it was used when I installed the Audacious.

I deleted the repo that you mention and I did zypper dup as you show me, but still nor working audacious and I have the same problem with sk1 when I am trying to start the pointer have the Icon of sk1 as the icon of audacious when I am trying to start too but is not working.

On Tue, 03 Feb 2015 03:46:01 +0000, Dexter22 wrote:

> I deleted the repo that you mention and I did zypper dup as you show me,
> but still nor working audacious and I have the same problem with sk1
> when I am trying to start the pointer have the Icon of sk1 as the icon
> of audacious when I am trying to start too but is not working.

If it doesn’t run from the terminal, the icon isn’t going to work either.

Try executing:

rpm -qi [packagename]

as I suggested to see which repo the packages came from. You’ll need to
use the proper package names, naturally.

The packager/vendor info will be the most important, but all of it is
what you should include - in code tags - for us to look at.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

lindx:/ # rpm -qi audaciousName        : audacious
Version     : 3.5.2
Release     : 2.1
Architecture: x86_64
Install Date: Mon Feb  2 23:56:30 2015
Group       : Productivity/Multimedia/Sound/Players
Size        : 462337
License     : BSD-2-Clause
Signature   : RSA/SHA1, Fri Jan  2 03:25:12 2015, Key ID 45a1d0671abd1afb
Source RPM  : audacious-3.5.2-2.1.src.rpm
Build Date  : Fri Jan  2 03:09:57 2015
Build Host  : swkj03.site
Relocations : (not relocatable)
Packager    : packman@links2linux.de
Vendor      : http://packman.links2linux.de
URL         : http://audacious-media-player.org/
Summary     : Advanced audio player
Description :
Audacious is an advanced audio player. It is free, lightweight,
currently based on GTK+ 3, runs on GNU/Linux and many other
UNIX-like platforms, and is focused on audio quality and supporting
a wide range of audio codecs.
It still features an alternative skinned user interface (based on
Winamp 2.x skins).
Historically, it started as a fork of a fork of XMMS.
Distribution: Multimedia / openSUSE_13.2



And what error do you get now, when you run it in a terminal window?

The last time you posted this:

But the packaged audacious should not look for its plugins in /usr/local/, nor install anything to /usr/local/.
If you still get the same errors, you probably have some other version lying around that is started instead of the packaged one.
Maybe you tried to compile it yourself at some point and now have a audacious in /usr/local/bin/ but the plugins are missing?

Please post the output of:

which audacious

and

ls -l /usr/local/lib64/audacious

If that exists, you should probably remove it.

I have the same error that you post, I was trying to compile but I have a problem with a library when I run make

Failed to compile tonegen.c (plugin)!../../buildsys.mk:391: recipe for target 'tonegen.plugin.o' failed
make[5]: *** [tonegen.plugin.o] Error 1
../../buildsys.mk:116: recipe for target 'all' failed
make[4]: *** [all] Error 2
../buildsys.mk:123: recipe for target 'tonegen' failed
make[3]: *** [tonegen] Error 2
../buildsys.mk:116: recipe for target 'all' failed
make[2]: *** [all] Error 2
buildsys.mk:123: recipe for target 'src' failed
make[1]: *** [src] Error 2
buildsys.mk:116: recipe for target 'all' failed
make: *** [all] Error 2



I was trying to install togen.c but I think I messed up. Any help please.

lindx:~ # ls -l /usr/local/lib64/audacioustotal 4
drwxr-xr-x 2 root root 4096 Nov  8 23:53 Input