Attention users of Opensuse 13.2 & XBMC/KODI if you get this error here's a fix!

When I tried to start XBMC from Kickoff it wouldn’t start. So when I started it from Konsole I got this:

sh: xdpyinfo: command not found
Traceback (most recent call last):
  File "/usr/share/xbmc/", line 175, in <module>
    if (badColorDepth()):
  File "/usr/share/xbmc/", line 154, in badColorDepth
    return bitDepth
UnboundLocalError: local variable 'bitDepth' referenced before assignment

I found a fix for this that may work for you if the same error hits you.
What did was I went through Yast typed pyinfo into the Search.
A package called xdpyinfo came up, I installed it & now XBMC works like it should.

Yes, XBMC was missing a dependency.

But it has been fixed already:

And the current version 13.1-2.1 now in the repo does require xdpyinfo:

wolfi@linux-lf90:~> LANG=C zypper info --requires xbmc Loading repository data...
Reading installed packages...

Information for package xbmc:
Repository: Packman Repository
Name: xbmc
Version: 13.2-2.1
Arch: x86_64
Installed: No
Status: not installed
Installed Size: 68.0 MiB
Summary: XBMC Media center
  XBMC media center is a free cross-platform media-player jukebox and
  entertainment hub.  XBMC can play a spectrum of of multimedia formats,
  and featuring playlist, audio visualizations, slideshow, and weather
  forecast functions, together third-party plugins.