Attempting to access "Boot Loader Options" freezes system

Any one else seeing this behaviour where going into the Boot loader Options (Yast > System > Boot Loader > Boot Loader Options) to edit GRUB2 options almost immediately, and absolutely, freezes up the system (requires a hard reset)?

Particulars: 12.2, x86_64 … not sure what else would be relevant for this one … nor am I sure whether its the Yast module’s problem or whether it has something to do with GRUB2 itself … first time using GRUB2, and, currently, not very familiar with its mechanics (as opposed to with legacy GRUB )

If you’ve only opened the editor and not actually made any changes, that doesn’t sound right.

If exactly how you described it, recommend for starters exploring other YAST modules to see if any other exhibit the same behavior.


Indeed, that is exactly the case!

I have now also observed on several occasions that sometimes just getting into the Boot Loader module fails – it, the module, becomes unresponsive on “Read Partitioning” 33% step … fortunately the rest of the system is still responsive. Killing the module doesn’t take immediate effect – the GUI remains on screen for several minutes but it looks like Kwin killer finally deals it a death blow.

recommend for starters exploring other YAST modules to see if any other exhibit the same behavior.
Good suggestion. Under limited use so far, have not found any other cases of disturbing behaviour with other Yast modules

It seems that after this happens, upon the next boot/reboot of the system, the resolution of the primary monitor is screwed up (much lower or zoomed in/panned in) starting from the KDM login screen and carrying through to the desktop (i.e when X is running), yet when logged in, randr reports that its operating at correct/native resolution. Oddly enough, the other monitors are not affected (on either the KDM login screen or on the desktop)…ugh. Then it seems like it takes several reboots before the correct resolution is restored again (both on KDM and the desktop) for the primary monitor.

Anyway, in regards to the initial problem, I have discovered that if I boot via the “rescue” mode, then I can access and change the boot loader options through the yast module. Though, I’ll also note that the read partitioning step (that occurs when you start up the yast bootloader module ) does seem to be way too long (~15s … especially for an SSD)…its strangely reminiscent to the slowness of the disastrous packagemgmt in the 10.1 release LOL rotfl!

Also of note, I uninstalled the yast2-bootloader module (as well as the 7-8 dependencies) and then later did a reinstall of the very same. That produced no change in behaviours from what I’m reporting.

Something really screwy going on.

Also chasing down another likely GRUB2 related issue: trying to get HDMI audio up and running – needing to add boot option, but when its applied, I’m (a) not getting any audio (though everything looks good from pauvcontrol etc) and, worse, (b) a pink vertical line (maybe just one or two pixels width) running the entire height of the primary monitor (once KDM starts up and persisting through the desktop) is now observed. Ugh. Removing the radeon audio boot option removes the pink line display artifact.

This blows goats. My Factory install (utilizing legacy grub), and which I was just previously running on this system (as well as utilizing the bleeding edge xorg repo) had zero issues in these regards and has been remarkably stable. I had moved seamlessly from 12.1 to that cutting edge setup sometime in early summer (as 12.2’s final shape was taking place) . I’ve decided to drop back to “stable” 12.2 now, before that (now essentially a very early 12.3 release) might become buggy when heavy development on and further shaping of the next release picks up speed. Was certainly not anticipating these headaches with stock 12.2 given my very favourable experience with the 12.2 transition via the Factory distro. It goes without saying that my initial impression with GRUB2 has started off in the wrong direction. >:(

In regards to this later mentioned HDMI audio issue, all I can say is that I’m such a monkey – as is clearly explained here, my HD 6xxx series adapter’s do not have HDMI audio support in the radeon driver natively included in the, kernel 3.4 using, stock 12.2 openSUSE release. Switching to trying with the older 4xxx generation radeon, and I find that HDMI audio does indeed work like a charm …i.e. GRUB2 never was at fault. Again, I repeat, I am a stupid head :stuck_out_tongue: … I guess at some point during my summer romp with running Factory I had switched the audio out to the HD 6xxx but forgot about that little fact.

Now back to the tackling the original (and subsequently found ) problem(s) regarding the wonky Yast Bootloader Module …

Okay, some progress on this. Installed the GRUB2 update today and in four tests:

  • the first three were successful-- upon entering the module, it did not become unresponsive during the “read partitioning” step (though it still took an unnatural amount of time (~15s) to complete this step) and I was then able to access the
    boot loader options screen and then successfully make edits
  • the fourth turned up another case of what appeared to be the module becoming absolutely unresponsive upon entry during the “read partitioning” step … however, after trying to close the module and being notified by KDE that it was unresponsive, instead of trying to kill the process as I had in earlier instances, I left it running to see if anything would happen … to my surprise, the “reading partitioning” step eventually, after several minutes (maybe close to 5?), completed and I could then access the boot loader options … weird.:dont-know:

So it appears that

  • I can now sometimes (75% of cases) somewhat normally access the module and its boot loader options to make changes … and, perhaps, in the remaining cases just be really (really) patient
  • or I could boot into the recovery mode (GRUB2 > Advanced options for openSUSE > recovery mode … note: I mistakenly called this rescue mode earlier in the thread) and access the module … this method seems to have worked all along, albeit also with a slow (~15s) partition read step
  • or just manually edit /etc/default/grub and then run grub2-mkconfig -o /boot/grub2/grub.cfg, which works without fail every time

Given that I’m not actually passing new or changing kernel boot options all too oftern, I think I will stop spending any more time on this and just use the grub2-mkconfig route when need arises.

Don’t know what caused the original inability to access the options via the module, or whether today’s grub update provided such a fix (the change log does not indicate such). Nor do I know why grub seems to be having difficulty or, at least, is tripping up when it comes to my partitioning (which is pretty darn vanilla). Shrugs and moves on.

I’ve used it extensively but not experienced any trouble, except that I don’t find it behaves as expected.

I wonder if this may be related to floppy probing. Do you see any error messages related to /dev/fd0 in dmesg after probing? Do you have floppy controller (not necessary floppy itself) on motherboard and is it enabled in BIOS?

its possible … it was something I had in the back of my mind

Do you see any error messages related to /dev/fd0 in dmesg after probing?
No, there is no such message.

When I went through the log on Sunday, the only thing I found that I thought might be playing a part in any way was: kdm[687]: Cannot execute ‘grub-set-default’: not in $PATH.
But that is apparently an old bug: [Bug 584082] grub-set-default does not work](

I do not know if that is still being generated after applying yesterday’s grub2 update (I haven’t checked)… but I do seem to recall seeing mention of grubonce (the preferred way, so says the thread I just linked too) in the changelog.

Do you have floppy controller (not necessary floppy itself) on motherboard
yes, the mobo has a floppy controller

and is it enabled in BIOS?
IIRC it is disabled, but will have to check later on to see if it is disabled, and if not, whether that makes a difference.

Looks like this was indeed related to floppy probing. Although I did not have any such entry in my file, what I did have was floppy drive support enabled in the mobo’s BIOS (I had performed a BIOS update likely in July and must have cleared settings and overlooked it … it was on the first page of the Award BIOS and not in the advanced chipset options).

I’ll make a note of this in the that other thread too.

Anyway, all problems solved as far as I can see with limited testing.

Actually, I was able to re-trigger the original problem: “going into the Boot loader Options (Yast > System > Boot Loader > Boot Loader Options) to edit GRUB2 options almost immediately, and absolutely, freezes up the system (requires a hard reset)”

I have, however, also been able to narrow things down to what is causing this: when I have both the integrated graphics (iGPU) and the discrete graphics (dGPU) enabled in the system, via turning both on in the BIOS (though the adapters are not both enabled via xorg), then this freezing will occur.

My earlier explained HDMI audio “issue” actually helped to bring that knowledge to light. If you bear with me I will clarify:

Recall that I complained that using the kernel boot option did not work and also introduced a vertical pink line display artifact But in the process of discovering that those “bugs” were solely a case of user error (because such support for the dGPU is not available in the stock driver for 12.2), I first trouble shot by testing the very same on the iGPU – something which involved unhooking the HDMI cable from the dGPU and hooking it up to the iGPU, as well as taking the extra step of disabling the dGPU in the BIOS. As the iGPU has appropriate driver support for HDMI audio, it worked flawlessly and I realized shortly afterwards where my folly lay in this regards.

Next I resolved the other issue (slow “read partitioning”) by disabling floppy support in the BIOS. After that, I reported back here, in my very last message, that everything seemed to be working fine.

However, after running with just the iGPU for a day or two (during which time everything in regards to the Yast Bootloader Module did indeed seem to work fine on several uses of it), I switched back to having both the iGPU and dGPU enabled in the system. In the process of doing this, I switched the HDMI cable back to the dGPU, but what I initially forgot about was that I still had the option set in the bootloader kernel boot options and, because of this, I re-encounterd the same vertical pink line artifact. No problem right? I mean its just a case of going into the GRUB2 settings and removing that particular boot option causing this issue. Lets see now, I can do it manually (via editing the /etc/default/grub.cfg file and then running that grub2 command) or I can even more effortlessly do that via my now apparently perfectly functioning Yast Bootloader module. I choose Yast. And upon attempting – Bingo! I immediately find the module & system impaired by the freezing issue once again and requires a hard reboot. Ugh.

(Incidently, upon booting up after that, or coincidently shortly there afterwards, I discovered that the Plymouth bootsplash animation no longer worked on system startup. I have not been able to get it back, so have started another thread about that particular error here)

I checked a few more times with attempts to use the Yast module, but the result was the same case of a complete system freeze each time. As that’s not much fun, I set this aside.

Now, in the course of tracking down a couple of other annoying bugs (not related to this issue, but related to the use of multiple graphics adapters), I have since disabled the iGPU in the BIOS. For kicks and giggles (and given my experiences above which were leading me to believe that the presence of the two graphics adapters are at the heart of the Yast module freezing issue), I tested the Yast bootloader module once again. The result? Fully functional again. So, in my mind, that further isolates the fact that this freezing issue in the Yast module appears only when the two adapters are enabled concurrently.

The only other test that I am curious about is what the result will be when I enable both adapters in the system via the BIOS and then enable use of them both in X via enabling the appropriate server layout. I suspect that won’t make any difference, but then again, maybe it is having some impact on the situation. I’ll have a look when I get a chance.

In the meantime, as it is, it looks like the freezing issue I’ve encounterd is a bug that is only brought to light in more of an edge case usage scenario. Can anyone else replicate this?

Hi all,
I can confirm the trouble about the floppy.
Also if not installed in the system i had to disable in the bios of the Gigabyte putting on “none” the option.
The floppy give trouble also at the system creating some lag.
Then… attually I dont use grub2 so i cant confirm other issue.