Attansic card stopped working after kernel update

I have an ASUS P5QL-E motherboard with an Atheros / Attansic PCI-E network chip. I have both XP and openSUSE installed. The network chip worked without any problem until three frustrating days ago when I updated my openSUSE 11 system using the automatic update. Previously I had kernel Now I was upgraded to kernel and the network chip is not working any more. (It still works in XP.) I cannot go back to the old kernel as both the corresponding vmlinuz and initrd files were removed from the system, although the module directories were left intact.

The hardware detection in YaST detects the card, displays its properties correctly, the network configuration dialog shows two lines containing the Attansic card, but the first one cannot be edited and marked as "not configured’, while the second one has my been configured but marked as not present.

I have found a driver module for the attansic card called atl1.ko in
/lib/modules/ directory and made sure the /etc/modprobe.conf.local file contains the single line:
alias eth0 atl1.
I can load this module manually with modprobe, (it loads mii.ko first) but the eth0 device still odes not appear.
I discovered that the old kernel had a module named atl1e.ko instead of atl1.ko. I copied it to the module directory and run depmode then tried to load it but modprobe said it is not the correct file format.

The boot messages I see (from boot.msg):

Starting HAL daemon done
Setting up network interfaces:
lo IP address:
IP address:
lo done Waiting for mandatory devices: eth0 NSC
20 19 18 17 16 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
eth0 No interface found
failedSetting up service network . . . . . . . . . . . . . . . .failed

In the messages file the following line was present before the update:
Jun 15 15:57:32 falcon kernel: ATL1e: eth0 NIC Link is Up<100 Mbps Full Duplex>
Now it disappeared.

Can you help me?