Attansic/Atheros wired NIC not recognized

I am having and issue with an Atheros (shows as Attansic for some reason) PCIe wired ethernet chipset. I have successfully installed various Linux distros in the past, but have not done so for a while. Now I have a new system and would like to make it fully functional with networking enabled.

The system is based on the fairly common Asus P5Q MB with the Atheros NIC onboard. I would rather not pop the system open just to add a “Linux friendly” NIC as the Windows Vista side of the systems seems perfectly fine with this NIC.

I did download the Atheros Linux driver as a tar.gz (atl1-2.0.7-linux-2.6.20-standalone.tar.gz) and following some posts here I seemed to successfully unpack it an put it in /home/user/drivers. It shows with its own folder after the unpack and there is a Makefile file in the folder. When I try sudo make install, I get an error that says “not a known command”, so I’m kind of stumped.

I know I am a pretty complete newbie here, but this is getting fairly frustrating. Can I get some guidance on what to do next ?

any and all help on this matter is greatly appreciated. I’d very much like to have openSUSE running on this system.


Hi. Have you installed the RPM “make”. Run this command in a console to see:

rpm -q make

ok, I’ll look, but what if it (MAKE) is not there, what steps should I take then ?

Somewhat off topic, and not intending to invite a flame, but I am starting to remember what a PITA it was to install and configure the Linux distro’s I had on my prior system (Kanotix, a debian clone, and OpenSUSE 10.x) This time I thought I would just go back to one that I knew to be pretty robust so I would not have the exact kind of problem I am having … i.e. no network access.

I mean, come on, this is a pretty common/popular/maintream ASUS motherboard with a well known on-board NIC. What the heck! >:( I have spent the better part of 2 days in utter futility on this issue, and the more I have to reboot into Vista (of all things) to check forums and the web for clues, the more installing openSUSE seems like a fools errand.

ok, whew, rant off, I’ll try seeing if I have Make installed, and go from there.

ok, there we go then … Make was not installed, I installed it, and then seemed to be able to get the Atheros drivers unpacked and loaded, but still no network.


Configure the card. Here’s a pictorial tutorial:
HowTo Configure a network card in Suse/openSUSE 10, 11 for LAN and Internet Access.

I appreciate the step by step pictorial. But, the issue is that the Attansic/Atheros NIC is not even recognized as is shown in the first shot of Net Configuration … it actually comes up and says that the Attansic (Atheros) card is not recognized because of lack of firmware … or something to that effect.

Googling on this topic determines that my on-board NIC will not be supported until kernel 2.6.27 (current release is 2.6.25). There are some posts that supposedly show directions to recompile the source with a compatible driver, but at this point, I think I’m going to bag it and wait until the NIC is supported in the release version.

It’s just not worth the hassle. too bad.



Anyone knows what that is mean?
p5q:/lib/modules/ # insmod atl1.ko insmod: error inserting ‘atl1.ko’: -1 Invalid module format

This is an up-to-date SuSE 11.0 on a “fantastic” ASUS P5Q Pro MB.

The original kernel version said that, too.


O, o!
This was my problem. I used wrong kernel version! I forced -default and my kernel is -pae.
Now atl1.ko is loaded. And that’s all! No eth1, or other Ethernet device. :frowning:
(eth0 is a PCI 3Com 509B)

With the openSUSE liveCD version 11.0 it is not easy to set up the integrated NIC on the ASUS p5ql pro ( or, I think, ASUS P5Q* ). More specifically, any ASUS board that uses the Atheros 81 series NIC chipset. I did manage to get it to work finally though. A lot of the problem comes from the fact that the openSUSE livecd does not come with gcc, make, the kernel headers, or the kernel source. In order to get these installed you have to download them from the openSUSE website. Also, you have to download their dependencies. All in all, about 10 rpms are needed to do this.
Once you have this done, get your linux driver from the asus website. Unzip it, get it onto some media, and get it into your network bereft filesystem. Once there decompress it and cd to the src directory. The usual make, make install process works here. NOTE: for me, I had to edit the Makefile and change all the CFLAGS to CFLAGS_EXTRA. Then, cd to the directory specified at the end of the make install command (where it said it put the .ko file). once there, run insmod ./atle.ko. Now, your ethernet should autoconfigure in about 30 seconds and you’ll be good to go!

Thanks for your description!
I installed kernel-source, kernel-headers (I don’t know if it needs), make and gcc.
I download l1e- file.
It was compiled and the result atl1e.ko file was installed in the running kernel success full:

Atheros(R) AR8121/AR8113/AR8114 PCI-E Ethernet Network Driver - version
Copyright (c) 2007 Atheros Corporation.
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 17 (level, low) -> IRQ 17
PCI: Setting latency timer of device 0000:01:00.0 to 64

There is an eth1 interface, now. I don’t know whether it is working, because there isn’t connected UTP cable in it. (I use eth0 with 3Com 509B.)

The only one problem which is remained: building rpm:
p5q:/home/rattila # rpmbuild -tb l1e-
error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)