Atomic Modeset Error -22 after latest Nvidia Update on Tumbleweed

@diacobel.1 normally nosimplefb=1 is used for Intel/Nvidia hybrid setups, did you add this? Also is perhaps suse-prime installed?

Can you show the output from inxi -Gxxz

I am running a straight Tumbleweed install. I have done no modifications to anything on the system. I did not install suse-prime but upon checking it is installed. Here is the output from inxi -Gxxz

Blockquote
inxi -Gxxz
Graphics:
Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: Micro-Star MSI
driver: i915 v: kernel arch: Gen-13 ports: active: none empty: DP-1, DP-2,
HDMI-A-1, HDMI-A-2, HDMI-A-3, HDMI-A-4 bus-ID: 00:02.0 chip-ID: 8086:a780
Device-2: NVIDIA AD106 [GeForce RTX 4060 Ti] vendor: Micro-Star MSI
driver: nvidia v: 550.78 arch: Lovelace pcie: speed: 2.5 GT/s lanes: 8
ports: active: none off: HDMI-A-5 empty: DP-3,DP-4,DP-5 bus-ID: 01:00.0
chip-ID: 10de:2803
Device-3: Logitech HD Webcam C525 driver: snd-usb-audio,uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-5.3:7 chip-ID: 046d:0826
Display: wayland server: X.org v: 1.21.1.12 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
alternate: intel gpu: i915,nvidia display-ID: 0
Monitor-1: HDMI-A-5 res: 2560x1440 size: N/A
API: EGL v: 1.5 platforms: device: 0 drv: nvidia surfaceless: drv: nvidia
wayland: drv: nvidia inactive: gbm,x11,device-1,device-2,device-3
API: OpenGL v: 4.6.0 vendor: nvidia v: 550.78 glx-v: 1.4
direct-render: yes renderer: NVIDIA GeForce RTX 4060 Ti/PCIe/SSE2
display-ID: :1.0
API: Vulkan v: 1.3.283 surfaces: xcb,xlib,wayland device: 0
type: discrete-gpu driver: N/A device-ID: 10de:2803 device: 1
type: integrated-gpu driver: N/A device-ID: 8086:a780
Blockquote

@diacobel.1 So it is a hybrid setup… So do you want to use Prime Render Offload for your Nvidia card or just the Nvidia card?

If just the nvidia card, then you need to check the system BIOS and see if you can either disable the iGPU, or set the Nvidia card as primary… You will need to uninstall suse-prime and add a lock as well. Likely you will need to swap the nosimplefb for the nvidia one in the Grub kernel options.

If you want to use Prime Render Offload, then you should be able to uninstall suse-prime and add a lock and install switcheroo-control, then as root user systemctl enable --now switcheroo-control.service since your on Plasma, you will need to use the command switcherooctl . Plasma is supposed to get a dbus service to enable right click and launch with the discrete card at some point I believe.

But if you clarify your workflow can go into more detail.

I primarily use the computer for photo editing, video editing, cad design, and general office work. Did not even know it is a hybrid setup. When I did the installl after I defined the packages I wanted, directory structure, and filesystems to be used, I let the Tumbleweed installer make the rest of the decisions. Tthough Prime Render Offload appears to be a Nvidia decision. Could this in some way be a Wayland conflict? I am leaning towards keeping Prime Render Offload. Thoughts?

As a side note I just installed the latest updates including new Nvidia drivers. No change, atomic modeset still fails.

@diacobel.1 Prime Render Offload should work fine with graphical applications and detect the card is available and usable for editing…

I’m assuming there is a Motherboard connection for your monitors that could be used?

Did you uninstall suse-prime (Xorg only) as that would have created an Xorg file and also inhibits the use of Wayland…

What does the output from xrandr --listproviders show?

My motherboard has a HDMI connection which I don’t use. My monitor is connected only to the Nvidia card. suse-prime is currently installed and xrandr --listproviders returns 0.

After reading through this dialogue I checked and found that switcheroo-control is installed on my system as well. Services Manager is showing switcheroo-control as inactive.

@diacobel.1 OK, so you need to remove suse-prime and add a lock. Then power down and plug the monitor into the motherboard connector so it should use the intel GPU and reboot. Then post the output from inxi -Gxxz and xrandr --listproviders again.

@diacobel.1 Just a FYI for another user with the same issue https://forums.opensuse.org/t/how-to-switch-to-the-nvidia-dgpu-in-tumbleweed/175576

I did as you requested. When I restarted the computer it made it to the login screen and froze. I was unable to move to a console screen and was forced to power down. Fortunately pressing the pwr button makes the machine go to init 0 instead of doing a hard reset. As a result I was unable to run the inxi or xrandr commands with the hdmi cable connected to the motherboard.
When I reconnected the hdmi to my graphics card the first thing I checked was the uefi bios. integrated graphics is enabled and the integrated graphics adapter setting is set to peg. Perhaps the intel gpu doesn’t play nice with wayland? With suse-prime removed the machine boots to runlevel 5 without issue.
Switcherooctl is installed on my machine but is currently disabled. What will I have to configure once I enable it?
Thanks again for taking time with this issue.

@diacobel.1 As root user, run systemctl enable --now switcheroo-control.service

done. hopefully this is the end of the issue. thanks again for taking an interest, it is appreciated.
Dave

@diacobel.1 So it’s all working as required now?

It appears to be.