ATI ?

Hi,
how do you install the latest ATI drivers on OS 11.1 x64 ?

The repository listed: Additional YaST Package Repositories - openSUSE does not work.

It gives a continous “could not add repository”.

Did anyone manage to get fglrx working with the latest drivers ?
I’m having a 4850.

Thanks,
Skymerto

It may be a few days before the driver is in the repository. You can always compile your own using the instructions on the ATI website, but I will just wait till they drop it in the repo.

thanks… Guess I’m going to wipe 11.1 and install Ubuntu again.

Such a pity, I wanted to make OS my new primary OS.

skymerto wrote:

>
> thanks… Guess I’m going to wipe 11.1 and install Ubuntu again.
>
> Such a pity, I wanted to make OS my new primary OS.
>
>

Why not just d/load manually from the ATI site and run the installer?

As long as you have the kernel source and gcc+make etc ( as shown on the ATI site ) then it only takes 2 minutes to run and install.

I have just done it here on 2 machines no sweat.

Lot quicker than a format an install of another distro :slight_smile:


Mark…

Nil illegitimi carborundum

In most cases, you can use the open-source drivers (radeonhd for newer chipsets, and radeon for older ones). The only exceptions are for pre-Radeon graphics cards (which are supported by the older mach64 or ati drivers) or the very newest chipsets (HD46xx/HD43XX only). All ATI X-series (including X1K series), HD2xxx and HD3xxx drivers are supported by the included radeonhd driver (I have an X1650PRO in AGP, and am using the radeonhd driver, complete with compiz support and gaming support).

I had a Radeon 9250 that was not supported by the regular ATI proprietary driver. Where can I find this Mach 64 driver?

If you cant wait few days, then go ahead. Install Ubuntu… Btw, radeonhd drivers works fine.

Ok, I just needed a night to sleep on it.

Going to make a couple of more attempts at installing it.
(have tried running the installer 5 times but it just bombs out).

I installed openSuSE on my desktop with an Intel Q9550, 4 GB RAM, Asus P5Q-Deluxe motherboard, and a Radeon X1950 PCI-E graphics card. I am trying to run both KDE 4.1 and KDE 3.5, but have only tested in KDE 3.5 so far.

I have taken the time to install via the ATI installer. I have tried the 8.12 and 8.11 installers, as well as the 8.9 installer. In OpenSuSE 11.0, the 8.11 and 8.10 drivers failed with this card (X would not load after installation) and so I reverted to the 8.9 drivers. Thus, I thought I would try a good range of the versions, but nothing seems to work.

The 8.12 and 8.11 installers install well, and aticonfig --initial -f works as expected. X even loads after a this. However, when anything tries to access the driver, (glxinfo, fglrxinfo, glxgears, wine, etc) it prints gives the following output.

glxinfo
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  144 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  15
  Current serial number in output stream:  15

The 8.9 installer loads and then gives the following error output.

==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
which: no XFree86 in (/usr/sbin:/bin:/usr/bin:/sbin)

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib::none:2.6.27.7-9-default; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.psY050

I have yet to see any posts that regard this issue on openSuSE (save one in a foreign language that was not very helpful to me) and only a few on Ubuntu 8.10 (also not very helpful). This has been somewhat puzzling. In the past, every time ATI drivers failed to install or run correctly, the X server would fail to load. I am unsure what this means.

Thanks to anyone who might be able to help.

Oddly enough installing the driver from the ATI website left me with a corrupted screen on login and/or the black screen on login. Even after running the --initial command etc.

For now I shall go back to no compositing and wait for the repository drivers to see if they work any differently.

Select your driver from Drivers & Software and download it. A binary file (with .run extension) should come. Make a backup of /etc/X11. Just execute the downloaded file with ./file_name and a GUI installer should come. After installation run the command aticonfig --initial. Restart your machine. (The driver may create Hazard)

A fresh install of 11.1 on my T60p with an ATI v5200 identified the card correctly, and by default 3D Effects were enabled. Unlike 11.0…which identified it correctly, but never allowed 3D Effects, even after trying to install newer drivers.

I’ll hold off on updating the drivers in 11.1 until I read more here.

I’m having exactly the same issue, I have just installed 11.1 64 bit and have a 4850 card, installing the most recent driver (8.12 from the ATI site working fine on 11.0 64 bit) Everything seems fine until running the flgrx command. I can use the ATI configuration utility to set up my dual screens etc.
Continuing to google!
Cheers, Peter.

I had installed the Ati drivers (8.12) by running the installer.

Restarting brought me to a corrupt screen. I switched back to failsafe xorg.conf - did an uninstall of the ATI drivers.

Then I did a new install of 8.12 and ran aticonfig --initial.

Rebooted all seemed okay except fglrx gives me same errors as mentioned.

As soon as I get home from work I can continue troubleshooting.

Okay, so, after digging through the logs and checking what files are actually being loaded when X starts, I found that it is trying to load the 32-bit ATI driver. I have a working solution, though it is certainly not the prettiest solution, but it is only two commands.

First, remove/move the 32-bit driver. I used:

sudo mv /usr/lib/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so.bak

Second, copy or link the 32-bit driver file with the 64-bit driver file. I linked, but copy should work just as well. I used:

sudo ln -s /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so

I then restarted X and did an fglrxinfo and I get:

fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1950 Series
OpenGL version string: 2.1.8304 Release

Hope this helps the rest of you who have this problem.

Thanks SchroedingerHepcat !!
glxgears , fglrxinfo now works!

Yep, works for me now too. Thanks very much.
Cheers, Peter.:slight_smile:

Thumbs up, SchroedingerHepcat! With users like you, who needs Customer Support?lol!

It should use the radeon open source driver…

Do a:

su
#sax2 -r -m 0=radeon

Then save the configuration.

Thank you, SchroedingerHepcat! I used ati-driver-installer-8-12-x86.x86_64.run and this was failing for me as well. Your solution works.