ATI wrong resolution on second monitor

I recently installed Suse11.1_64 on a lenovo thinkpad W500.
This has a ATI Mobility FireGL 5700 (very much like a radeon HD3650)

After some fiddling I got the ATI driver to work on it, but now I can’t get the dual screen to work as I want;
I can’t get any resolution higher than 1024x768 on a second monitor.
The laptop screen always works fine in its 1920x1200 native resolution, but any second monitor I try has a maximum of 1024x768 !

I can get lower resolutions no problem, I can get it in clone mode, or as a separate X-screen or in Xinerama, but always with this low resolution (the monitor I tried with is 1920x1200)
In the catalyst control center I cannot do anything at all with the second monitor. In Sax2 I can set the monitor and resolution, but this is then ignored and it uses the 1024x768 anyway :frowning:
Tried fiddling with the xorg.conf according to several hints I found on the internet, but to no avail :frowning:

Anybody any ideas what is wrong here or what I might do to fix this ?

btw: In windows I can get the second monitor to do anything no problem…