ATI works in 64 bit -- doesn't work in 32 bit


I have openSUSE 11.1 installed in a multiboot configuration on my 64 bit computer. It’s installed twice. One installation is 64 bit. The other is 32 bit.

For both of them I have all the online updates installed. I have the ATI repository configured for both. I’ve installed the fglrxG01 RPMs for both, correctly matching the kernel as seen in “uname -r”.

The 64 bit install works fine. The 32 bit install boots to a black screen.

If I boot to runlevel 3 with the 32 bit O/S, I can run sax2. I’ve tried these:
sax2 -a
sax2 -r
sax2 -m 0=fglrx
sax2 -r -m 0=fglrx
They all bring me to a black screen where I have to pull the plug to get beyond it.
If I use the curses package manager (command = yast) to remove the fglrxG01 RPMs from the 32 bit install, then I get the GUI back with a simple run of “sax2”.

How can I get the ATI drivers to work for 32 bit?
Can I use a config file from the 64 bit install (which currently is working).


Too slow guys. And the answer is:

Boot to runlevel 3, login as root.
Run “yast” to get the curses? version of Yast.
Uninstall the fglrxG01 rpms.
Run sax2 in the full-screen console – get the vesa display – accept and save it.
Run startx and you’re in the GUI
Reinstall the fglrxG01 RPM’s
Open a console and run this command to couple the ATI config with the working vesa X11 config:

aticonfig --initial --input=/etc/X11/xorg.conf

Reboot and the low res screen that you coupled with aticonfig will let you into the login prompt as a normal user.
Reconfigure the graphics to the desired resolution

please mark this thread :SOLVED:


The ‘aticonfig --initial --input=/etc/X11/xorg.conf’ is mentioned in some of the other ati threads as well as in the release notes!
I had similar problems and decided to read the notes… this was the only real piece of useful info they contained.
I guess, we are all the same - we like to battle and then only when all else fails RTFM.:wink:

Not to worry, my nvidia card on opensuse M6, was worse to fix and get working properly. Which all shows, any card can give problems.

That’s right – rtfm. I found the magic command from running “aticonfig–help”

For other who cruise by, how to install ATI:

Run the whole install and Yast Online Update process without any ATI drivers, even if you have to run in a console at init 3 . You can install packages at init 3 by using the command “yast”. But all being well you can go to the end with vesa resolution.

Then add the Community ATI Repo
Then add the two fglrxG01 RPMs

Then open a console, su to root and run the command “aticonfig --initial --input=/etc/X11/xorg.conf”