ATI video card configuration problem, no xorg.conf file

Looks like my video card problems are due to a missing xorg.conf file.

From su terminal command
ls /etc/x11
ls: cannot access /etc/x11: No such file or director

How does one create an xorg.conf file?

Card = “ATI 7500 PCI” video card. (note: YaST probe indicates it is a Radeon LW).

The packages “ati-fglrxG01-kmp-default” and “x11-video-fglrxG01” are installed.


X11 (capital X) Linux is case sensitive

The 7500 card is not supported by the ATI proprietary driver, unfortunately. So you will have to make do with the stock radeon driver.

Thanks. It is a capital X.

What is the stock Radeon driver? Is this the default diver w/o 3-D support, or is there some kind of legacy driver that can be installed?

BTW: This forum rocks. Solid, courteous advice.

run sax2 accept configuration that should rewite your X11 files
then try aticonfig --initial

I had a Radeon 9250 a while back and went through all this already. I ran an older driver version that supported my card, but this driver would only work in OpenSuse 10.1, due to lack of compatibility with later versions of Xorg. I ran 10.1 for a while just so I would have 3d acceleration but it was not worth it, so I just decided to forgo 3d with my card.

Looking at the page with previous driver versions here:

Previous Radeon® Series/Motherboard/Notebook Display Drivers for Linux x86

It looks as though the 7500 was never supported, only the 8500 and up, and even then you’d have to run version 10.1 of OpenSuse in order to have a compatible version of Xorg that would let you install the driver.

As far as your question on the “radeon” driver, this is the one that gets installed by default when you install OpenSuse and the installer detects an ATI card. So if you have a working display, that would be the driver you’re already running right now.

Sometimes you can get some 3d acceleration with thew radeon driver, if you go to the terminal, type su, enter root password and then enter this command:

init 3

Then log in as root and run this command:

sax2 -r

If you go to “change settings” see if you can check the box that says “enable 3d acceleration”. If it’s grayed out, you’re out of luck. If not check the box, save your settings, exit, and when you get back to the terminal enter this command:


When you get back to the desktop, go to the terminal and check 3d acceleration by entering this command:


If you get errors, then 3d acceleration is not possible with your card, using any method I know of.

I must have an additional problem. Running sax2 -r crashes with the message
Died at /usr/share/sax/ line 653.

Given that release 11.1 is 2 weeks away, I’ll try to solve the problem after upgrading. Thanks to everyone for your help.

I tested this by removing my /etc/X11 folder and running sax2 that reinstalled my xorg.conf file but nothing else luckily I have tro partitions with 11.1 rc1 installed one with kde4.1xx
and another with kde 4.2 beta and was able to copy my X11 files. from one to the other

I just thought of something else. Maybe try running YAST and do a search for “radeon” to confirm you have the file, and then right click on it and select “update” and maybe the repos might have a newer version.

Also search for “X11” and make sure you have that installed.

One of these two methods might allow sax2 to then run without errors.