ATI RadeonHD 6310M - OpenSuse 11.4 ( Asus K43U Seris Laptop )


It has been a nightmare to get the ati radeon 6310m card to work properly on opensuse 11.4.

Historical Info:

  1. Got new laptop, installed opensuse 11.4 - all ok except noticed display is a little dull and that max resolution was only 1024 x 768.
  2. googled and saw lots of info ( scattered everywhere ) on installing ati drivers with opensuse. Finally settled on link ahown below;

SDB:ATI drivers - openSUSE , 1 added the repo from (as shown below )

Index of /mirror/ati/openSUSE_11.4

After the install of the proprieratary drivers ( 64 bit ) , the display was much sharper, i got a resolution of 1366 x 768 ( as shown in the asus laptop specs ) BUT I GOT A WATERMARK " AMD - UNSUPPORTED HARDWARE "

  1. After more googling, i ran "aticonfig --initial " but it said “NO SUPPORTED ADAPTERS DETECTED”.

  2. More googling brought me a script called ‘atiupgrade’ from user please_try_again

openSUSE Forums - ATI driver with atiupgrade, i got the latest version , v2.9,

ran it ( outside of X)

and still got “NO SUPPORTED ADAPTERS DETECTED”. But this is a radeonhd 6310m.

Any ideas on what to do?

oh yes, i forgot to add that my display had a watermark “AMD Unsuported Hardware”.

pls note that i do have X running, lspci -nnk shows that the fglrx drives is being used and i can get a resolution of 1366 x 768. The catalyst control center reports that i have a radeon hd 6300 series.

So the only bother for me now is this watermark “AMD UNSUPPORTED HARDWARE”
( I dont care about aticonfig complaining “NO SUPPORTED ADAPTERS DETECTED” )

The link here has some kind of fix;

::KaibaTheLegacy::: remove annoying amd unsupported hardware logo in Linux

[li][i]#[/i][/li][li][i]# copy from here[/i][/li][li] [/li][li][i]#!/bin/sh[/i][/li][li]DRIVER=[b]/[/b]usr[b]/[/b]lib[b]/[/b]fglrx[b]/[/b]xorg[b]/[/b]modules[b]/[/b]drivers[b]/[/b][/li][li][b]for[/b] x [b]in[/b] $[b]([/b]objdump -d $DRIVER[b]|[/b][b]awk[/b] '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'[b])[/b]; [b]do[/b][/li][li] [b]sed[/b] -i "s/[COLOR=#007800]$x/\x90\x90\x90\x90\x90/g" $DRIVER[/li][li][b]done[/b][/li][li] [/li][li][i]# to here[/i][/li][li] [/li][li][i]# exit and type[/i][/li][li] [/li][li][b]chmod[/b] +x[/li][li] [/li][li][i]# Then type[/i][/li][li] [/li][li][b]sudo[/b] [b]sh[/b][/li][li] [/li][li][i]# Log out and back in. Ta da![/i][/li][/ol]

Is there any guru here who can take a look at this fix within the opensuse 11.4 context ?

On 10/21/2011 11:06 AM, MarcoMeswara wrote:
> Is there any guru here who can take a look at this fix within the
> opensuse 11.4 context ?

i recommend you wait for please_try_again to drive by…
(or anyone else with over (say) a thousand or so posts here who claims
to know–not me)…

i’m not certain what time zone he operates in, you might PM him and ask
that he look in on

and, if i were you i’d hold off on experiments while waiting…

openSUSE®, the “German Automobiles” of operating systems

Sound advice DenverD.

  1. Will hold of experimenting.
  2. PMing - some users get pissed off when we ask for help directly. Is user ‘please_try_again’ on the friendlier side of things?

On 10/21/2011 11:56 AM, MarcoMeswara wrote:

> 2. PMing - some users get pissed off when we ask for help directly. Is
> user ‘please_try_again’ on the friendlier side of things?

do not ask him to help you off line, in PM…just bring this thread to
his attention and ask him to look in…

if he can be, he is usually very knowledgeable/helpful…

[if he gets mad tell me and i’ll beat him with a wet noodle…]

openSUSE®, the “German Automobiles” of operating systems

The packages in this repo are the same as the ones created by atiupgrade. Installing the latest driver from this repo or running atiupgrade are two ways of doing the same thing.

See my answer here: Upgrading ATI driver with atiupgrade - Page 9

It should have told you that the latest version of the driver was already installed.

I don’t know this specific card, but

  • if it’s not the most recent model
  • and fglrx is loaded:
lsmod | grep fglrx
  • and it is not an older version of the driver loaded from initrd
  • and you see the watermark however everything looks fine…

it might just be a bug in the driver. Otherwise, either the card is too new or the driver too old.

User please_try-again;

  1. The card is a November 2010 issue - as shown by wikipedia.

  2. Will try the nomodeset option from the other thread you commented on.

  3. What about the fix shown in post #2

::KaibaTheLegacy::: remove annoying amd unsupported hardware logo in Linux](

The code posted there is not going to work because is located somewhere else (and it varies on 32 and 64bit systems). Here’s a code that would patch the file (and be faster), but I have no idea if it will remove the watermark (not having this problem).

#! /bin/bash
DRIVER=$(find /usr/lib*/xorg/modules/drivers -name "" | head -1)
SEDCMD=$(objdump -d $DRIVER | awk '/call/&&/EnableLogo/ {printf "s|\\x%s\\x%s\\x%s\\x%s\\x%s|\\x90\\x90\\x90\\x90\\x90|;", $2, $3, $4, $5, $6}')
cp $DRIVER{,.org}
sed -i "$SEDCMD" ${DRIVER}

You can try it if nothing else helps, but make sure that you have the latest driver before.
Please report if it works (will probably post this hack in the HowTo forum if it does).

If it screws up the driver, use the code below to restore the original one:

#! /bin/bash
DRIVER=$(find /usr/lib*/xorg/modules/drivers -name "" | head -1)

  • You’ll do all this as root of course.

the nomodeset option in the boot options did not do it. the watermark still remained after rebooting.

trying the fix now.


#! /bin/bash
DRIVER=$(find /usr/lib*/xorg/modules/drivers -name "" | head -1)
SEDCMD=$(objdump -d $DRIVER | awk '/call/&&/EnableLogo/ {printf "s|\\x%s\\x%s\\x%s\\x%s\\x%s|\\x90\\x90\\x90\\x90\\x90|;", $2, $3, $4, $5, $6}')
cp $DRIVER{,.org}
sed -i "$SEDCMD" ${DRIVER}

Thanx a million please_try-again.

i have also given yr patch to ::KaibaTheLegacy::: remove annoying amd unsupported hardware logo in Linux](

I, too, would like to express my heartfelt thanks to please_try_again. I used the YAST method to upgrade the driver, but this was before changing the graphics card. A kernel panic occurred precisely at the moment the driver installation was complete, but YAST had not yet quite finished. Had the card exchanged for a Radeon 7870, also a new power unit (previous was too weak). The system booted up, no problem, but flgrx could not be rebuilt (‘failed’). No 3D effects possible, and, as an interesting side-effect, could not play either DVD or MPEG4 videos on anything! Re-installed the driver, this time YAST could finish: brilliant! But that AMD watermark… well, I tried the fix on the previous page and now everything is happy in the garden. It all works brilliantly. :slight_smile:
System info: OpenSuse 12.2, Linux 3.4.47-2.38-desktop x86_64, KDE 4.8.5 (4.8.5) “release 2” desktop, graphics card as above, AMD Athlon™ 64 X2 Dual Core Processor 5200+.

Probably this is not very helpful, but just in case!