Ati radeon xpress 200m "Finally Works" opensuse 11

[size=]I have used opensuse since 10.1 and the xpress 200m has never work before this on my laptop. In celebration I fixed three other systems running Linux with the xpress 200m and all have worked fine. (1 E-machine, 2 HP’s, and a Gateway)

on a fresh install make sure you have the fglrx kernel drivers by searching for them in “install software”.

once you have found them simply follow these instructions

open a terminal and enter[/size]r

init 3

this will shutdown the X server

Next login as root and the enter this command

sax2 -r -m 0=fglrx

Adjust the screen settings as desired, and after you’re finished type

init 5

This restarts the x server and desktop.

If after you have done this and you are unable to start your graphical desktop here are two possible fixes.

login and enter on the command line:


This will allow sax to choose what ever driver it wants.

sax2 -r -m 0=radeon

This command will return the open source ATI Driver to use.

Note: The e-machine required me to run Sax2 on the command line once after restarting. (KDE wouldn’t launch until this was done)

All 4 Systems worked with 3D games as well as desktop effects (compiz fuzion).

The driver present on a fresh install should be the 8.49 edition of the ATI Closed Source Driver. I have not tried the 8.6 yet on any system, please let me know if it works better. As I have heard that their could be an issue with it with regards to the xpress 200m and other old cards.

The Day’s of wishing you could be cool like the other Linux Desktop Effects users are over.


I have encountered one issue across all 4 systems a crash when you close the screen, lock the system, or allow the screen saver lock to engage.

The Work around I have found to work is simple.

  1. Turn off the screen saver lock
  2. Turn off all the lock setting under KPowersave

I believe the last is the most important

After doing this you can manually lock the screen without a crash.

This issue didn’t show up until I activated the Closed Source ATI Driver.

While I have not Experienced a Crash in several weeks I would like to submit a bug report.

Does Anyone know which log to look in for the crash details?

I’ve searched for fglrx but it can’t find any packages someone know why?

Everything seems to work fine now, thanks for this great mini-tutorial!