ATI Radeon Xpress 1150 on openSUSE 11.1

Hi

I’ve been using openSUSE 11.0 for a long time, and recently I finally switched to 11.1.

I have an HP Compaq nx6325 with ATI Radeon Xpress 1150.
I used this tutorial for 11.0 and it worked fine, but now when I try to do the same I get a black screen and a system freeze after executing this line: sax2 -r -m 0=radeon

Besides after switching back to the old xorg.conf I’m no more able to run any of the glx programs (glxgears or glxinfo). This is the message I get:


X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

Is there any painless way to get my graphics card working?

zajcew adjusted his/her AFB on Saturday 09 May 2009 23:26 to write:

>
> Hi
>
> I’ve been using openSUSE 11.0 for a long time, and recently I finally
> switched to 11.1.
>
> I have an HP Compaq nx6325 with ATI Radeon Xpress 1150.
> I used ‘this’ (http://en.opensuse.org/ATI_Radeon_Xpress) tutorial for
> 11.0 and it worked fine, but now when I try to do the same I get a black
> screen and a system freeze after executing this line: sax2 -r -m
> 0=radeon

Instead of the 0=radeon option have you tried using the 0=vesa if I read the
howto right you

mv the old xorg.conf to a backup then create a fresh one with the:

sax2 -r -m 0=radeon

which could be causing probs because ( correct me if I am wrong, I only use
the prop drivers ) when you install the fglrx stuff it deletes the installed
mesa and installs its own which might not work with radeon driver???

so try the vesa option, might still not work though :slight_smile:

or instead of moving just make a copy of the original xorg.conf and go
straight to the sax2 -r -m 0=fglrx

stage and see if that generates a working xorg.conf.

as stated I only ever use the propriety modules from AMD/ATI direct and have
no experience with the one-click jobby so do backup the xorg so you can get
back which will mean you will have to uninstall the ATI kernel modules et al
that Yast has put on, no biggy just use the ncurses version of YaST

HTH


Mark

Nullus in verba
Nil illigitimi carborundum

0=vesa - system freezes

sax2 -r -m 0=fglrx alone does nothing - still no 3D support

I tried installing ATI proprietary drivers, but no success so far - maybe I’m doing something wrong. I generated the rpm package, installed it and ran sax2 -r -m 0=fglrx. Do I have to do anything else?

zajcew adjusted his/her AFB on Sunday 10 May 2009 11:16 to write:

>
> 0=vesa - system freezes
>
> sax2 -r -m 0=fglrx alone does nothing - still no 3D support
>
> I tried installing ATI proprietary drivers, but no success so far -
> maybe I’m doing something wrong. I generated the rpm package, installed
> it and ran sax2 -r -m 0=fglrx. Do I have to do anything else?
>
>

When using the propriety drivers you do not use sax, after you have
d/loaded and compiled the drivers and there are no errors while doing it.

(I do not use the rpm method I just let the installer run through and
install the modules itself)

I then just run:

aticonfig --initial

This will make you a new xorg.conf you then just need to start up X either
by going to run-level 5:

init 5

do not use sax as it will not work and can cause probs, when you get to a
GUI ( KDE, gnome etc…) you can open a console and run:

amdcccle

Which will give you a nice catalyst GUI for configuring the card.

If you get any errors during the aticonfig --initial about the xorg.conf
file then go to /etc/X11/ there should be a backup xorg.conf with a .install
or other type of comment which will be a back-up, just rename that to plain
old xorg.conf and try again.

HTH

Mark

Nullus in verba
Nil illigitimi carborundum