ATI radeon problems

Hello

I have just bought a Dell Inspiron 5010 laptop with an ATI Radeon hd 4250 graphics card. I have Opensuse 11.4 installed and tried to install the fglrx drivers with no success. I’ve followed the instructions on SDB:ATI drivers - openSUSE. I also tried the ati_driver_installer with similar failure.

after the install I can only get a text screen with errors (below) during boot up and the fglrx module isn’t being built, this then happens during the reboot after install.

fglrx: no matching device section for instance (busID PCI:0@0:17:0) found
FATAL: Module fglrx not found

Then it goes on to say that xinit failed etc. Other errors are:

xinit failed. /usr/bin/Xorg is not setuid
if so either use a display manager (strongly recommended) or adjust /etc/permissions.local

Other problems which may be relevant are, I have to type “nomodeset irqpoll” to get into the GUI. I also am not able to revert to the old drivers when fglrx stuffs up. even when I follow the instructions it still tries to load the fglrx drivers.

Is there any way to get 3D accelleration with this card because the 2D display is c**p.

Thanks for any help.

First on the wiki page, it seems some important instructions get ride off.
Before trying to install the fglrx module, you have to ride off radeon.

Boot with adding to the grub line : nomodeset blacklist=radeon 3
then you finish in level 3, console mode.

the second point is to remove the radeon kms module if loaded
lsmod | grep radeon
should return nothing, if it return something edit /etc/sysconfig/kernel and setup the NOKMS according to your openSUSE version

Then installing the fglrx should goes easy.

ps : the new Catalyst 11.8 are just published now.

Probably because you did not remove the rpms from the failed fglrx install and if you created any fglrx configuration to X files you forgot to restore those.

Thank you both for your replies.

Do I remove the radeon kms module from the command line before running the install script?

Should the fglrx module be made before reboot and can I check it it’s there?

When everything wrong and I tried to get back to the radeon driver I did “rm /etc/modprobe.d/fglrx.conf” this returned that there was no such file or directory, so I assume this one wasn’t made either during the install.

rm /etc/X11/xorg.conf was ok and so was modprobe radeon

oldcpu what rpms do I need to remove and how? also what files do I need to restore and how?

In the readme for the ATI Catalyst driver I noticed that it requires XFree86-Mesa-libGL this won’t install because of dependencies and also XFree86-libs which I can’t find and isn’t in any opensuse repositories, any ideas where to get them etc.

Typically the proprietary AMD Catalyst driver is referred to as the fglrx driver. Check what is the output of typing:


rpm -qa '*fglrx*'

and that may tell you if you have the proprietary AMD graphic video driver installed. Also check to see if there is any custom /etc/X11/xorg.conf file created by running an ATI/AMD configuration program.