ATI Radeon Mobility X1400 and choppy video

I’m running openSUSE 11.2 on my Dell Inspiron e1505 laptop. Everything works well and the default driver that installed seems to be working fine until I try to play a video on full screen.

This is most frequently noticed when maximizing a YouTube video. The video is choppy and the whole system starts to lag. Returning the video to the smaller, standard size fixes the lag and choppiness.

I’ve read elsewhere on the web that installing the ATI driver probably won’t help since the driver that installed by default is just as good. What do you think? I’d rather not deal with changing out my display driver if it’s not going to help.

Here’s my specs:

Intel CPU T2400 @ 1.83GHz
1GB RAM
ATI Radeon Mobility X1400
1680x1050 @ 60.1 Hz

What driver are you using? VESA ? Radeon ? Radeonhd ?

Go to /var/log/Xorg.0.log and open it with a text editor, and look for entries like (==) VESA or () VESA or (==)ATI or (ATI) or (==)Radeon or ()Radeon or (==)Radeonhd or ()Radeonhd so we can tell if your PC has a VESA, Radeon, or Radeonhd driver in use.

Reference your PC’s hardware, I can’t tell if the X1400 is a legacy driver. When I check the ATI web site for the X1400 is sends me to this link: ATI Catalyst™ Proprietary Display Driver suggesting it is a designated legacy product, but I don’t see it in the list.

I do note a number of openSUSE users have complained that the radeon and radeonhd drivers that come with openSUSE-11.2 (in rpms xorg-x11-driver-video and xorg-x11-driver-video-radeonhd) are lacking. (Note I tried to document some practical theory reference video drivers and their packaging for openSUSE here: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums ). If you know noithing about video drivers for openSUSE, I recommend you look thru that link for the ATI. Its not too long.

If you are willing to take a chance, you could try the latest very cutting edge open source drivers unofficially packaged for openSUSE for ATI hardware. ie … some openSUSE-11.2 users with “legacy” ATI hardware have found they get better behaviour on openSUSE-11.2 from the open source radeon and radeonhd drivers if they use the updates from the X11 : XOrg repository. That repository is here:

http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.2/

… and the rpms that some of us found gave better behaviour are these apps:

  • mesa
  • xorg-x11-driver-input
  • xorg-x11-driver-video
  • xorg-x11-driver-video-radeonhd
    and possibly ( ? ) others for a 64-bit openSUSE ? … (I tried them on a 32-bit PC). One caution - that tends to be a cutting edge repository, so there is always a risk it will make things worse when a cutting edge release has a bug.

Also, note, because that repository is so cutting edge, I recommend it be added, the rpms installed, and the repository removed. Do NOT leave that repository enabled 1 update longer than necessary.

If you need any guidance on how to add respositories or install rpms via yast please advise.

I checked the log and while VESA, ATI, and Radeonhd are all mentioned, Radeonhd seems to be listed far more than the others.

Not sure what all you’re looking for. I listed the key specs in my previous post. I found this if it helps:

28: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1002_7145
  Unique ID: VCu0.IhkYiOfJwr0
  Parent ID: vSkL.rxAOeWuq8i6
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "ATI Radeon Mobility X1400"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x7145 "Radeon Mobility X1400"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x2003 
  Memory Range: 0xd0000000-0xdfffffff (rw,prefetchable)
  I/O Ports: 0xee00-0xeeff (rw)
  Memory Range: 0xefdf0000-0xefdfffff (rw,non-prefetchable)
  Memory Range: 0xefd00000-0xefd1ffff (ro,prefetchable,disabled)
  IRQ: 16 (737653 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d00007145sv00001028sd00002003bc03sc00i00"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

I’ll check it out.

I added this repository and looked for these packages only to discover they are already installed. I didn’t previously have that repository added so I’m not sure where the packages came from.

I read through the practical theory guide you put together and it seems the driver I want is radeonhd. I’d like fglrx but I can’t tell if my hardware is supported or not. I also can’t tell for sure if radeonhd is what I currently have installed.

Maybe the problem isn’t the driver at all? Could something else be causing the lag and choppiness associated with watching a fullscreen youtube video?

Check the versions. I believe you made a mistake here.

Look again, and be very careful. Check the versions. OK ?

If you need help on using YaST > Software > Software Management in how to install applications, please advise. Clearly you mistook an indication that the applications were already installed (but an older version) and did not realize that you need to look deeper to see that the new versions are NOT installed.

Again, post here if you need help.

Note starting tomorrow, I will be away for 2 weeks and will likely have no access to the forum.

You are right. I looked under the versions tab and found that the newer versions were available. So I upgrade all four packages to the versions from the repository you suggested and restarted the computer.

I played a couple of videos on full screen and it is MUCH better. I wouldn’t say it’s perfect, but at least tolerable now and the system lag is only barely noticeable.

I would consider this issue resolved. Thank you for the help.:slight_smile:

Glad to read its working better, and thank you for sharing your solution.

With ATI stopping their support for legacy hardware (by their definition) it makes obtain similar behaviour now, to what we saw in the past, a bit more difficult for ATI graphic hardware users.

Apologies if my above post was a bit blunt. I’m struggling with a head cold, and I am not looking forward to my business trip in the next few days (I’m currently in the middle of packing for the trip).

No worries. I’m not that sensitive.

Have a good trip.