ATI Radeon driver blown away!

I hope someone can help…

Following some annoying flickering effects with my graphics card which seemed to co-incide with a kernel update, I tried updating the ATI FGLRX driver I was using from the one-click install… bad idea!! (isn’t hindsight wonderful! :shame:)

This broke everything. Leaving me only with command line.

As I’d read that FGLRX is now obsolete I tried the open RADEON driver, but couldn’t get that to work either. Just black screen all the time. The instructions for RADEON include a comprehensive exorcism of FGLRX from the machine and I can’t now go back to FGLRX as the ATI repository is broken and there isn’t a mirror that I can find.

In the end I tried downloading ati-driver-installer-10-2-x86_64.run from AMD/ATI
This gets most of the way through compiling but then goes beserk, screws up the display and deletes everything it tried to create. I can’t see any missing dependencies, BUT it does say you should have certain XFree86 packages – but these aren’t supported by Suse? and I can’t find any RPMs. Anyone know how to fix this? This might be my only hope? Alternatively I’ll have to find a solution for the Radeon driver - but I’m still not 100% convinced it supports my GPU.

I seem to have a read a ton of confusing/outdated/not-quite-relevant web pages and am now out of ideas and sleep. (hell - it wasn’t this hard with NVidia!)

setup is:

Radeon 2100 (RS740 796E)
kernel 2.6.27.45-0.1-default
arch: x86_64 dual core in acer aspire
OpenSuse 11.1, KDE 3.5

Here is a fairly current practical theory guide for ATI drivers so that you can understand better your options and understand better the recommendations that may be given to you. In particular please pay attention to post#1 and post#11 in this link: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Note while sorting any difficult with the fglrx and radeon and radeonhd drivers, you can always fall back upon the vesa or if worst comes to worst, the fbdev drivers (as a very short interim).

OK thanks, getting anything working now is the priority - I’ll post back after I’ve read your links and tried it tonight.

al1ster wrote:
> I tried updating the ATI FGLRX driver I was using from the
> one-click install… bad idea!! (isn’t hindsight wonderful!

if i were King i would banish one-click installs from my
kingdom…sure they are ‘easy’…in fact they are the easiest way i
know to murder a Linux system…

i have a feeling they were invented by someone who wished ill will on
ye olde Linux…


palladium

With respect to kernel updates impacting an ATI proprietary graphic driver, given that I always install the proprietary ATI graphic driver “the hardway” (which is not hard), what I typically do with a kernel update is the following (in order):

  • backup my /boot/grub/menu.lst file BEFORE installing the new kernel
  • ensure I have the ATI proprietary “.run” file ON my PC BEFORE installing the new kernel
  • install the new kernel, including kernel-source and kernel-syms of the IDENTICAL version of the new kernel,
  • BEFORE rebooting with the new kernel, check the newly updated /boot/grub/menu.lst and compare it to the backed up menu.lst and ensure it makes sence (this can be screwed up for systems with complex boot partitions as the kernel rpm installer can not always guess what to write to grub in all situations - especially those where users have a complex boot setup)
  • reboot direct to run level 3 (sometimes I boot to run level 5 just to prove its broken, but thats a masochistic approach - normally I just accept it will be broke and go direct to run level 3)
  • in run level 3 uninstall any exisiting fglrx rpm. For example:
rpm -e $(rpm -qa '*fglrx*')  
  • in run level 3 move the exisiting /etc/X11/xorg.conf to some name (such as /etc/X11/xorg.conf.oldcpubackup). For example:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.oldcpubackup  

Note this is “just” me and this step is likely not necessary.
.

  • build the new fglrx rpm by running the proprietary ATI .run script with the appropriate argument. For example on a 64-bit openSUSE-11.2:
run sh ati*.run --buildpkg SuSE/SUSE112-AMD64  
  • install the newly built fglrx rpm. For example:
rpm -Uvh fgl*.rpm   
  • run the ATI config program to create a new /etc/X11/xorg.conf . ie something like:
aticonfig --initial 

.

  • reboot via “shutdown -r now” to X window

… again, there is some practical theory guidance here for any onlookers to this thread who are baffled by the above: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Thanks for the very clear instructions - they deserve posting on the Suse wiki sometime!. But unfortunately, the RADEONHD route hasn’t worked for me yet. :frowning: For the record, symptoms are as follows:

installed versions of packages:
xorg-x11-driver-video-radeonhd: 1.3.0_20100216_79a0ab2
sax2: 8.1-542.11.1
xorg-x11: 7.4-8.20.1
xorg-x11-driver-video: 7.4-19.8.2
xorg-x11-server: 7.4-17.6.1

I even removed and re-installed the radeonhd package to make sure it was the right version from the right repo and all the files were “new”

the following then occurs

> sax -p
Chip: 0 is -> ATI ATI Radeon 2100 RS740     01:05:0 0x796e AGP radeonhd

>sax2 -r -m 0=radeonhd

SaX initializing please wait ...
SaX your current configuration will not be read in

SaX access to your display is denied

SaX something went wrong while X was called with -probeonly
SaX try to call 'sax2 -p' and select a single device?
abort

this sometimes then stops with a giant X cursor (which moves) on a black background. Nothing else works and I have to <ctrl><alt><f4> back to command line.

Q) I wonder if this is the wrong driver for this chip? IMHO the X.org wiki is not very clear on this.

Q) I also wonder if there any 32 bit versions of packages that are needed in parallel to the 64 bit ones? (or conversely, any that must be avoided?)

In the meantime, I’ll try compiling the ATI driver again…

some more info:

ATI driver compile still bombs-out shortly after the stage where it is “postprocessing kernel module”, but its too quick to read and I havn’t yet found a log file from it.

trying to run SAX2 with vesa also fails with black screen (no cursor).
However in the tail of the log file it says
“fatal server error - no screens found”

higher up it also reports Warning couldn’t open module vesa (module does not exist, 0)!
any idea whats going on? I’m really stuck now… (ATI repo still broken too)

… ok … I confess in my previous post I had thought you were trying to install the proprietary fglrx driver. But I see now you want to try the radeonhd driver. OK, we can do that. :slight_smile:

Did you read my post above, where I referenced this link:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums and recommend you read post#11 in that link ??

The radeonhd is buggy and post #11 has the fix to that.

I see from your post, where you do not mention your PCs Mesa version, nor do you mention all the xorg-x11-driver rpms that should be updated, that I think you did not read post #11 ??

Anyway, please follow the advice in that link, in post #11. If you have trouble understanding that post, please advise.

If you elect to always go you own way, and not follow advice, you WILL undoubtedly learn a LOT more. However it will take longer and possibly be more painful for you. Hang in there. You just need to follow some advice and you will be there.

Ensure you remove the fglrx rpm after every failed proprietary driver attempt.

ok … some comments here …

1st - do you have a digital camera with a video mode? If so, its very easy to take a video when one encounters a problem that is repetitive, then play back in slow motion and read the errors

2nd - there are lots of log files :slight_smile: … for example "/var/log/Xorg.0.log , and /var/log/messages , and upon boot there is “dmesg” which can be put into a text file (preferably immediately after boot) as a regular user with “dmesg > dmesg.txt”. Please do NOT post output here of such files. Post on http://pastebin.be instead, and press dump on that site, followed by posting the URL here. Just the URLs.

When graphics fails during an install, I am often immediately suspicious of a user’s rpms. What is the output of:

rpm -qa '*kernel*'
rpm -qa '*Mesa*'
rpm -qa '*driver*'
zypper search -t pattern | grep 'Base Development'
uname -a

I recommend you copy and paste those commands if you can (it may be hard with no gui) :slight_smile:

Note - Linux is case sensitive.

OK, I’ve been busy, but no joy yet.

My suspicion is also on the RPMs, (I notice that mesa is version 7.7.99-12.1, but I’m having trouble replacing it with commandline yast2 - it stays with this version, trying to delete it (prior to replace with alternative) will change the architecture of many things and I wonder if they’ll get permanently messed up?

Yes, I did read #11, but didn’t immediately connect it with my situation as I’m on Suse 11.1 not 11.2 and wasn’t particularly trying to add a “bleeding edge” version, just one that might match my kernel…

Anyhow, let try and be methodical. Your questions on RPM versions etc:


> rpm -qa '*kernel*'
kernel-syms-2.6.27.45-0.1.1
kernel-default-base-2.6.27.45-0.1.1
kernel-source-2.6.27.45-0.1.1
linux-kernel-headers-2.6.27-2.28
kernel-default-extra-2.6.27.45-0.1.1

> rpm -qa '*Mesa*'
Mesa-7.7.99-12.1
MesaGLw-7.2-1.30

> rpm -qa '*driver*'
xorg-x11-driver-video-7.4.-19.8.2
xorg-x11-driver-input-7.4-11.6.1
xorg-x11-driver-video-unichrome-20091117-1.6
xorg-x11-driver-video-radeonhd-1.3.0_20100216_79a0ab2-3.1

> zypper search -t pattern | grep 'Base Development'
| devel_basis           | Base Development                                        | pattern

> uname -a
Linux linux-acer 2.6.27.45-0.1-default #1 SMP 2010-02-22 16:49:47 +0100 x86_64 x86_64 x86_64

my only other thought - do I need the 32 bit version of Mesa as well? - I’ll try it - nothing ot lose!

and finally - no FGLRXs to remove - it failed to compile every time…

more info - finally managed to trick yast2 into changing the version of Mesa from 7.7.99-12.1 to 7.2-10.3.6

also added Mesa-32bit, version 7.2-10.3.6

made no difference to result of:
sax2 -r -m 0=radeonhd

I also thought about trying Repair with the install dvd - but it doesn’t have an option for repairing graphics as far as I can tell.
NB - the “live” CD works OK…any way of pulling the graphics from this?

Good point. I missed your note in the bottom of your 1st post that you were on 11.1.

Yes. That will be exactly what your install had.

simply put in the liveCD and roll back to those versions of Xorg-x11-drive and those versions of Mesa.

The functionality is there in 11.1.

I do NOT have immediate access to an 11.1 install, so I can not hold your hand and walk you through this, but 11.1 does provide that capability in YaST.

still no joy! and I’m getting desparate to get at my PC.

reverting back to any/all combinations of 64bit RPMs makes no difference until the version is the one on the distribution disk - when it causes the whole PC to crash and sometimes reboot. Its always the black-screen-of-death! Nothing gets written to xorg.conf.

Its the SAME story for vesa as for radeonhd.

I also tried removing the xorg.conf to force a re-build of file, but it didn’t work, nothing gets written. I also tried various versions of SAX2.

Looking in the logs - the only error I can find is “GLX error Can not get required symbols”, but I have no idea if this is important or just one of those things that gets glossed over.

I recall from installing SUSE11.1 that the only driver that worked for me was FGLRX. Unfortunately th d*** repository is still broken - does anyone know whats going on? mirrored content on other repos is also broken as far as I can see.

Is there anywhere I can get the intact RPMs?

I think the reason the live-CD works is that it is not 64 bit.

The only solution I can think of now - is a new non-ATI graphics card!

Unless one of you has a bright idea??

Just install the fglrx the hardway (which is not hard).

Its easy.

so far its crashed every time and failed to create anything. There are no logs in /var/log, but I’ll try again and have a look around.

Lets see what you are starting with first.

Whats the output of:

rpm -qa '*glrx*'
rpm -qa '*Mesa*'
rpm -qa '*driver*'
rpm -qa '*kernel*'

Have you downloaded the ATI .run file yet? and if you have, what is it called? Include the full name so we can check versions … etc …

Have you installed the openSUSE YaST software pattern ‘base development’ ?

I know you gave that before, but have you changed it since ? I think you rolled back. If so, post the changes.

Also, what is output of:

zypper lr -d 

Thanks for coming back -

I rolled stuff back and then forwards again, but not quite to the absolute latest on the driver, so here are the current versions (all x86_64 versions of course):

Mesa 7.2-10.3.6
Mesa-32bit 7.2-10.3.6 (which I added in case it helps)
MesaGLw 7.2-1.30 (also added on the offchance it might help)

no *glrx packages - can’t download them with yast.

xorg-x11-driver-input 7.4-11.6.1
xorg-x11-driver-video 7.4-19.8.2
xorg-x11-driver-video-32bit 7.4-19.8.2
xorg-x11-driver-video-radeonhd1.2.4_121202_4e89726-2.1.1
xorg-x11-driver-video-unichrome 20080807-12.47

I can’t find how to check “software patterns” with the blue screen version of yast, maybe its hidden in a menu I havn’t found? But probably I’m missing something in the “development” area as I’ve not used this PC for compiles before. I tried checking things mentioned in the ATI docs for the driver, but got stuck at the lack of XFree86 packages.

I cannot manually copy across the output of ‘zypper lr -d’ its too much, but my enabled online repositories are:

Index of /update/11.1
Index of /distribution/11.1/repo/oss
Index of /packman/suse/11.1
http://www2.ati.com/suse/11.1
Index of /repositories/X11:/Drivers:/Video/openSUSE_11.1
Index of /distribution/11.1/repo/non-oss
Index of /distribution/11.1/repo/non-oss

oops forgot details of the ATI file:

ati-driver-installer-10-2-x86.x86_64.run

too much ??? This does not inspire confidence. What exactly have you installed from these too many online repositories?

I make no secret of the fact that I am on the record in likely over 100 posts on this forum telling users ONLY the following repositories: OSS, Non-OSS, Update (which are the official) and one and ONLY one non-official which is Packman. No others. IMHO if you can’t point to what you have updated from the “too much” then there is a good chance you messed something up real good.

If ATI does not work for you, then remove it. Really. Remove it. You can add later if you learn it works. Same as X11. Remove it. No point in keeping it now and you just risk install an incompatible rpm. So remove it. And after it is removed, check to ensure you have NO RPMS from it. That is what rolling back is all about.

Why have two non-OSS? What is that supposed to achieve? … anyway, its a non-sequitur.

Reference not being able to find the pattern “base development”. Its in YaST. Its not that difficult. Please go again and LOOK. Its not that hard.

How about the ATI .run file? What .run file did you download from ATI to install as a proprietary driver ?

How about the output of:

rpm -qa '*kernel*'

Is that the same as before ?