ATI Radeon 5470 Driver OpenSUSE 11.3

Anybody have luck To install ATI driver with OpenSUSE 11.3
My laptop is ASUS K42Jr
I tried but no luck and the screen is crash everytime i reboot

Somebody please help , before i’m using Ubuntu 10.04 is working and compiz also work nicely

Thanks in advance

I think there are problems with the latest Kernel and ATI not updating their drivers in time. I installed 11.3 but did not update the kernel and the default driver on my HP dv7t laptop (ATI 56xx video card) seems to work fine. But there are three option - download and install the latest driver (like you did ) - but i couldn’t get that to run correctly. There is also the ATI repo for OpenSUSE 11.3, but that doesn’t seem to work either with the latest Kernel for 11.3. I have not tried the jenglh repository, which also has an ATI driver .rpm file.

Also, try booting into FailSafe mode, then from a konsole, become root user (i.e., using su) then run aticonfig --initial -f
That might fix the problem, or else you might have to do mv /etc/X11/xorg.conf /etc/X11/xorg.conf.busted followed by mv /etc/X11/xorg.conf.install /etc/X11/xorg.conf first.

Follow this guide here:
openSUSE Lizards » ATI HD57xxx fglrx drivers under 11.3

I did this for my laptop with a HD4570. Basically you can boot into failsafe then follow the guide