ATI Radeon 3650 - can not boot (into liveCD) - version 11.4 KDE


I can not porpperly boot into live CD. I get the option menu in beginning and when i select the liveCD option it starts loading the kernel and then screen gets garbled. full of very small dots. Its liek the graphics card is not recognised propperly.

I’ve read about similar issue here: ATI Radeon HD 3650 AGP boot problem

but as i see the user’s specific problem in taht thread was caused by having an AGP card and on an older version. however my card is PCI. it should boot normally. i haven’t tried nomodeset parameter mentioned in that thread, but the card shouldn’t need it anyway. what could be the problem?

Should i use a liveDVD?

EDIT - also i am using a desktop (so no mobility GPU and such…)

Try nomodeset

There is no live DVD
Only an Install DVD

nomodeset worked. tough the picture was a bit off to the left. still it wasn’t too bad so i can try it out.

It seems this nomodeset was a bug in RC and wasn’t fixed in the final version (unless these are some bleeding edge opensource drivers…). I have 2 *ubuntu computers, one of them is using KDE. so i wondered how OpenSUSE did it. And it really is fantastic. I mean it’s really easy for the user to find what they need. so good job.

just fix this nomodeset. it shouldn’t be necesasary for these newer ATI cards. I’ve tried many live CDs and none of them so far needed it. :slight_smile:

Yes, the need to have to use ‘nomodeset’ in openSUSE-11.4 with Radeon hardware was to address a bug that crept in during the final RC versions of 11.4. I wrote a bug report on this (as my Dell Studio 1537 laptop’s Radeon HD3450 hardware was thusly impacted).

By using ‘nomdeset’ on openSUSE-11.4 default boot you are by default using the ‘radeonhd’ graphic driver which is not as supported as the ‘radeon’ graphic driver. What you can do, from the liveCD as an interesting test, is boot the liveCD (with the boot code ‘nomodeset’).

Once in the GUI with X running, open a terminal and type ‘su’ (use ‘enter’ for the password) and type ‘init 3’. That will push the liveCD back to run level 3 (a full screen text mode).

Log in as user ‘linux’ and again use ‘enter’ as the password.

Then go to /etc/X11/xorg.conf.d/50-device.conf file, and remove the ‘#’ from in front of the line " #Driver “radeon” " and save that change. You will need to do that change with root permissions. I typically install the program ‘mc’ (midnight commander) into memory on the PC running the liveCD, as running ‘mc’ in text mode gives one a menu driven text editor that works great in full screen.

Then once the change has been made/saved to /etc/X11/xorg.conf.d/50-device.conf (which of course is a change in RAM) then exit your editor and with root permissions type ‘init 5’ and that should restart X with the ‘radeon’ graphic driver that you will find has superior performance to the ‘radeonhd’ driver.

For long duration testing with a liveCD, I have even installed (into RAM) the proprietary Catalyst driver which gives great performance (relative to the radeon and radeonhd drivers). Of course once one turns the PC off then all is lost (since one is operating out of RAM in a liveCD).

Ah now it makes sense. So nomodeset is actually there to avoid a bug.

Well i don’t have much time to tinker arround lately, so i hope i get some free time later on my hands. I have actually never tried to download porprietary drivers. So maybe i should give those a go. I have a boradband internet connection so it shouldn’t be a big issue to download them and actually try them out. I am also thinking of getting a LiveUSB which should increase the response time.

My concern was only because my other computer that actually has Linux installed is using Opensouce. I guess in this case i would have to try your trick. It seems easy enough to do it.

I decided to explore new OS as i said i have some issues with Kubuntu. Although it is stable, the KDE is not implemented propperly. I don’t really care what OS i have as long as computer runs as it should and can get the work done on it.

Well, yes and no. Or no and yes (depending on how one looks at it).

Nomodest is there in case modesetting (to automatically configure one’s graphics) does not work. Just because it does not work, does not mean its a bug. It may simply be that that feature has not been implemented yet. BUT in the case of the Radeon HD3450 it DID work previous, it was broken, and for the HD3450 it IS used to avoid a bug. The same is true for the HD3650. Clear as mud ? :slight_smile:

Good luck with your GNU/Linux efforts, what ever distribution you end up using.