ATI Proprietary Driver Install Guide | openSuSE 11.2 vanilla

Could it also be your configuration file ? Have you tried:

  • booting with no xorg.conf file ? or
  • after booting direct to run level 3, creating an xorg.conf file with “aticonfig --initial” and then restarting to run X window ? or
    *]after booting directo to run level 3, creating an xorg.conf file with “sax2 -r -m 0=fglrx” and then restarting to run X window ?
    Do all of the above give this unsatisfactory behaviour that you report?

Pardon my intrusion, but I too have trouble installing.

The ATI documentation mentions XFree86-Mesa-libGL and XFree86-libs are required. I assume the refer to the X11, right?

My second problem is that after completing the graphical part of you instructions (built distribution specific package) the console asks me the same questions. I have completed that part and the I get an error mesage

Package build failed!
[Error] Generate Package - error generating package : SuSE/SUSE112-AMD64

I checked many time and the requirements are met.

Any ideas/suggestions?


Ensure you removed any fglrx rpm BEFORE you tried to generate the package. Ensure you have kernel-source, kernel-syms of the appropriate version, and have linux-kernel headers and gcc/make (preferably the base development package) installed BEFORE you tried to generate the package. Also ensure your graphic hardware is supported by the driver, as legacy hardware (as deemed by ATI) is not supported.

Thanks for the quick reply!

I’ll give it a try again this evening. :slight_smile:

UPDATE: This may sound foolish :shame: , but I realized that the kernel I have is desktop version 2.6.31 , not vanilla. Is this going to affect the install?

what is the output of

rpm -qa '*kernel*'

For example on my PC

oldcpu@hal2009:~> rpm -qa '*kernel*'

Note the version of kernel-source and kernel-syms is the SAME as kernel-default. That is important ! You need the same version there for this to work.

oldcpu this is the output

kcharvalias@linux-Laptop:~> rpm -qa '*kernel*'

Kernel source does not appear yet YAST says version I also notice that kernel-default is absent.

kernel-source is there.

It looks to me that your pc uses kernel-desktop instead of kernel-default.

Those appear to be correct packages. As noted, when you build, you must ensure any fglrx rpms are removed first. And you must have rebooted since the last kernel update.

oldcpu, I did reboot when I updated kernel. No fglrx rpm’s are installed.

I tried again this morning. The result of

cat /usr/share/ati/fglrx-install.log | more

is the same as before.

I also noticed that the glibc version I have is 2.10.1. The command-line instal recognises it as 2.1.
I don’t know what else to suggest. I think I’ll let some time pas before trying again.

Another silly question (my apologies … ) . Do you have the base development pattern selected in YaST ? (to give you gcc, make … etc … ).

You mean:
YaST -> View -> Patterns -> Development -> Base Development?

Base development is unchecked :shame:

Enabling it now

Ahh … ok, … then once all the MANY apps from the Base Development pattern are installed, can you try again ? Ensure you have no fglrx rpm installed before you try again.

Just to make sue of the syntax

rpm -e '"*fglrx*"'


rpm -e '*fglrx*'


I use this:

rpm -e $(rpm -qa '*fglrx*')

my reference guide is this: ATI/The Hard Way - openSUSE

Thank you very much for the assistance! Built and installed ok, the ati demon is running.
Restarting now.

I have my fingers crossed ! :slight_smile:

SUCCESS! rotfl!

Thanks again! :slight_smile:

Congratulations !! And well done in your determination to see this through to succeed.

I have had some success too! It seems to have installed properly, i have a cursor and was able to launch a quakelive game, so looking good. Ill try and get desktop effects working now but that isnt really important,

Thanks for all the help!

everything is working perfectly now, desktop effects and all!

I didn’t have the base development pattern either, so i installed that. Then it said i didn’t have kernel-source, yast showed it as installed so i re-installed it, and it all went smoothly from then on.

so THANK YOU again for all the help in this thread!!