ATI Proprietary Driver Install Guide | openSuSE 11.2 vanilla

Good people,

I’ve been strugling with the ATI Proprietary Driver, and eventually made it work easilly after reading the documentation available with the driver.

There isn’t actually much things to do around this, and it’s pretty much straight installation if you have a clue on what’s going on, or eventually on what you are doing.

For this instalation I’ve used the following:

openSuSE 11.2 x86_64 vanilla (no updates)

  • Installed the Development Packages for system (the usual stuff, including

ATI driver package for x86_64 10.1 (Radeon Mobility M92 4570 / RV710)

Now for the real stuff…

Download the Driver from: Advanced Micro Devices Inc. - I’m not providing links as I would assume they are hardware specific. My hardware is a ATI Mobility M92/RV710 based chipset (Radeon Mobility HD4570 using LVDS output on a Sony Vaio NW21EF/S).

Open a gnome terminal or xterm, whatever you prefer and run the following commands:

su -

After super user password prompt should deploy you on a super user shell prompt.

cd /home/USER/Download

This will place you on the Download folder where Firefox saves by default the files downloaded. Keep in mind to replace “USER” by your username.


This will make your ati driver package run the installer. From this point on untill the package is done, we continue on graphical mode through the Loki installer.

Now, there’s a couple of important things… first we don’t want to use premade packages, at least I don’t and I won’t recommend you to do such. Screen by screen, this is what we need:

  • 1st screen: Generate Distribution Specific Driver
  • 2nd screen: Accept the Licence Agreement. I haven’t read this, please do so, though I won’t believe AMD is trying to hurt you, just the **** lawyer stuff.
  • 3rd screen: Select “SuSE Packages” followed by “SuSE/SuSE112-ADM64”,
  • 4th screen: Press EXIT.

At this stage you should be back on the root shell prompt. First thing you should actually do is check for the build log, you can do such by:

cat /usr/share/ati/fglrx-install.log | more

the line you are looking for is this:

Package /home/USER/Download/fglrx64_7_4_0_SUSE112-8.69-1.x86_64.rpm has been successfully generated

If you go such, this means you have successfully created a RPM (Red Hat Package Manager). Now what you need to do is install the package you just created. This is accomplished by running the following command:

rpm -Uvh /home/USER/Download/fglrx64_7_4_0_SUSE112-8.69-1.x86_64.rpm

Now comes the tricky part… Which apparently shoots down a lot of users… the wicked “black screen”… Apparently through my trial/error experience in this package, it happens only when you are not running a small daemon. By installing this RPM, the daemon is located on /etc/rc.d and should run at system boot every time before X starts. ATI has been nice to people and offers this daemon init script to SuSE and RedHat users.

Make sure you have the daemon running…


Since we are paranoid… check if you have the following:

ps aux | grep atieventsd

Should return some lines, one of them should be something like this:

root    1200  0.0 0.0  34744  1112 ?     Ss  19:57  0:00 /usr/sbin/atieventsd

Nice, everything seems to be running :slight_smile: Now the final step…

aticonfig --initial

It should generate your xorg.config resident in /etc/X11/.

If everything goes ok, you should be able to restart your X now and have full 3D/2D hardware acceleration. I do reckon that most problems I had previously was to the fact I was neglecting and unaware of the existence of the ATIEVENTS Daemon. This has to be running so you don’t get the “Black Screen”.

Restart X as you wish, CTRL+ALT+Backspace, through kill, power switch, reset… whatever you feel like!

Has for the rest, good luck all on your duties.
And with this, Sony Vaio NW21EF/S is fully supported by OpenSuSE 11.2 Vanilla. Good job from the Community, only thing which is really annoying me is Grub. Soon a small howto on how to replace Grub by Chameleon!

Nelson Marques, Gnome Marketing Team.](](

Any idea what to do if the log says that it does not build the rpm? I have a situation where even as root, it failed to compile the rpm. I tried about 5 times before giving up.

Well, I would point that this is due to the lack of required development packages and 32bit compatibility.

People should read the Documentation provided by ATI where it states the following:

The drivers above support English only.
The display driver requires POSIX shared memory to be enabled on the system.
Kernal Sources package is no longer required if Kernel Header package is installed.
32-Bit packages must be installed for 64-Bit Linux drivers to install or work.

*These sites are community resources, and are not supported by, or affiliated with AMD in any way.

ATI Requirements

If Posix shared memory is enabled you have this device: /etc/shm. I used vanilla installation, and OpenSuSE 11.2 does have it enabled.

Kernel header package can be installed with:

sudo zypper install kernel-headers

32 bit packages can be installed with YaST easilly. Please check SuSE documentation on how to perform such operation.

Installer instructions from ATI can be download from here (ATI Website).

The relevant point on this instructions is the software you need to be installed, this goes for devel packages aswell:

> libstdc++
> libgcc
> fontconfig
> freetype
> zlib
> gcc (this you don’t need to install devel packages, unless they have dependencies, but YaST should fix dependencies if you use it to install the software, and even if you install devel package for gcc won’t harm your system).

Make sure you have all of this packages installed and the respective glibc 32 bit compat libraries. It shouldn’t be a problem if you have it all installed.


Unfortunately, the 32 bit driver was already installed in my PC. Sorry for not mentioning that. I tried reinstalling the 32 bit drivers without success.

nmarques78 wrote:


> Code:
> --------------------
> The drivers above support English only.
> The display driver requires POSIX shared memory to be enabled on the
> system. Kernal Sources package is no longer required if Kernel Header
> package is installed. 32-Bit packages must be installed for 64-Bit Linux
> drivers to install or work.
> *These sites are community resources, and are not supported by, or
> affiliated with AMD in any way.
> --------------------

There are hundreds if not thousands of 32 bit packages. Which ones?


Applying a bit of commum sense, the ones specified in ATI Documentation for sure.

Download the Driver from: Advanced Micro Devices Inc. - I’m not providing links as I would assume they are hardware specific. My hardware is a ATI Mobility M92/RV710 based chipset (Radeon Mobility HD4570 using LVDS output on a Sony Vaio NW21EF/S).

Do you have any information about Radeon Mobility X2300 (ATI Mobility M64) ?? I use sony vaio cr353,…

I’m (basically) completely new to linux (I haven’t used it in years - and back when I did, all my hardware, except my modem, was supported, so I never had worries), and have little to no knowledge of the commandline under linux (wish it was more like DOS, which is easy).

If I install the OpenSuse 11.2 DVD, will that already have all the packages I need to install the Ati driver, or will I need to download some things separately?

Right now my display on my laptop won’t work at all under opensuse, so I don’t know if my network card would work or not (and therefore I would prefer to download everything under my windows system (i’ll be dual booting) and then just install any additional packages I may need from a usb flash drive).

Also, if I download the driver off the AMD site, can I somehow add it into the installation of opensuse? There is a driver menu when you boot up the install DVD - can I somehow do it through there, so its there from the start?

I followed your instructions and everything seemed to go smoothly. I restarted X but I have no mouse cursor and things are very laggy. Webpages take a long time to scroll and it was pretty much unbearable to use so I reverted back to the backup of xorg.conf.

I’m using Suse 11.1 x64, my GPU is a HD4870 and I downloaded the following .run package Please advise.

If you download the latest driver, read the fine documentation.

*The latest version of the ATI Proprietary Linux driver is designed to support the
following Linux distributions:
􀁺 Red Hat Enterprise Linux suite
􀁺 Novell/SuSE product suite
􀁺 Ubuntu

If you read further, my interpretation is that there is no need to generate a distribution specific package.

What advantage is there in installing ATI Events Daemon if the automatic install looks as though it would work without it? Also, the proprietary driver in the official 11.2 repository has been broken for a couple of weeks.

This kind of guide makes me consider installing Gentoo if one needs to jump through all of these hoops just to get a graphics driver working.:wink:

If you read carefully the documentation, it says that if you generate the package for “supported” distributions you get the correct init scripts on the package. If you don’t you do them by hand based on the ones supplied on the docs. Somehow you missed that part of the documentation.

The advantage is that you need it for the driver to work correctly and manage your hardware and power options. Good luck ignoring it, you might get a full black screen and eventually you might get you GPU overheating.

Good luck with the TGZ carnage.

I successfully installed the 64-bit Catalyst 10.2 driver on my openSUSE-11.2 KDE-4.3.1 on Radeon HD3450 graphics 2 hours ago.

It was a standard “the hardway” (which is not hard) install. Nothing unusual. It worked. No check sum errors. No missing cursor. 3D works. KDE-4.3.1 works. It works WELL !!

Its unfortunate new users struggle here. I do not know what to say, other than perhaps some experience goes a long ways, and the difficulty new users encounter here with the proprietary graphic driver installation is unfortunate.

It’s unfortunate that new people don’t even read the docs, not that ATI docs are user friendly towards those persons, they could at least specify the required packages in 32bit, which would be a great help and which devel packages are required. I can understand why not do it (because SOME distros really don’t care about package name conventions).

I had no problems with openSuSE 11.2 and this driver set. I use openSuSE only for gaming, so I need strong 3D, for all the rest I use something else. Waiting for next release which hopefully will bring xorg 1.7.5 support.

All those distributions share one thing in common by the way, they all use xorg 7.4 or lower as ATI seems not to be a “bleeding edge” driver provider ignoring completly Xorg 1.7.5.

Anything above Xorg 1.7.4 is not supported because it’s not old software. Blame ATI.

Thanks for taking the time to make a thread like this and trying to help.

I am doing my best to follow your instructions, but it does not proceed as you have described.

I start the installer using the terminal commands you use, and select distribution specific - suse… and it gets to the 4th screen where i press exit.

However, once i have done so the installer immediately starts running in the terminal i am using, and there is no .rpm in the folder. Also, when i run

cat /usr/share/ati/fglrx-install.log | more

i am met with this message

Package build failed!
[Error] Generate Package - error generating package : SuSE/SUSE112-AMD64

Do you have any advice on where i can proceed from here? I am using opensuse 11.2 w/ gnome, the catalyst 10.2 drivers and have a 4850x2 card.

nevermind, i got it to build eventually by following the “ATI/The Hard Way” guide…

however when i did eventually get it installed, i had the same problems: no mouse cursor and atrocious perfermance. Not really sure what to do now, just have to live without 3d or maybe try another distro if i cant get it working. i love everything else about opensuse so far, but god this is frustrating =/

Installing a pre-compiled binary might not work properly if the dependencies are not set properly (same as --nodeps --force carnage, not ever to be used).

If you had problems compiling the binary, that’s because something is very wrong there, most likely missing the development packages.

It’s not really a distribution problem, it’s just ATI not being nice to people. My suggestion is the following:

Fully update your system through YaST or zypper.

Check on “The Hard Way” walkthrough for the packages you need installed and make sure you install the 32bit+64bit packages and the development packages for those packages.

Uninstall the current fglrx installation

rpm -e `rpm -qa | grep fglrx`

and then try to install it normally according by doing the sh ati…

If the RPM doesn’t build, it’s because you don’t have almost for sure all the required packages installed.
The reason why I advice you to compile the driver is because if you can generate the RPM, it will place the init scripts in the right place, and saves you a lot of trouble.

Keep in mind that after every kernel update, you need to reinstall the driver.

Keep also in mind one thing, every try you fail is a part of a learning process, every obstacle you beat, it another victory knot on your belt :slight_smile:

Anyway, the default settings worked fine for me from “aticonfig --initial”.
I’m running Doom 3, UT2004 and some other stuff that requires openGL with very good performance.

I can’t advertise where I am usually so that I could give you a hand, but if you log into FreeNODE IRC, search for “nmarques” and I’ll try to help you :slight_smile: (I’m on UTC btw)


This “no cursor” problem is strange. I’m wondering if it occurs only at some resolutions and not others ?

Does it occur with all desktops ? (ie only KDE4, or only Gnome ? )

What is “atrocious” performance? If compared to MS-Windows then welcome to Linux and the relatively poor support in proprietary Linux drivers compared to Windows drivers. If “atrocious” compared to VESA or radeonhd driver, then its another issue.

Thanks for the replies, ill give it another go later.

As for what i meant by bad performance, i mean compared to the vesa /radeonhd drivers. With the default drivers i cant enable desktop effects, but i can comfortably move a window around or scroll down a page… However with the ati drivers, when i do this it will jitter horribly, going into slideshow mode. I also tried some older versions of the drivers and had the same problem, so i guess its just not installing properly. I’ll double check i have all the required packages and try again.