ATI Proprietary driver for Compiz

I have successfully installed Compiz and ATI driver on my laptop with openSuSE 10.3 (with some problems but solved).

I then tried to install 3D support (that is ATI proprietary divers) on my new openSuSE 11.0 desktop.
My VGA is a ATI HD3850. Using the opensource driver I have no problem (but that doesn’t support 3D). The wiki suggests an “one-click-install” to get the drivers. After doing that and rebooting the system I was in text mode :eek:.
Via command-line sudo yast I removed the two packets:
“ati-flgrxG01-kmp-pae” “x11-video-fglrxG01” that were installed from the ATI repository. Then the system booted in GUI mode.
(Yes, I am sure I have pae kernel as I have 8GB of RAM working :smiley: ).

I thought I could get the drivers from the ATI website, but realized that I wouldn’t know how to remove them from text mode if the same problem occurs. So if someone suggest this please explain how to remove them via command-line :).


poletti marco wrote:

> So if someone suggest this please explain how to remove
> them via command-line :).

Try reinstalling from the one-click-install, then rebooting into runlevel
3–text mode (type ‘init 3’ at the grub menu). Then
run ‘aticonfig --initial --resolution=0,1600x1200,1280x1024,1024x768’.
This should properly build the /etc/X11/xorg.conf.

A second attempt would be to run ‘sax2 -r’, then reconfigure it using the


Menes Narmer
menesofmemphis [at] gmail [dot] com

“Unity and humility is the lesson all of history teaches.”

Thanks for the reply.

I installed ATI drivers, then swiched into runlevel 3 and typed aticonfig --initial …
Running startx from runlevel 3 (from root) or rebooting into normal mode gives the same error messages:

(EE) Failed to load module “type1” (module does not exist, 0)
(EE) Failed to load module “dri2” (module does not exist, 0)
dlopen: /usr/lib/xorg/modules//drivers/ undefined symbol: miZeroLineScreenIndex
(EE) Failed to load /usr/lib/xorg/modules//drivers/
(EE) Failed to load module fglrx (loader failed, 7)
(EE) No drivers available

Fatal server error:
no screens found
giving up
xinit: Connection refused (errno 111): unable to connect to X server
xinit: No such process (errno 3) Server error

going into text-mode yast I noticed that one-click-install had installed the module for kernel-default, not kernel-pae as it should (or as I think it should). I added the module for pae kernel from the Ati repository, but same problems arise. The one-click has also installed the kernel-default packet so I tried to boot without pae (unsuccesfully).

Any clues?

Oh, I forgot: when I ran from level 3 root

aticonfig --initial --resolution=0,1600x1200,1280x1024,1024x768

it wrote the following messages:

Found fglrx primary device extension
Nothing to do, terminating
error at set screen resolution: screen0 does not exist
aticonfig: parsing the command-line failed

Is my screen section of xorg.conf causing problems? (I haven’t modified it by hand) :confused: