ATI IXP audio problems, usb mic

I’m running openSuSe 11.1 i586 GNOME, and I have been trying, unsuccessfully, to make my built-into webcam usb microphone to record something with 'arecord.

arecord -f cd -D hw:2,0 -d 20 test.wav
Recording WAVE ‘test.wav’ : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
arecord: set_params:966: Channels count non available

All my audio specs can be found here:

I’ve been following instructions from an Audacity Wiki:
USB mic on Linux - Audacity Wiki

In the process of doing this, I came across several issues about my sound card.

if I run the ‘speaker-test -c2 -l5 -twav’ I can hear the lady saying front left and right.

I tried the audio troubleshoot guide for OpenSuSe (SDB:AudioTroubleshooting - openSUSE), but I get to step 2:

Yast -> Hardware -> Sound and I try playing the test sound, NOTHING happens. I tried reconfiguring, either the quick setup and normal setup, but it made no difference.

If I do: cat /proc/asound/cards I get

ATI IXP rev 2 with unknown codec at 0xc0003400, irq 17
1 [Modem ]: ATIIXP-MODEM - ATI IXP Modem
ATI IXP Modem rev 2 at 0xc0003800, irq 17
2 [U0x46d0x991 ]: USB-Audio - USB Device 0x46d:0x991
USB Device 0x46d:0x991 at usb-0000:00:13.2-1, high speed

It is the “ATI IXP rev 2 with unknown codec at 0xc0003400, irq 17” line that worries me. what is that about unknown codec? could it be that the reason of my mic’s failure?

Sometimes when I play a video on, for example, I get a brief horrible noise at the beginning, but then I get normal audio (even though I run firefox from the terminal, I get no output concerning this issue).

I tried installing Skype to test my usb mic, but all I got was this

ALSA lib pcm.c:2202:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi

I was able to log into skype, but when I tried placing calls I got a “Problem with audio playback”. More puzzling is the fact that, after I rebooted, skype wouldn’t even start!

skype &
No protocol specified

I posted this problem on its own here: Skype fails to capture framerate (30), Unknown PCM cards - openSUSE Forums

But now, I have the feeling all these things are linked together. That’s why I posted this together.

I hope I get some responses


Good news for a change…at least the Skype issue has been resolved. The “No protocol specified” error message was due to using apparmor to jail skype as suggested by: Skype HOWTO - openSUSE

I still get the sound error though. From other posts it seems that skype takes at default the first audio device on its list. That one happens to have the problem. But I’m using one that seems to work with it.

However my main issues remain…