ATI help

Well I was trying to follow along with the ATI section on this forum and got to this point.


aticonfig --initial --input=/etc/X11/xorg.conf

ldconfig didn’t seem to do anything at all. After that I tried the aticonfig blah blah blah section of the code. Which then said the config file could not be found. I was lost at that point and decided to give up and tried to go back to my desktop. Only now all I get is a black screen. Is there anyway to fix this? And even better if I can fix this how the hell do I get this stupid driver to work. I tried the “easy way” but that just hosed my system as well, and I ended up re-installing suse, and now tried the “hard way”.

I just run the command

aticonfig --initial -f

That’s what the installer says to run in the last window that comes up.

Then, after that, make sure you are logged in as root and run

sax2 -r -m 0=fglrx

Run sax2, and when you exit, type


If everything you try fails, from text mode, logged in as root, run

sax2 -r -m 0=radeon

This will switch you back over to the stock driver so you’ll at least have a desktop.

still a linux noob here, but is there anyway to get into the command line mode before it finishes booting up? Otherwise I can’t even get to the boot screen anymore cause it just straight to the black screen. Is there a way? Or am I looking at a re-install?

From the boot menu, right as you are starting up the machine, choose “Failsafe Mode”. This will boot you into text mode. Log in as root, and then run the sax2 command.

Once sax2 is finished, you can either hit control alt delete to reboot, or type “reboot” in the terminal.

From the boot menu, just as the machine starts up, choose “Failsafe Mode”. This will boot you into text mode. Log in as root and run the sax2 command.

After sax2 is finished, you can type “reboot” into the terminal, and when the machine restarts you should have a desktop again.