ATI HD4870X2 driver problems

Hi all,

Unless I struggled already a few days with the ATI driver, I didn’t managed to get the ATI driver working for my HD4870X2.

My setup is as follows: Opensuse 11.1 running on a Intel i7 920 with an ATI HD4870X2 graphics card.

I tried roughly two installation methods.

  • Adding to yast
  • Installed x11-video-fglrxG01 and ati-fglrxG-1-kmp-default
  • Runned su -c ‘SaX2 -r -m 0=fglrx’
  • Runned “rm /usr/lib/dri/ && ln -s /usr/lib64/dri/ /usr/lib/dri/”
  • Restarted X
    Now after starting X I get a white screen. If I reboot the pc, I get a black or white screen. If the black screen appears, the system hangs.
    This is a part of what the Xorg log says during a black screen:
(II) LoadModule: "fglrx"

(WW) Waring, couldn't open module fglrx
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (module does not exist, 0)

Quite interesting isn’t it? I just installed the thingie…


  • Downloaded the “ATI Catalyst™ 9.2 Proprietary Linux x86 Display Driver” from
  • Installed the driver according instructions in PDF.
  • Runned “rm /usr/lib/dri/ && ln -s /usr/lib64/dri/ /usr/lib/dri/” afterwards
    Now the installer tells me that all is fine, but looking carefully into the install-log it appears that compilation errors occured.

I’m wondering what I can do more to get the driver running… :’( Does someone has a brilliant idea?

Thanks for replies in advance

I have the same model graphics card and I was UNABLE to use ATI Catalyst 9.2 version. I also tried 9.1 version but NO success. However, 8.12 version WORKS for me when I use the second step you described. The only difference was the part where you run

“rm /usr/lib/dri/”,

I renamed the file as by running

“mv /usr/lib/dri/ /usr/lib/dri/”

I have kernel version I tried to update the kernel to and uninstalled the 8.12 ati driver and installed 9.2 but no luck there either. I also tried 9.1, 8.12, and 8.11 but all of these ended up with either black screen on boot up or fglrxinfo shows errors.

So try kernel version with ATI Catalyst 8.12 version.

Hope this helps you.

Thanks a lot for your reply. I understand you used the 8.12 driver directly from the ATI site? I guess you’d to install the kernel-source / kernel-headers / gcc and make packages in advance of performing step 2?

Thanks for your reply in advance

Yes, I downloaded the drivers from the ATI website under previous version and then also used yast2 to get the packages needed before I installed the 8.12 driver. Note: all the required packages are available in the installer instructions (a pdf file) from the ati website as well. It also mentions that for 64bit version 32bit packages must be installed as well.

I am running 64bit openSuSE right now but I’m thinking of switching to 32bit because of other problems not related to ATI drivers.

Good luck

It was quite a struggle to install the right packages (I updated a few already), but…

You’re a hero :smiley: !

martijn@linux-508k:~/Desktop> glxgears
47432 frames in 5.0 seconds = 9486.318 FPS
45443 frames in 5.0 seconds = 9088.511 FPS
48253 frames in 5.0 seconds = 9650.480 FPS

Lets see now if we can get it to dual head 0. Thanks man!

Ok, for the ones who want to know… Got the dual head setup working too…, including 3D acceleration:

Open a terminal and login as root:
>> su

Specify the initial dual head configuration (my secondary screen is left of the primary, could also be right):
>> aticonfig --initial=dual-head --screen-layout=left

Tell the driver that your orientation is horizontal:
>> aticonfig --dtop=horizontal --overlay-on=1
>> aticonfig --desktop-setup=horizontal

Tell the driver to set Xinerama on:
>> aticonfig --xinerama=on

Now restart x by pressing two times Ctrl-alt-backspace and login again.

>> glxgears
to check if the acceleration still works. :wink:

If it’s all working you’re happy, I guess!

Glad to see that it worked for you. It seems that certain kernel version goes with certain ATI Catalyst driver. I just switched to 32bit openSuSE with kernel*-pae and 8.11 version works while all the rest were useless.

Hmmm. Strange. Linux is a powerfull OS, but sometimes it’s really a fight to get things working.

The thing is that I wanted to do visualization things using VTK and ITK. These libraries use such an amount of memory that 32-bit almost standard fails after loading two or three volumes. That’s why I had to switch to 64-bit, but without OpenGL it wasn’t that better ;-). Now all works fast and fine!