ATI HD4350: No GLX When Using fglrx

I see a lot of people have been having problems with ATI driver installations, but I haven’t seen any posts regarding this specific issue:

When I install opensuse 11.2 x86_64 from the DVD, the provided radeonhd 1.3 driver works mostly fine. There are some occasional minor graphic aberrations, but nothing to cry over. Typing “glxinfo” in a console spews forth all kinds of GLX information, which all looks positive.

When I try to install the Catalyst 9.10 or 9.11 drivers, the installation appears to be successful and X.org starts up fine, but my display is super slow. Moving windows around is painful. Typing “glxinfo” at the command line gives me an error message. My procedure basically involves running the ATI installer, choosing “automatic setup”, and then running “aticonfig --initial” after installation is complete.

I don’t know if DRI is disabled, or if the GLX error is the culprit. I also read somewhere that there might be some conflict between the kernel’s Radeon DRM module and the FGLRX driver.

Can someone enlighten me please?

Two commands which may be useful:

fglrxinfo (only applicable if using proprietary driver)

glxinfo |grep direct

glxinfo gives me the following error message:

name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  19
  Current serial number in output stream:  19

fglrxinfo gives me… exactly the same error.

glxgears gives me… exactly the same error.

Sluggish video could stem from a number of factors. First off, eliminate the 3D contribution. Configure Desktop -> Look & Feel -> Desktop -> General tab. Verify Enable Desktop Effects is unchecked. [You can always select this later.]

Then, see if the fglrx module got loaded at all:

lsmod | grep -i fgl

If it’s not there, look at /etc/ati/fglrx-install.log. The last line should be “done.”. If it isn’t, you probably are missing some module build prerequisites; you have to install the kernel build packages.

I am using the 9.10 ATI .run file in my AMD64 box with good performance (glxgears 6200fps) in openSuSE 11.2. I did not run sax2, and I did not need an xorg.conf file. I see some npviewer complaints in my syslog, but things are OK aside from that.

HTH

Yep, already made sure of that.

Yep, it’s loaded.

I tried without an xorg.conf file, and video performance seems to have improved noticeably. It’s almost as smooth as using the radeonhd driver. However, still no GLX.

A viable fglrx module loaded, and still no GLX? Hmmmm…

More than one video driver module loaded?

lsmod | grep -i rad

Garbage in the driver’s database?

rm /etc/ati/amdpcsdb
restart X

Don’t know what else to suggest for this puzzle.

Nope, that came up blank. I sifted through the lsmod results manually, only one video driver loaded.

Did not change anything.

:’(

One final thought: my /var/log/Xorg.0.log file tells a happy tale of successful fglrx and GLX actions. Maybe it can give you a clue as to where things go wrong.

problem solved. Somehow the ATI installer was only doing half the job, and the installed files were incomplete.

The following thread:

Generating catalyst 9.11 rpm’s on openSUSE 11.2 - openSUSE Forums

solved my problem. Now all works as intended.