ATI HD 4850 problem

I have a serious problem due to the followings:

  • I’m using OpenSUSE Linux 11.1, and at this morning I decided to upgrade the system. New kernel, xorg, yast, … etc. were installed.
  • I have an ATI HD4850 video card and it was working well, but now it doesn’t work. Window wear off when I try to replace it (or if I scroll a web page it also wear off…), multimedia programs eg. video players can’t handle files, all in all ATI catalyst is installed but the system doesn’t handle my video card. It looks like my PC has turned back to the stone age.
  • I tried to reinitialize the ati fglrx drive, but no effect…

My question is:
What should I do after a full system upgrade to force my ATI HD4850 card working properly again?

I would be gratefull for suggestions!

First of all, some practical theory (mostly for NON-proprietary graphic drivers): openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Now you say you “tried to reinitialize the ati fglrx driver, but no effect” … in my experience, that statement is general enough to show you tried something, but gives those trying to support you no idea as to what you tried, and its more likely to scare OFF help, than encourage help. ie. you really should try to be more specific as to EXACTLY what you tried.

IF this is the proprietary ATI driver, note you MUST deinstall the “fglrx” rpm BEFORE you re-install the driver. If you do not de-install the “fglrx” rpm first, I believe it will often cause problems.

I hope this is helpful. If not, please post.

Best wishes and good luck.

Thanks for your suggestions, complete re-installation solves the problem immediately and the link is useful.
Best regards,