ATI graphics card works on Suse 11.0 but not 11.1?

Hi, got an ATI Mobility 9000 graphics card. Worked fine on OpenSuse 11.0, But when I
tried installing 11.1 the X server freezes
at the login screen (after rebooting). Is my card no longer supported? Thanks.

Here is my xorg.conf file:

(Near the bottom it lists the radeon driver
is being used, which I think is right.)

/…/

SaX generated X11 config file

Created on: 2009-05-06T18:54:25-0600.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “dri”
Load “dbe”
Load “freetype”
Load “extmod”
Load “glx”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “9”
Option “Device” “/dev/input/mice”
Option “Name” “ImExPS/2 Generic Explorer Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Driver “synaptics”
Identifier “Mouse[3]”
Option “Buttons” “7”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “on”
Option “HorizScrollDelta” “0”
Option “InputFashion” “Mouse”
Option “Name” “Synaptics;Touchpad”
Option “Protocol” “explorerps/2”
Option “SHMConfig” “on”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
HorizSync 31-60
Identifier “Monitor[0]”
ModelName “1024X768@60HZ”
Option “DPMS”
Option “PreferredMode” “1024x768”
VendorName “–> LCD”
VertRefresh 30-60
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
Modeline “1024x768” 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
Modeline “1024x768” 64.11 1024 1080 1184 1344 768 769 772 795
Modeline “1024x768” 55.00 1024 1072 1104 1184 768 771 775 790 +HSync -Vsync
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1024x768”
Virtual 3840 1200
EndSubSection
SubSection “Display”
Depth 16
Modes “1024x768”
Virtual 3840 1200
EndSubSection
SubSection “Display”
Depth 24
Modes “1024x768”
Virtual 3840 1200
EndSubSection
SubSection “Display”
Depth 8
Modes “1024x768”
Virtual 3840 1200
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “RV250 Lf”
Driver “radeon”
Identifier “Device[0]”
Option “monitor-LVDS” “Monitor[0]”
VendorName “ATI”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
EndSection

I found the best way to install and configure the ati drivers is by installing the ati website’s driver as root in run level 3. After the install, stil in rl3, run sax2 to configure the card. You should now be able to restart the xserver fine.

Hi, went to the ATI website and they only had the
radeon mobility 9600 and up listed. Should I use
the driver anyway?

Use this link for 9000 drivers:
AMD Support Search
and choose the version for linux.

No, you should not.

(And I seriously doubt, that your card was supported by fglrx-driver under 11.0, fglrx-support for Radeon 9000 was dropped a long time ago).

Use the free radeon driver already provided by the default packages, fglrx will not work with this device.

Akoellh, I think your right about trying to use the radeon driver.
But if you look in the xorg.conf file in my first post, (“device
section”, 4th paragraph from bottom) it looks like the driver
is set to radeon.

So is there something else wrong?