ATI flickering with GLX


I just installed the latest ATI drivers (9.2 20 feb 08) and it still flickers when you start a 3d app like GoogleEarth, GLXGears or any game.

It’s an old problem but has it ever been solved? Since it’s not on the known issue list anymore.

Also the posts I find about this using google usually give me old posts. So just wondering, is there a fix?

Btw I’m using a Mobility x1600 on openSUSE 11.1


Do you have compiz enabled? Interesting thread discussing similar topic:

This link too.

Don’t want to get wires crossed, but some users have found flickering video can be improved by adding the following line ‘Device’ section of /etc/X11/xorg.conf:

Option “TexturedVideo” “on”

Hi, thanks for the reply. It’s indeed only when Compiz is enabled. I’ll try that setting later on and report back here.

The option Option “TexturedVideo” “on” didn’t do anything noticeable.