ATI fglrx video driver install made a mess. How to fix?

openSuse 11.2
linux x86_64
ATI fglrx video driver v10.4
ATI radeon hd3200 video adapter

VirtualBox (any version) crashes at startup if the video acceleration options are enabled. This was not a problem before installing fglrx. The crash occurs when VirtualBox queries the video driver about OpenGL, I am guessing from the log file.

To (supposedly) have access to all of the features possible in the video adapter I installed the ATI fglrx video driver. I (apparently foolishly) chose the custom, installation-specific path rather than the more general default path.

After installing the driver I saw no observable improvement in performance or feature set. Worse, there are couple of new features that are decidedly undesirable, and cannot be disabled. At least one pre-loaded font simply disappeared. :frowning:

So I reverted to the original (open source?) radeon driver (“sax2 -r -m 0=radeon” at runlevel 3). All seemed welluntil I ran VirtualBox.

One thing I have not tried is to run the fglrx default installation. I fear making things worse.

Can anyone suggest what might have happened with the fglrx installation, and how to fix it?

Have a look here
openSUSE Forums - View Single Post - openSUSE Graphic Card Practical Theory Guide for Users

Ah! Thank you. I wish I had been directed to that URL before. I got my system fixed. Yay!

Can you tell me what the differences are between using <sax2> and <Xorg> to configure the video system?

sax2 is really the config tool for xorg.
But I wouldn’t spend too much time learning about it, the next release is seeing the back of it.

So for example if you run

sax2 -r -m 0=nvidia

You will configure the setting file xorg.conf to use nvidia, assuming you have a nvidia card and the driver installed.

You can run sax2 in a su terminal to start the sax2 UI.

Hello !
With OpenSuse 11.2 : my graphical card “ATI radeon XPRESS 200M” works but…
With Opensuse 12.1, the KDE splash screen get freezed after a couple of minutes.

I have installed the “xorg video driver radeonh” RPM using Yast but it doesn’t help.

Could you give any help so that it works in 12.1?

  • Shall I somehow use the driver used in the 11.2 version? How?
  • Shall I downgrade the KDE version of 12.1? How?

Thanks for your help,


Just for info: Do NOT try to install the ATI proprietary driver (flgrx also known as Catalyst). It won’t work with this graphics card.