ATI fglrx - 11.2 - Unknown symbol find_task_by_vpid

I configured ATI repo:

Deinstalled radeon driver: xorg-x11-driver-video-radeonhd


Reboot and no X11!

# modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)


#tail -f /var/log/messages 
Nov 25 20:19:56 xx kernel:  1690.047440] fglrx: Unknown symbol find_task_by_vpid
Nov 25 20:19:56 xx kernel:  1690.048641] fglrx: Unknown symbol pci_enable_msi


   10.262334] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
   10.262340] Disabling lock debugging due to kernel taint
   10.262697] fglrx: Unknown symbol find_task_by_vpid
   10.263888] fglrx: Unknown symbol pci_enable_msi
rpm -qa|grep kernel

xx:/usr/src/linux # uname -a
Linux xx #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux

My gpu is a ATI FireGL Mobility 5200 compatible with X1600

01:00.0 VGA compatible controller: ATI Technologies Inc M56P [Radeon Mobility X1600] (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 30b4
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at e0000000 (32-bit, prefetchable) [size=256]
	Region 1: I/O ports at 4000 [size=256]
	Region 2: Memory at f4600000 (32-bit, non-prefetchable) [size=64]
	[virtual] Expansion ROM at f4620000 [disabled] [size=128]
	Capabilities: [50] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [58] Express (v1) Legacy Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
			ExtTag+ AttnBtn- AttnInd- PwrInd- RBE- FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 128 bytes
		DevSta:	CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
			ClockPM- Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
	Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000


On Wed, 25 Nov 2009 19:36:01 +0000, pober wrote:

Looks like a known issue with the compilation of the kernel module on
2.6.31 - Google search turns up bugs reported for Ubuntu on this as well.

I can confirm I get it on 32-bit 11.2 as well.


Jim Henderson
openSUSE Forums Moderator

YUP. I’ll add a me too, plus a warning.

I did not remove radeonhd first. I had previously made a backup copy of xorg.conf.

I thought to get around fglrx failing by replacing the xorg.conf with my saved copy that referenced radeonhd. X worked, but very oddly.
My panel icon for pidgin never was right and the performance was extremely slow.

I rpm -ev removed both fglrx modules, made sure I had the right xorg.conf in place and rebooted.

Things are now back where they were befor.

Confirmed that 32 bits also do not work!

I just installed the driver from the ATI repo for fun… as i knew on forehand that ATI dropped support for older hardware on newer kernel/Xorg.

it did what i expected to do… ‘fglrx fails to start’

I was wondering why they put these drivers in the repo? Every newbie will install these drivers and then come to this forum and whine about X that won’t start. In worst case, they end up with a black screen and don’t know how to set back to ‘ATI’, ‘radeon’ or ‘radeonhd’ because they can’t get to another runlevel.

Wouldn’t it be nice to mention this issue in the opensuse wiki? The list of additional repositories list ATI repo. Maybe put a warning there for people who don’t know they are going to break there system.

My two cents.

a proud owner of ATI mobility radeon, using the open source “radeon” driver… even though it sucks at performance, it works!

Thnx for confirmation, though this is sad, that no working driver is provided by ati (repo or directly) for my gpu with 11.2.

Also switching back to radeonhd until they fix this.

****, no more ATI cards in my machines at work! They’re too lethargic releasing their drivers for linux :\

opewnSuSE 11.2 uses a different version of than the 'buntus as of 9.10/11.2; while oS went with 1.7, the 'buntus all stuck with 1.6.

I run Kubuntu 9.10 x64 because they stuck with 1.6 (they have Catalyst 9.11 in their repos and it works just fine, even with 2.6.31-15, which is a newer kernel than 11.2 uses). Support for 1.7 is not due in Catalyst for Linux until 9.12 (due to 1.7 slipping; remember, it was due over a month ago). It’s not a repo or even kernel issue; but entirely due to changes in X between 1.6 and 1.7.

I actually got better 3D performance with the radeon (not radeonhd) open-source driver, despite having an HD3450; however, I have other issues with oS 11.2 (in addition to the changes in 1.7 breaking Catalyst 9.11) which forced me to move to Kubuntu 9.10 (which stuck with 1.6).

My other issue with oS 11.2 has to do with the changes that broke AICCU (IPv6 tunnel) support; Kubuntu not only didn’t break it, due to it being based on Debian, AICCU is in the core repo and is thus a quick update away. If it weren’t for that, I could have stayed with oS 11.2, as it’s a lot more usable otherwise; however, the and IPv6 issues are very much deal-breakers for me personally.

OpenSUSE would be better of by removing the ATI repo from the site. Once you add it to your system it will automatically install the ATI driver once you open the Install Software tool.

As long as it doesn’t work. People with a supported card probably downloaded the drivers them selfs from ATI. How likely is it that this driver will get updated… :s

On my system i am running the rs690m x 1270 radeon and i added the following repository to 11.2 suse/11.2 after i restarted and went to software management it automatically loaded 2 drivers for ati after i restarted again it worked and i now have full 3d support with fglrx. and i did not have to do any searching or config. if there is an output to help others let me know so i can post i have no clue as to how i did this .

The ATI site says it needs some 32-bit packages installed for the 64 bit driver to work. So I made sure I had those, but the effect remains the same.