ATI Driver problem

I just recently switched to the GNOME desktop from KDE. I have an ATI Radeon HD 5700 card. Now, on the KDE desktop I downloaded the driver, and ran the installation program via the terminal. Reboot. Everything worked fine.

When I switched to GNOME I noticed the same sluggish display problems. So I installed the driver in the exact same manner. But for some reason it seems as though nothing has changed.

My problem is thus: I can literally see the pages loading any time I scroll up or down. The only word I have for it is sluggish. If anything it got worse after I installed the driver. I’ve searched, but between the performance hit and the lack of a concise manner with which to state this problem, I have turned up nothing.

The desktop should have nothing to do with it

Then what could it be? Because the problems I’m having now went away in KDE when I installed the driver. Also, I did look to make sure that I installed the correct version using the ‘uname -a’ command.

Certainly it sounds like it’s as if the driver is not installed
As su - what do you get for this

hwinfo --gfxcard

I ran the commands. Here is the output. Doesn’t seem like the card I have is recognized.

35: PCI 300.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1002_68b8
  Unique ID: svHJ.Q70JZn1ddJ2
  Parent ID: M71A.dAMzi+DfV5B
  SysFS ID: /devices/pci0000:00/0000:00:07.0/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: graphics card
  Model: "ATI VGA compatible controller"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x68b8 
  SubVendor: pci 0x1545 "VISIONTEK"
  SubDevice: pci 0x5770 
  Memory Range: 0xd0000000-0xdfffffff (rw,prefetchable)
  Memory Range: 0xf2fc0000-0xf2fdffff (rw,non-prefetchable)
  I/O Ports: 0x8e00-0x8eff (rw)
  Memory Range: 0xf2fa0000-0xf2fbffff (ro,prefetchable,disabled)
  IRQ: 255 (no events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d000068B8sv00001545sd00005770bc03sc00i00"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

Primary display adapter: #35

Have you read thru this
openSUSE Graphic Card Practical Theory Guide for Users

I’m reading through it now. I looked at the man file for the radeonHD driver that is supposed to come with openSUSE. I didn’t see my card (5770) listed at all.

Terribly sorry for the double post.

Ok, so I have tried

aticonfig --initial

As well as the Sax2 method listed in the link you sent me. Still no success. I then did a Google search of my specific card. I found this post.

How to install ATI Radeon HD 5770 Driver

After following the link to the guide, and then being linked again to the AMD website I find that the drop down boxes to specify what type of hardware I have do not work. They are completely empty of any sort of text or options

I’m not sure I would take that as a sign that they do not or will not work.
And I’m a nVidia man, never had ATI, so I ain’t much use.
Hang around, someone should have a clue.

Ok, this is really odd. I followed the steps in this guide. I tried the same thing on KDE, and encountered the same error; gcc make could not build the rpm package. So I was unable to complete the step where I had to enter the code

sh --buildpkg SuSE/SUSE112-IA32

I was never able to enter anything after that. But anyway, I tried again with GNOME, encountered the same error and rebooted. I then re-installed the ATI driver that I downloaded (third time that I have done so, mind you), entered

aticonfig --initial -f

and received this error message

Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-3
aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.

HOWEVER, the card is working. I no longer get slowdown when I scroll web pages, and the GNOME windows actually fade in and out. What’s more, I can see some actual desktop effects occurring.

Now, I’m not one to look a gift horse in the mouth, but one of the main reasons I switched to Linux was to understand. Does anyone have any idea what happened, and could they please explain?

Were you doing all this from level 3?

No. The only parts that I did from level 3 were the parts of the guide that I linked to that specifically stated to perform in level 3. All others were done in X window using the GNOME terminal.

Take a look at your /var/log/Xorg.0.log file to see what driver is loaded. Look for error messages. Also take a look at your /home/username/.xsesson-errors file and look for error messages. Maybe that will give you a hint. (… don’t post them directly here as they will just clutter the thread … )

I just looked at both of those files. There were no actual error (denoted by EE) messages in the Xorg.0.log file, and I’m afraid I don’t understand much of what is going on the the other. There is one thing that stands out, and I’m only going to post that little snippet.

** (bug-buddy:6356): WARNING **: Couldn't load /etc/xdg/autostart/ksmolt-autostart.desktop: Invalid key name: X-KDE-autostart-condition$e]

I assume ksmolt is just a kde version of smolt, and likely nothing to be bothered about.

What graphic driver did the Xorg.0.log file indicate your PC was using?

I am by no means an expert on understanding these log files, but here is what I found, in respective order as I perused the file

(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 5.0
        X.Org XInput driver : 4.0
        X.Org Server Extension : 2.0
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux//
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
        compiled for, module version = 8.70.3
(II) ATI Proprietary Linux Driver Version Identifier:8.70.3
(II) ATI Proprietary Linux Driver Release Identifier: 8.702                      
(II) ATI Proprietary Linux Driver Build Date: Feb  2 2010 22:48:24
(II) Primary Device is: PCI 03@00:00:0
(WW) Falling back to old probe method for fglrx

There is more on the fglrx driver after this, but the spill is huge. I looked through most of it and it seems like it identified my card.

What packages have you installed?

zypper se fglrx

What I always do is to install two packages: ati-fglrxG02-kmp-desktop and x11-video-fglrxG02 (desktop is my kernel of course).

Then I go to terminal (ctrl + f1) and make aticonfig --initial. Can’t remember if this backup your last Xorg file maybe yes but anyway delete or rename your current Xorg.conf before the aticonfig command just to make sure.