ati driver problem on my new Asus

G,day I have just got myself a new Asus M51V series laptop with a Radeon HD3470 graphics card. I have tried 3 different ways of installing the ati driver but nothing has worked. I have tried the “one click”, yast and the manual way generating the distribution specific package. “Display info” in “My computer” is blank. When trying to enable desktop effects I get

"Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type."

fgrxinfo gives me this
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 144 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 15
Current serial number in output stre am: 15

I am using opensuse 11.1 with KDE 4.2
Thanks for taking you time to help

It sounds like you are running the radeon driver. Have a look at /etc/X11/xorg.conf & /var/log/Xorg.0.log

Is the radeon driver the correct driver to use?
Here are parts of the 2 files. They were viewed from in KDE 3.5 because 4 was freezing int. on me. I hope this is ok.

SaX generated X11 config file

Created on: 2009-01-31T15:54:14+1100.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 331 207
HorizSync 30-62
Identifier “Monitor[0]”
ModelName “LGPHILIPSLCD LCD MONITOR”
Option “DPMS”
Option “PreferredMode” “1280x800”
VendorName “LPL”
VertRefresh 43-60
UseModes “Modes[0]”
EndSection

Section “Device”
BoardName “ATI Mobility Radeon HD 3400 Series (M82 95C4)”
Driver “fglrx”
Identifier “Device[0]”
Option “XAANoOffscreenPixmaps” “true”
Option “Capabilities” “0x00000000”
Option “OpenGLOverlay” “off”
Option “FSAAScale” “0”
Option “FSAAEnable” “off”
Option “VideoOverlay” “on”
Screen 0
VendorName “ATI”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
EndSection


Xorg.0.log***

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-03ep 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64
Build Date: 03 December 2008 02:40:38PM

(II) Loader magic: 0x7ae680
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 4.1
X.Org XInput driver : 2.1
X.Org Server Extension : 1.1
X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 7

(–) PCI:*(0@1:0:0) unknown vendor (0x1002) unknown chipset (0x95c4) rev 0, Mem @ 0xd0000000/268435456, 0xfdff0000/65536, I/O @ 0x0000c000/256, BIOS @ 0x???/131072
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX**
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX**
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX**
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX**
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX**
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX**
(II) “extmod” will be loaded. This was enabled by default and also specified in the config file.
(II) “dbe” will be loaded. This was enabled by default and also specified in the config file.
(II) “glx” will be loaded by default.
(II) “freetype” will be loaded by default.
(II) “record” will be loaded by default.
(II) “dri” will be loaded by default.
(II) LoadModule: “dbe”

(II) Loading /usr/lib64/xorg/modules/updates//extensions/libglx.so
(II) Module glx: vendor=“X.Org Foundation”
compiled for 7.4.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(==) AIGLX disabled
(WW) fglrx: Force AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: “freetype”

ABI class: X.Org Video Driver, version 4.1

() FBDEV(0): claimed PCI slot 1@0:0:0
(II) FBDEV(0): using default device
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX

[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX**
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX**
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX**
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX**
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX**
(==) FBDEV(0): Depth 16, (==) framebuffer bpp 16
(==) FBDEV(0): RGB weight 565
(==) FBDEV(0): Default visual is TrueColor
(==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDEV(0): hardware: VESA VGA (video memory: 6144kB)
(II) FBDEV(0): checking modes against framebuffer device…
(II) FBDEV(0): mode “default” not found
(II) FBDEV(0): checking modes against monitor…
(–) FBDEV(0): Virtual size is 1024x768 (pitch 1024)
(**) FBDEV(0): Built-in mode “current”: 78.7 MHz, 59.9 kHz, 75.7 Hz
(II) FBDEV(0): Modeline "current"x0.0 78.65 1024 1056 1184 1312 768 772 776 792 -hsync -vsync -csync (59.9 kHz)
(==) FBDEV(0): DPI set to (96, 96)
(II) Loading sub module “fb”
(II) LoadModule: “fb”

(II) Loading /usr/lib64/xorg/modules//libfb.so
(II) Module fb: vendor=“X.Org Foundation”
compiled for 1.5.2, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(**) FBDEV(0): using shadow framebuffer
(II) Loading sub module “shadow”
(II) LoadModule: “shadow”

(II) Loading /usr/lib64/xorg/modules//libshadow.so
(II) Module shadow: vendor=“X.Org Foundation”
compiled for 1.5.2, module version = 1.1.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) do I need RAC? No, I don’t.
(II) resource ranges after preInit:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX**
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX**
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX**
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX**
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX**
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX**

Does this put any light on the situation?
Thanks************************************

G,day,
I just thought that I would let everyone know that I have the ati driver working and can now use the desktop effects.

All I did was install the new 9.1 driver (after removing the old one). Basically I just followed this walk through
How To: ATI Drivers OpenSUSE 11.1 - Ubuntu Forums

I hope this helps someone.