ATI driver install - No more gui/sax

I just installed 11.1 today, with KDE. After getting everything installed, I decided to install the ATI drivers as performance was quite dismal to say the least. I was hoping the driver from the ATI repo would be an improvement. I installed via the repo, then rebooted. At first boot it did not load KDE, just the command line. So I logged in, and tried to go into Sax2. All I got was a black screen. Then rebooted into failsafe, same thing.

So I rebooted again, this time backing up the xorg.conf and xorg.conf.install files, then deleted xorg.conf. Tried Sax2, just a black screen. I copied the initial Sax2 save file to xorg.conf, and tried Sax2…nothing. Checked both files to insure they were the original prior to the ATI driver install, rebooted. Sure enough…black screen. But this time it does not boot to the command line, but rather the screen goes black.

This is what is in my xorg.conf now, which is what was working prior to driver install:
Section “Device”
BoardName “RV250 Lf”
Driver “radeon”
Identifier “Device[0]”
Option “monitor-VGA-0” “Monitor[0]”
Screen 0
VendorName “ATI”

The only log message I get is this in messages log:**
Apr 10 01:25:42 linux-e1fw kdm[2812]: X server died during startup
Apr 10 01:25:42 linux-e1fw kdm[2812]: X server for display :0 cannot be started, session disabled

And xorg.log:
(II) Loading /usr/lib/xorg/modules//
(II) Module int10: vendor=“X.Org Foundation”
compiled for 1.5.2, module version = 1.0.0
ABI class: X.Org Video Driver, version 4.1
(II) RADEON(0): initializing int10
(II) RADEON(0): Primary V_BIOS segment is: 0xc000
(II) RADEON(0): Legacy BIOS detected
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
drmOpenByBusid: Searching for BusID pci:0000:01:00.0

And xorg.log without ATI driver:**
(II) Loading /usr/lib/xorg/modules/linux//
(II) Module fbdevhw: vendor=“X.Org Foundation”
compiled for 1.5.2, module version = 0.0.2
ABI class: X.Org Video Driver, version 4.1
() FBDEV(0): claimed PCI slot 1@0:0:0
(II) FBDEV(0): using default device
(II) resource ranges after probing:

[0] -1 0 0xffffffff - 0xffffffff (0x1) MX**
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX**
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX**
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX**
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX**
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX**
(==) FBDEV(0): Depth 16, (==) framebuffer bpp 16
(==) FBDEV(0): RGB weight 565
(==) FBDEV(0): Default visual is TrueColor
(==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDEV(0): hardware: VESA VGA (video memory: 10240kB)
(II) FBDEV(0): checking modes against framebuffer device…
(II) FBDEV(0): mode “default” not found
(II) FBDEV(0): checking modes against monitor…
(–) FBDEV(0): Virtual size is 1280x1024 (pitch 1280)
(**) FBDEV(0): Built-in mode “current”: 131.1 MHz, 80.3 kHz, 76.6 Hz
(II) FBDEV(0): Modeline "current"x0.0 131.09 1280 1312 1472 1632 1024 1028 1032 1048 -hsync -vsync -csync (80.3 kHz)
(==) FBDEV(0): DPI set to (96, 96)
(II) Loading sub module “fb”
(II) LoadModule: “fb”**********

Suffice to say, this does not even include the problems with Xen not loading, VMWare can’t install, Elisa and VLC fail to load…**

I was able to get this resolved by rebooting, and using SSH from another machine to un-install the ATI drivers. After looking at the specs on my laptop, it appears I have a ATI Mobility Radeon 9000, where as the driver in the ATI repository says it is for M9 or later. I am not familiar enough with ATI cards to know what M9 is in terms of version.

The driver that is given by default has horrid performance (or is it KDE4?).

So am I stuck with this driver?

You need to find out what the version of ATI card you have using lspci. This is what I get:
01:00.0 VGA compatible controller: ATI Technologies Inc RV535 [Radeon X1650 Series] (rev 9e)

The RV535 is the important bit. Then check out the ATI docs and get latest and previous driver that supports your card. Install and configure using aticonfig --initial --input=/etc/X11/xorg.conf . Do not do the sax2 -r -m 0=fglrx as this might mess up the config file. Make sure the* files from /usr/lib point to /usr/X11R6/lib and startx.

Hopefully this abbreviated version works else read thru ATI - openSUSE and use liberally…

Radeon RV250 [Mobility FireGL 9000] (rev 02) -

Looks like I am *#(@ out of luck for getting 3D support, which is really pathetic. I suppose I should direct the anger at ATI? This isn’t exactly ancient hardware, of course the way the video MFRs are these days, anything past 6 months seems to be outdated.