ATI driver help

I have an ATI Radeon 4890 card and openSUSE 11.1 64-bit kernel-default.
I can’t get the ATI drivers to work any way i try it. I followed the instructions here: ATI - openSUSE this just added a new option to my grub menu: debug-openSUSE. When i try to boot into that, i have no mouse or keyboard at all. The hard way does nothing at all to my system but install fglrx.
Does anyone know a way to install this driver? any help is welcome and if you need more info just tell me.

I was in your shoes. Didn’t matter what I tried. Finally this worked and maybe it will for you:

Uninstall the fglrx RPMs

If you can’t get a gUI then do this to uninstall them: Boot to runlevel 3 and run command as root: yast
That gives the ncurses graphics screen for yast. Open software management and uninstall the fglrx RPMs.

Once they’re uninstalled, run sax2 to get a new GUI using whatever system sax2 chooses (probably vesa).

Get your online updates up to date.
Then add the Community ATI Repo
Then add the two fglrxG01 RPMs

Then open a console, su to root and run this command

aticonfig --initial --input=/etc/X11/xorg.conf


aticonfig returns no acceptable hardware or display. I tried to reboot and now when my computer turns on all you see is the word Grub on a black screen and nothing else

Try as root:
/usr/bin/aticonfig --initial
(you probably need the path)

Don’t run aticonfig until you’ve successfully removed the fglrx RPMs, then successfully run sax2 to create a new low resolution xorg.conf file, then successfully reinstalled fglrx RPMs, then run aticonfig with the special syntax, all strictly in that sequence. (but maybe you did that, in which case you have a larger problem).

But it looks like you have a different problem now, a broken bootloader. For that you should read this tutorial to get back to openSUSE, including read the appendix on how to repair grub once you’re in openSUSE: HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

Okay fixed the bootloader.
I did it in that exact order but i think i know what happened. I was using a 42’ HD tv as a monitor (got a 20’ lcd now) and suse was saying it wasnt supported so i had to pick a display resolution and type before it finished booting.
Because of that i think sax2 didnt work properly. I will try again with my new monitor.

Swerdna, please clarify - you say to add the “Community ATI REPO”, but the ATI REPO does not show on the “Community” list in YAST (NVIDIA Repo does).
Do you mean add ?

Yes that’s the one

OK, I followed your procedure, deleting the fglrx repos, then getting a GUI via the radeon module.
Reloaded the fglrx01 RPMs, ran the aticonfig and rebooted.

I got a login screen, but X crashes part way thru the KDE4.1 startup, bringing me back to login screen

Any thoughts?

You said you deleted the fglrx repos. What was needed was to uninstall the fglrx RPMs, not delete the repo.

Then you said you got a GUI back by using the radeon module. The plan was to get the GUI back by using sax2.

Give it another run, from the beginning, and follow this carefully:

remove/uninstall fglrx RPMs (not the repo)
reboot and run sax2 to create a new low resolution xorg.conf file
reinstall fglrx RPMs
run this:

aticonfig --initial --input=/etc/X11/xorg.conf

What you seem to have done was simply to run the radeon module in some fashion, not to really re-initialize the video from the bottom up. This may fix it or it may not, but give it a run and see.

My typo - did not delete the REPO, I uninstalled the RPMs.

Retried again, same result.

After uninstalling the fglrx RPMs, the first reboot starts a new, working GUI, I assume using the radeon module, as I can see it with ‘lsmod’.
I logged out of that GUI session, started a console session.
Ran SaX2.
Ran yast and reloaded the fglrx01 RPMs.
Ran aticonfig .
On second reboot, from login screen I see X starting to come up, then crashes as the KDE4.1 splash is being painted in middle of screen.

I started a console session, tried to run SaX2 but it crashes as well, with a message “xc: sorry could not start configuration server”

I looked at /var/log/SaX.log and at /var/log/Xorg.0.log.
I see no error (EE) marked entries in the later.
There are several warnings (WW) which appear to be dealt with.

I am using the “default” kernel - any reason to think “pae” would work?
For now I’ll back down to radeon.
I don’t really need 3D, but the radeon mod does not support the full 1680x1050 resolution of my monitor.

Thanks for help

I’ve no reason to think the pae would be better. Got me beat. You can’t do much more than you have already done. You can only hope for a skilled person to cruise by.

I use Gnome but i had ATI drivers working once on a computer when i had pae.
Since then ive had default and never gotten them to work. I dont see why it would
be different

When you have reinstalled the drivers from the repo, try rebooting without any aticonfig.
When the boot menu appears, type 3 to get into runlevel 3 and then login as root.
Now do the aticonfig --initial and then sax2 to configure the card.

whych - thanks for the suggestion.
I am away from the machine for a couple of days but will try it and report back

I also have a 4890 card with 11.1 x64. I have successfully installed the ati driver via terminal under run level 3. I have also had aticonfig -initial take care of updating my X11 config. Running lsmod verifies that the fglrx module is loaded.

Life is great… almost.

I am having a strange error come up in my system logs when using the “user switch” button from the kicker menu in KDE AND also when I try to switch sessions using CTRL+ALT+F8,9,…

Also, the new session never actually loads - I get only a black screen and blinking cursor in the upper left.

The message is as follows: [fglrx:fireglAsyncioIntEnableMsgHandler] ERROR IRQMGR returned error 1 when trying to enable interrupt source ff000036

Does anyone know if there is something I must add to the X11 config or another setting unbeknownst to me to make this work?

I think there is a bug somewhere in the driver. On some of my ati systems it works fine, but not on others. The moment I try and change user, the system locks up.
Multiple terminals are fine though.

Thanks, that was my fear.

i read that you have to link the binary or something like that. Heres what it said:

OK, I tried whych’s suggested aticonfig after reboot to init 3, no difference. I also tried “The hard way”, both direct install and via the “build RPM” method. Both died miserable deaths, The good news, I have become somewhat adept at cleaning up the mess and getting running again on the radeon 2D driver.

Just fyi, the is an Asus M2A-VM MB, integrated X-1250 graphics.

Two guestions:

  1. I have seen several references to the "ln " tweak posted by buddhadakid. Any consensus if this is correct out there? If required, why not implemented by the driver packages?
  2. From the ATI site, support for X-1250 graphics is in Catalyst 9.3, and now on ‘legacy support’. It seems to imply that drivers later than 9.3 will not support X-1250. In the Catalyst 9.2 Installer Notes, which are attached to the 9.3 download page, there is a statement that “32-Bit packages must be installed for 64-Bit Linux drivers to install or work.” Any thoughts on which 32-Bit packages they are referring to?