ATI driver causing display problems with HD4850

Just updated my graphics card to a Sapphire HD4850 1GB from an MSI HD3650. Uninstalled the Catalyst 9.1 driver for 36xx series and installed the 4800 series Cat 9.1 (created a Open Suse 11.1 rpm from the ATI installer, installed with YaST) ran aticonfig --initial and from init 3 ran sax2 -r -m 0=fglrx. Both glxinfo and fglrxinfo show:
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4800 Series
OpenGL version string: 2.1.8395 Release
The problem starts when I try to run games such as Flight Gear, ppracer and other 3D games. I get horizontal banding and artifacts across the display. I have reinstalled the catalyst driver and re-run the configs, but the problem remains. I dual boot with Vista 64 bit, and have no problems on the windows side so the problem is not with the video card. I am at a loss as for what to look for or cconfiguration changes to clear up the problem… Suggestions???

I was able to solve my problem by un-installing the generated rpm and doing the custom install instead of the distribution rpm. Everything is working fine now. Not sure why the generic install would work, but the open suse 11.1 rpm failed so miserably…

You still having good luck with this card and OpenSuSE 11.1? I have the same card and I’m about to try and dual boot with OpenSuSE, I’ve already tried a other distro’s and none of them could handle my card well:( I just want to be able to have dual montiors and play some 3D games that can actually utilize this card.

Anything to watch out for? anything you tried that killed the x server?

Thanks for any advice or help in advance.