ATI-driver and linux doesn't boot anymore


Im a newbie in linux, but when I wanted do install SupertuxCart :), yast proposed to install also the ATI-driver. After the next reboot, it showed me a black screen. Also in the Safe-Mode. How can i repair this?

Thanks for your answers in advance,

Welcome to the openSuSE forums. I hope you enjoy your stay in our community.

Now, Let’s get on the task.

What you did, is pretty much the same as I did when I was a new to openSuSE, except I just wanted my Compiz Fusion to work. You probably went on and installed the new driver “the easy way” with a one-click install or installed it using yast, which has the latest release. The problem is, this driver is not very reliable in 11.1, unfortunately. I’m sorry to say it, I have an ATI Radeon HD 3200, and installing those drivers, really makes it look ugly. I even posted a video, which basically shows that there’s nothing you can do. where people are trying to hack SaX2, but I tried it and it only fixed my resolution, which still a + .

Good luck. And don’t forget, learning Linux will be frustrating in the beginning.

First off, if the 1-click installs are really still causing problems, someone should take them down.

Second, I don’t see much reason for a reinstall. It isn’t a terribly hard fix to go through, though getting the ATI drivers working has traditionally required (and still seems to require) a little bit of perseverance. And, since X, the graphical server, is no longer booting, you will have to deal with the command line. In my opinion this is not a bad thing, and if you stay with linux, you will certainly get a bit of experience at the command line sooner or later.
Getting X working again**

So, let’s get started. When you boot and get a black screen, you should be able to type Ctrl+Alt+1 to get the option to log-in in a text terminal. Type in your username and password, or, if you prefer to by-pass all the sudo commands, log in as root, as we will be working on files with root permissions.

The first step is to change the config file for X to tell it not to try to use the ATI driver you just installed, but to use the generic ati driver instead. To do this:

cd /etc/X11

First, back up the config file with

cp xorg.conf xorg.conf-fglrxfailed

Then, edit your xorg.conf file with your favorite text editor and change any text

Driver     "fglrx"


Driver     "ati"


You should now be able to reboot your system and have the graphics load again, of course without the new drivers.

If you wish to install the ATI fglrx drivers, you should download them from ATI’s site and install them manually. (I am using the 9.2 version; I haven’t taken the time to try 9.3.)

Assuming that you boot okay, I recommend that you back up the xorg.conf file again, so that you have a working copy to fall back on.

Go ahead and remove whatever packages were installed by that one-click installer.

Installing the ATI drivers

Download the installer from ATI’s website.

Make sure you have all the header’s installed for your kernel.

Run the installer, select to install, and let it run.

When the installer finishes, run the command

sudo aticonfig --initial

After you do this, either restart X with a double Ctrl+Alt+Backspace or reboot your machine. You should have the drivers working. To check, run the command “fglrxinfo” in a terminal and make sure the output displays the version of your card there, and doesn’t mention “mesa” anywhere.

If any of this doesn’t work, post back here and we will see what other help we can get you.

Good luck, and welcome to openSuSE!

I did this, as I’ve been having trouble getting the ati drivers going lately.

When I restarted X (ctrl alt backspace) it gave me a very distorted picture, although I can see movement when I move my mouse. I’m guessing Theres something not right in my xorg.conf file? has anyone else been able to solve this problem? I did it with Catalyst 9.2 on openSUSE 11.1 64 bit.

For the record, my card is a radeon 9850.

Last year I ran a laptop with a Mobility Radeon 9800. The laptop died, so I don’t know about the current drivers, but I ran into a similar problem when updating those drivers once. I had to regress to an earlier version of the drivers to get it to work. (I think I was upgrading to 8.11 and had to regress back to 8.9, but I don’t remember completely.) I don’t know if it is the same problem, as I know there are a few things that can cause a garbled screen from my own experience.

If you would like to post your xorg.conf file, I would gladly take a look at it, if you think your problem is there.

Thank you very much for your answers.
I haven’t replied for two weeks, because I was on vacation :).

I haven’t tried the cmd-line solution yet, but I will do so soon.

Thank you,

On my PC, the shortcut Ctrl+Alt+1 doesn’t work.
Any idea why?