Ati driver 9.6 - missing dependencies

I tried to install the Ati driver (current version 9.6) following the official guide here:
Hardware - Installing ATI Drivers - openSUSE Forums

I’ve installed the entire “Kernel Development” package with all dependencies, as recommended in some other thread.
I’ve also installed the packages mentioned at the beginning of the guide:

zypper in kernel-source gcc make

I’ve then built the package for 11.1, which worked without problems.
However, if I then try to install it in a su terminal, it says it’s lacking dependencies:

rpm -Uvh fglrx64_7_4_0_SUSE111-8.62-1.x86_64.rpm

error: Failed dependencies: is needed by fglrx64_7_4_0_SUSE111-8.62-1.x86_64 is needed by fglrx64_7_4_0_SUSE111-8.62-1.x86_64 is needed by fglrx64_7_4_0_SUSE111-8.62-1.x86_64

I already tried the following:

zypper in libstdc++

but that just tells me that libstdc++ is already installed.
What do I need to install to resolve the dependencies?

Hey Nichiren,

Sounds like someone else has been having the same trouble. This might be of help to you:

Strange problem with ATI driver (Page 4)

Hope this helps you resolve your problem! :slight_smile:

Yes, I hope that as well.

If you still have the problem, let us know and we’ll help to find an answer for you. :slight_smile:

I tried anything you should install listed in that thread, but still no dice… all the same missing dependecies >:(
I’m starting to lose patience with openSuse, had nothing but trouble so far.


the libstdc++ exists in different versions. the so.5 should be packaged with libstdc++33

have a look at Index of /distribution/11.1/repo/oss/suse to find the package. installing the 33 version could get you one step further … :wink:

ps.: choose the right one for your architecture (32bit -> i586, 64bit -> _x64)

Installed that libstdc++33, and it indeed did resolve the dependencies.

I then ran the rmp imstall, aticonfig and sax2 from a root init 3 command line:

rpm -Uvh fg(press tab to autocomplete)
aticonfig --initial -f
sax2 -r -m 0=fglrx

Sax2 launched its config server and asked me if I wanted to use the settings, and I agreed. The dialog disappeared, and Sax2 crashed with a frozen mouse pointer on its config screen, so I had to reset.

After the reboot, fglrxinfo reported Ati, but some things are still not right:

  • when I move windows horizontally, the horizontal borders flicker wildly.
  • the console and other apps still tell me that transparency is not supported (yet it works on my fedora 11 live usb stick)
  • when I choose to reboot from the menu and clicked Reboot on the dialog, I got a screen full of colourful garbage.

Obviously, something went wrong :silly:
Somehow, openSuse just doesn’t want to work properly for me:

  • first the stupid installer message about the supposedly inconsistent fs, which suddenly went away after I used a 3rd party partitioner to create unpartitioned space
  • then the issue with mounting the disks
  • ati installer won’t run at first
  • then I have to hunt down all the dependencies
  • now it still doesn’t run properly >:(