Ati Driver 1Click update and No X anymore.

I’ve tried to update my Ati Radeon Mobility 9000;s driver with the one on official suse pages titled ATI_Driver_HOWTO. After install that 1click solution, I’ve change the driver line with fglrx in my xorg.conf and made a copy old one. After restart it didn’t start the X and I took back my original xorg.conf but didn’t work to start X. I get bored to install opensuse after every ATI driver experiment. Normally, it works well after removing the line virtual with the MESA driver. Could you give me any idea to take back my system to original state. Now I can enter the console; I don’t whether I should name it console or not. Thanks

ATI dropped support for that card over 2.5 ago, use the free driver “radeon” instead.

Yeap I know it, but at the comment part of the 1click installation it says that M9 and later graphics card are supported. That;s the reason why I tried to install it.

I;ve just check that I can not get any console view even I start the system in failsafe mode. How can I fix it without any console. I think I have to install opensuse again. phuffff

You can launch yast sw_single from console, search for packages with keyword “fglrx”. There should be two packages with name starting with fglrx- . Remove them, reboot (failsame mode again) and run sax2 -r .

Bull****, just start opensuse with

vga=normal 3

(to be typed in at the boot screen) and use yast as described before.

yeah that was bul*** , but it works now.

On what repositories can I find the fglrx packages using Yast?. I can’t find them with the default repositories =/


The fglrx packages are NOT on the opensuse repositories. You should add the ATI repository. Please see ATI - openSUSE for details.