ATI Driver + 11.4 -> can't boot to KDE?

Hi everyone,
after installing 11.4 I can no longer boot into KDE using the ATI driver from their website. Same thing happened prior to 11.4 but I assumed it was an out of date driver so I updated SUSE + the driver, no difference. Boots straight to command line.

I was getting errors about the Xorg.conf.old file unable to be overwritten when I tried ‘Xorg -configure’. I did find a few solutions from other threads and simply deleting Xorg.conf allows me to boot into KDE using the default (whatever that is) graphics driver (fps is very low but it boots at least).

Any time I reinstalled the ATI driver/tried to use it it would die again. After a bit of searching around the log files for Xorg and X11 I found an error about “display not found” or something of that nature and then it was giving up and booting to cmd. had it working fine in the past prior to a software update (either driver or kernel or both, I don’t remember) so I’m not entirely sure what broke it.

I can give more specific error details once I get home in an hour or two but I’m just wondering if the latest ATI driver (11.2? I think it is) is compatible with openSUSE 11.4 and if anyone has a solution to this problem.

Try the Failsafe boot or
Add nomodeset to the boot argument

I typically build my ATI graphic driver the hardway. I found for my Dell Studio 1537 laptop with a Radeon HD3450, that I needed to specify ‘nomodeset’ when booting, and then build the driver ‘the hardway’ when building the proprietary driver. I also had to build the driver for openSUSE-11.4 with openSUSE-11.3 settings because the ATI/AMD proprietary driver does NOT claim support for openSUSE-11.4. So one has to be aware of that fact, … ie the driver may or may NOT yet work with 11.4, hardware dependent.

Its also possible, before building the ATI/AMD proprietary driver, than one may need to run “yast” (you can run yast in text mode with root permissions if X window not available) and navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted.

But the bottom line, unfortunately, is AMD do NOT yet support openSUSE-11.4 with their proprietary Linux driver.

Thanks for the replies.

Try the Failsafe boot or
Add nomodeset to the boot argument

nomodeset didn’t appear to do anything unfortunately, and failsafe boot took me to command line as the normal boot did :frowning:

Fortunately I managed to realise I’d stuffed up the driver installation. I was following these instructions here (under “The hard way”): SDB:ATI drivers - openSUSE
I assume that’s what you were referring to oldcpu, as the “hard way”?

Basically I generated the package but forgot to actually install it via “zypper install”. :embarrassed:
Running it via KDE didn’t seem to work as I’d tried it earlier. Once I installed it using zypper, it booted up fine using ATI drivers 11.2. For the record I’m using an ATI 5850HD.

Not sure if anyone has access to the page at SDB:ATI drivers - openSUSE, but it may be worth adding in a line for other linux newbies to actually run it through zypper before proceeding with the “aticonfig --initial”. Thanks again!

Just a small report: I tried to add the ati repo for 11.4 (simply by taking the url for 11.3 and changing 3 to 4). This actually seems to work - the installation of the drivers through yast is possible. But then the system also boots into command line.

I did not try the nomodeset option.

I did not try the nomodeset option.

why not???