ATI- driver (1 click install ) failes.

I have 11.2 running on a 64 bits machine (Pentium HT) and added a ATI-videocard HD2400 pro.

I found a simple 1-click install on
ATI drivers - openSUSE
and choose the install for 2000 series and newer.

As told , logout and log back in, but no way, X is broken.
Even a complete reboot still broken.

I had backup from xorg.conf so placed it back to have X again.
I also noticed with lsmod | grep fglrx:
fglrx 2279288 0

So there is a driver present now, but what went wrong is my question.

Okay, did some troubleshooting myself:

cat /var/log/Xorg.0.log | grep “(EE)”
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) RADEONHD(0): The fglrx kernel module is loaded. This can have obvious
(EE) GLX error: Can not get required symbols.
(EE) config/hal: couldn’t initialise context: unknown error (null)

as told me on:
ATI troubleshooting - openSUSE

Ok, then start step 1 thru…
but at step 2 NO rpm available, I deleted it in step 1 didn’t I ?

The idea is to install the latest (most current) rpm in step-2. But before one does that, it has to be removed in step-1.

I understand you saying :), but now my question is:

How do I get a new rpm from the driver ? In the Yast-way with the 1-click install it removes the rpm after install (or must I change some settings in Yast temporarely ?)

The ATI-way gives me a *.run file what is a shell installscript, so anyway not a rpm. Maybe some guru’s could extract an rpm from it but I do not know that.

Fact is that the 1-click install is not working in my case, so that easy option seems to easy to be tru…well it shows anyway in my case :slight_smile:

The *.run file when executed will automatically build the rpm and put the rpm in the same directory as the .run file. One does need to ensure (prior to executing the .run file) that one has kernel-source and kernel-syms (matching one’s kernel version) already installed, plus linux-kernel headers and the appropriate compilation programs (I typically select the baseline developement pattern in yast software management).

I’ve never used the one-click install so I can not answer any questions on that.

At least back in 10.3, the ATI route seemed to be the most consistent way to get working drivers. It could be different now, but I have not had much luck in the past with ATI and 1 Click Install. A couple of points I remember from generating my own RPM:

  • I believe the script is not executable by default and you have to manually set it (chmod a+x yourfile
    .run)*]Pay very close attention to the options the script presents, or it will not build you the right RPM *]As oldcpu mentioned, make sure you have kernel-headers and development tools installed

I hope that gets you started.

MatthewEhle, I will take your advice in account.

Btw, I had troubles installing from ATI run script before: the grafical way says everything went well, but in console I had some messages, wich I do not know if the are fatal or not.

Also I noticed the .so -files generated were not executable, maybe I had to set executable first like you said.

Main point now is: when using the ATI runscript: should I install or build a package for my distro ?

Since you were able to run the script, it is already able to execute, so you should be good there.

As for generating .so files, that doesn’t seem right. It should provide you an RPM, which you can then install via the RPM utility or YaST. Unless there is something that I don’t remember…

You should have it build a package (RPM) for your distro. After you build it, you can then install it. If you still have some troubles, I’ll try to reproduce the steps I took to get it working.

Using the ATI-runscript and choosing to build a suse112 amd64 package fails:

Out[ut of fglrx-install.log:
/tmp/ati.2XqU4j
Package build failed!
[Error] Generate Package - error generating package : SuSE/SUSE112-AMD64

So I think I am stuck here for the moment

I noticed on the ATI site that the driver for your card was updated yesterday. Have you tried that?

ATI Display Driver HD2400

I tried this shell script on my 11.2 system and was able to produce an RPM out of it. Here are the specific steps I did.


chmod a+w ati-driver-installer-10-1-x86.x86_64.run
sudo ./ati-driver-installer-10-1-x86.x86_64.run
  • Selected Option 2 (Build Package)
  • Pressed OK
  • Agreed with everything they told me :\
  • Chose my install path (I did /tmp as well)
  • Pressed OK
  • Selected SuSE Packages, then OK
  • Chose my SuSE flavor and architecture (I have always done this with 32 bit, so I can’t help with 64)
  • Waited for a minute, after which the RPM was built

I was able to generate a 32 bit RPM, but I got the exact same error when trying to go 64 bit. Since my installation is 32 bit, my guess is that you are missing some 64 bit libraries. Since I don’t have a 64 bit installation, I don’t think I can go much further than that.

Yes, thanks for trying, but I had no luck even try 32 bits or 64 bits: it does not give me a rpm. What I do notice is that in /tmp their is new map called /fglrx with lots of files and 2 submaps…I assume these are what I need, it is only not an rpm. Maybe there is a workaround to move everything to a certant place ? and after that how to continue ?

btw yes I have used latest 10.1 version, but no differents.

That’s strange that you don’t see an RPM out of it. Mine is named fglrx_7_4_0_SUSE112-8.69-1.i386.rpm. Maybe you could try something like:

sudo find / -name fglrx*.rpm

It seems that ATI should provide an easier way to do this, but I have had no such luck personally. This is one of several reasons why I go nVidia now.

No, nothing to find… :frowning:
I think I am stuck, I really do not understand why I cannot build an rpm from the file. My last hope would be if anyone with 11.2 and 64 bit would want to build it for me and then sent me…

BUT… :slight_smile: looking around with find I noticed something else:

In /usr/src/packages/BUILDROOT I found a MAP called:
fglrx64_7_4_0_SUSE112-8.69-1.x86_64 with submaps /etc/ and /usr with a lot of submaps and files…

Does this bring some light ??

I see the same that you do in my /usr/share directory. It seems the only difference is the RPM :\

The release notes indicate a number of libraries needed, beyond what we outlined before. Most of these are likely already installed, but you could be missing some important ones. The release notes can be found at
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_101_linux.pdf

I can provide a 32 bit RPM built against the 2.6.31.8 kernel, but I can’t promise anything as far as it working on your setup…

Yes I know those libraries, only thing I cannot find with Yast or Zypper on my 11.2 are those 2 XFree86 libs, but probably they are present under another name on 11.2

I also wonder if I don’t have to solve the problem regarding buildpkg first, when I do:

sudo sh ./ati-driver-installer-10-1-x86.x86_64.run --buildpkg SuSE/SUSE112-AMD64 I get:
Package build failed!

So is it going wrong just with this file, or a general build-problem…I wonder how I could check if buildpkg is working properly.

Also I ask again if in the mean time someone could provide a rpm from this driver for 11.2 64 bits

ok, I tryed ATI driver again to install :
./ati-driver-installer-10-1-x86.x86_64.run

It goes wrong, in fglrx-install.log I read:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Error] Kernel Module : Kernel module build environment not found - please consult readme.

those “repcompiled” kernel messages suggest to me you still have the “fglrx” rpm installed that must be removed first if you are going to go that compilation route.

Yes you were probably right…

I have uninstalled it the ATI-way and also the Kernel way ( /usr/src/linux make mrproper ect…)
Because I am trying both ways and both ways fail :frowning:

I am confused: all I read about installing this driver keeps failing.

Most annoying is the fact I cannot get an rpm from the ATI-package…pfff…

Also note I had troubles with this one on 11.2 before but then the 1-click install solved it…until a “sudo zypper dup” destroyed it again !!! thank you zypper for this behavior…

…also I would not need it if default driver was good enough, but on default installation X is very slow on my computer, most annoying is very slow scrolling in Firefox and not able to run any video (slow too) and it uses almost 100% cpu…****