ATI + Desktop Effects = White

Just installed 11.0 a few hours ago, installed the latest, or I assume latest ATI drivers via one click method, enabled Desktop Effects and I now have a pure white desktop.

How do I, or can I, disable Desktop Effects from the terminal?

I restored the automatically saved xorg.conf but it didn’t help.

I have an X1800XT btw, should Desktop Effects work under that?

Oh and what command line text editors are available for Suse? I’d love nano or something mildly usable unlike vi or vim. Is there a way to list all present editors?

I assume you’re using KDE, as the ‘white screen of death’ seems to be more common with KDE. Am I right?

Does the x-server start at all? When do you get the wsod?


No I’m using Gnome. X starts, for a few seconds you can see glorious green and the Gnome loading splash screen, the screen flickers a bit while desktop effects are trying to start then everything goes white.

I ran sax2 from the terminal which made some edits to the configuration by itself and now alls working fine, although the effects do seem a slight be glitchy.

I also have the same problem you had. Is there any way you could give me some more details on how to fix this? I’m new to the openSUSE desktop.


When it boots into the white desktop press Alt+Ctrl+F1 to open a terminal, and type “su -” and enter your root password. Now type “sax2”. This will open the graphics and monitor properties. It will hopefully tell you that it has decided on a configuration and all you do is accept the changes, reboot your system.

i have too same problem that atis fglrx dont work its same with kde4 and gnome getting only white screen when enable desktop effects how i can fix the problem or can i fix it ?

Same problem here (except with KDE).

Same problem here. All of the desktop controls still work, just can’t seem them. Running Gnome on Mobility Raedon x1600. Fortunately the setting is profile dependent so you can log in as root and either create another account or delete/recreate the one with the issues. I have to say that it is good to see others having the same issue. I also downloaded and installed the ATI drivers from ATI, and still have the issue.

My card is an ATI x1800 Mobility Radeon. Although the default radeonhd drivers work on all Live CDs and on the Gnome Install they fail on the KDE4 Install. Leaving me with a blank black (sometimes white) screen.

The 0=ati; 0=fglrx; 0=vesa settings do not work either. Although 0=vesa does respond to startX but fails on reboot.

I have tried installing the latest Catalyst 8.6 drivers dated 18th June from the command prompt but that, too, fails. It balks at the point of “Post Processing the Kernel Module”.

With the error message “There were errors during the installation. Details can be found in

The contents of the log:
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0

kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

I have tried every which way now and am at the point of giving up and moving on. Everything has been tried many times over, three installs of the Catalyst 8.6 in case there was a corruption in the file, and so on.

I have installed from the Live CD three times and from the DVD twice. The md5sums are correct for the install iso’s.

If anyone has any suggestions then I should love to hear them.

I’ve been doing some updates and configuring my system since the compiz wasn’t working, but I did see some ati updates come down as well as a kernel update, after restarting my 3d desktop started working. Worth a try to make sure you have all of the latest patches.

I got the same problem as well. It is cause by the desktop effect.

FYI, I am using X1300.

Anyone has a solution to that?? Else I’ll need to reformat and install a fresh one!

How do you update with the command prompt?

I have no way can access to the GUI desktop.

Hi, I have the ATI x1600 Mobility and am using Gnome and I have the exact same problem. Luckily I blindly clicked all over the screen and I clicked on the open DESKTOP EFFECTS window and disabled the effects and I have my desktop back. How can this be overcome?

How do you update with the command prompt?

I have no way can access to the GUI desktop.

Not having a wired internet connection, for me it meant getting the ATI driver on to my openSuSE partition by the backdoor.

I have two Linux distros on my computer. So from Ubuntu I can download the ATI Catalyst driver and copy it over to my openSuSe.

Then start openSuSe with a Level 3 boot and go from there.

But then it didn’t work anyway, so what do I know?

i too installed all those patches and then try to install that atis fglrxG01 and nothing still white screen and sax2 do not working from kernel its says only that acces denied as root only way was to remove that driver from kernel was with zypper,is there any way to make those fglrx drivers to work ?i have atis radeon x800 xl and with other distros fglrx drivers work fine with suse 10.3 i didnt have any problems with fglrx drivers

I have the same problem. If there was a way to disable desktop effects from the command line, it could be fixed. Reinstalling makes no difference. It must be something in the user profile that sets the effects. I had a look but couldn’t find anything. sax2 made no difference.

I have auto login enabled so I can’t use any other profile.

Here’s what sax2 did to my /etc/X11/xorg.conf to fix my white screen problem

Section "Device"
  BoardName    "Radeon X1800 Series (R520 7100)"
  Driver       "fglrx"
  Identifier   "Device[0]"
  Option       "CenterMode"
  Option       "VideoOverlay"
  Option       "XAANoOffscreenPixmaps" "0x856c388"
  Option       "Capabilities" "0x829a1e8"
  Option       "FSAAScale" "0x864bbd0"
  Option       "FSAAEnable" "0x864df58"
  Screen       0
  VendorName   "ATI"

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"

Section "DRI"
    Group      "video"
    Mode       0660

I got around this by deleting the .kde4 folder in my /home directory and re-installing. I just have to make sure now I never, ever enable desktop effects.

Opensuse 11 is great though… Apart from this, and a little problem with my wireless card (intel agn4965), it has been great.

Well done!

This might help some. It’s an easy work-around in graphic mode. (It repeats some of the above in 6 easy steps for beginners.)

  1. Get out of Gnome by pressing ctrl+alt+backspace. You may have to hold them down.
  2. At the login screen select a smaller window manager, not kde or gnome. Failsafe gnome doesn’t work either.
  3. Put in your name and password to get into the new desktop.
  4. Right click and open a file manager, and go to your home folder.
  5. Enable hidden files. Burrow down through .gconfig and apps til you find compiz.

Here’s what I did. I sent the compiz file to the trash. :eek::eek:

Whether this is legit or not, after a necessary reboot to sort out nautilus, I found my system seems to be working as before, and the compiz file had regenerated itself, and I vowed never to try desktop effects again.