ATI + Compiz?

I’ve installed the x11-video-fglrxG01 drivers, but when I enable Desktop Effects through simple-ccsm, the whole screen just goes White, and I can’t see beans :confused:

Any help?

Regards,

Søren

What graphics card do you have? Post your specs

My specs are:

ASUS P5K SE, with a Club 3D Radeon HD 3850. 2 Gigs of Kingston DDR 400 RAM (I think - which ever RAM fits into such a MOBO :D), a 200gb PATA drive and a 500gb SATA drive.

I’m ofc running openSUSE 11.

Do you need any more details than that?

Regards,

Søren

I had a similar issue when I first installed openSUSE 11. My card is a 3870, which is similar chipset. Seems to me something is wrong with the YasT2 drivers. I suggest downloading the drivers from ati website Drivers & Software and manually installing them. If you have further questions, feel free to ask.

I could use a hand :slight_smile:

The installer just exits with an error.
I get the following in the log:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0

initializing…
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

Now, I’d consult the README, but I don’t know where it is :slight_smile:

I read the install-document (https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_cat86-inst.html) but it doesn’t really handle the situation where something goes wrong… :confused:

However, I did make sure to install GCC and all the other stuff mentioned, if I could find it in the repository…

I could use a tip :slight_smile:

Regards,

Søren

post your xorg.conf and did it previously work with xgl, aiglx or ATI?

ah, remove the drivers you previously installed, so in runlevel 3, do:

 rpm -e $(rpm -qa '*fglrx*')
cd /nameofDriverDirectory
sh ati-driver-installer-8-6-x86.x86_64.run // driver you downloaded
rm /etc/X11/xorg.conf //remove xorg.conf that YaST did you for
touch /etc/X11/xorg.conf // create a blank new xorg.conf
aticonfig --initial --input=/etc/X11/xorg.conf //let aticonfig fill xorg.conf for you

That is what did it for me, hope it works for you.

Hello,

So, first - my xorg.conf:

/…/

SaX generated X11 config file

Created on: 2008-06-23T18:10:19+0200.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “ServerLayout”
Identifier “Layout[all]”
Screen 0 “aticonfig-Screen[0]-0” 0 0
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
EndSection

Section “Files”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
EndSection

Section “Module”
Load “dbe”
Load “type1”
Load “freetype”
Load “extmod”
Load “glx”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “InputDevice”
Identifier “Keyboard[0]”
Driver “kbd”
Option “Protocol” “Standard”
Option “XkbLayout” “dk”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Identifier “Mouse[1]”
Driver “evdev”
Option “InputFashion” “Mouse”
Option “Name” “Logitech Media Play Mouse”
Option “Pass” “3”
Option “Vendor” “Sysp”
Option “evBits” “+1-2”
Option “keyBits” “~272-287”
Option “relBits” “~0-2 ~6 ~8”
EndSection

Section “InputDevice”
Identifier “Mouse[3]”
Driver “mouse”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “ImPS/2 Generic Wheel Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Modes”
Identifier “Modes[0]”
ModeLine “1280x1024” 107.0 1280 1360 1496 1712 1024 1025 1028 1059
ModeLine “1280x1024” 87.8 1280 1328 1360 1440 1024 1027 1034 1053 +hsync -vsync
ModeLine “1152x864” 106.5 1152 1224 1352 1552 864 865 868 903
ModeLine “1152x864” 97.7 1152 1224 1344 1536 864 865 868 900
ModeLine “1152x864” 90.0 1152 1224 1344 1536 864 865 868 897
ModeLine “1152x864” 88.0 1152 1200 1232 1312 864 867 871 895 +hsync -vsync
ModeLine “1152x864” 81.6 1152 1216 1336 1520 864 865 868 895
ModeLine “1024x768” 83.0 1024 1080 1192 1360 768 769 772 803
ModeLine “1024x768” 76.9 1024 1080 1192 1360 768 769 772 800
ModeLine “1024x768” 70.5 1024 1072 1104 1184 768 771 775 796 +hsync -vsync
ModeLine “1024x768” 70.1 1024 1080 1184 1344 768 769 772 798
ModeLine “1024x768” 64.1 1024 1080 1184 1344 768 769 772 795
ModeLine “800x600” 50.3 800 840 928 1056 600 601 604 627
ModeLine “800x600” 45.9 800 840 920 1040 600 601 604 625
ModeLine “800x600” 44.8 800 848 880 960 600 603 607 622 +hsync -vsync
ModeLine “800x600” 42.3 800 840 920 1040 600 601 604 623
ModeLine “800x600” 38.2 800 832 912 1024 600 601 604 622
ModeLine “1280x1024” 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection

Section “Monitor”
Identifier “Monitor[0]”
VendorName “DEL”
ModelName “DELL 1907FP”
UseModes “Modes[0]”
DisplaySize 376 301
HorizSync 30.0 - 83.0
VertRefresh 43.0 - 76.0
Option “DPMS”
Option “PreferredMode” “1280x1024”
EndSection

Section “Monitor”
Identifier “aticonfig-Monitor[0]-0”
Option “VendorName” “ATI Proprietary Driver”
Option “ModelName” “Generic Autodetecting Monitor”
Option “DPMS” “true”
EndSection

Section “Device”

#BusID “1:0:0”
Identifier “Device[0]”
Driver “radeonhd”
VendorName “ATI”
BoardName “ATI Radeon HD3850”
Option “monitor-DVI-I_2/digital” “Monitor[0]”
EndSection

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
BusID “PCI:1:0:0”
EndSection

Section “Screen”
Identifier “Screen[0]”
Device “Device[0]”
Monitor “Monitor[0]”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x1024” “1152x864” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1152x864” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1152x864” “1024x768” “800x600”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1152x864” “1024x768” “800x600”
EndSubSection
EndSection

Section “Screen”
Identifier “aticonfig-Screen[0]-0”
Device “aticonfig-Device[0]-0”
Monitor “aticonfig-Monitor[0]-0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

next, I tried your code.
the sh-thing just launches the install… Which fails miserably :confused:

But what’s worse, after trying the installs (I think it was my own attempt, though), I can barely scroll! Everything just, well, lags…

Regards,

Søren

lags because you have no driver. What exactly does the output say when the sh “fails miserably”?

I figured it was something like that :confused:

It just says “error during install, see the log”.

The log says:

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0

initializing…
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

regards,

Søren

do you have kernel-source and kernel -syms installed?