ATI Catalyst, Installing

Followed steps from the PDF guide on ATI website.

1)Uninstalled everything i had under ATI Repository
2) did sh ./
3) Did the automatic install, using recommended settings

4)Went into run level 3 and did SaX2 -r -m 0=fglrx

5)Rebooted but cant get OpenSUSE to use the fglrx driver.

PD: Also, doing /usr/bin/aticonfig --initial didnt help

I think i may be missing some dependencies, but i couldnt find all of them under Packman or default repositories

ATI install notes advise not to run sax2.

Some folks report better install experience after removing all pre-existing fglrx drivers beforehand. I find I don’t have to bother.

On my AMD64 system, the 9.10 driver needs no xorg.conf file; it creates one as necessary.

See the /usr/share/ati/fglrx-install.log file to verify the module got built and installed OK.


Its not working, tried generating distribution specific packages, everything went well acording to the log you pointed, package shows as installed on Yast, but still cant get SUSE to use the fglrx driver

To clarify, the last line of fglrx-install.log is “done.”? And when you do


you don’t see fglrx?

If so, that is disheartening.

You could always remove /etc/ati/amdpcsdb, remove xorg.conf, reinstall via the .run file (just run it and accept all defaults), see what happens.


It may be a personal mistake, i had Kernel-Source for 2.6.31 and not for 2.6.27 (the one im on right now).

Ill get to you as soon as i install the driver under 2.6.31

Yep, stupid of me im sorry, it was all because the kernel-source package was for another version of Kernel. hehehe

Although, only doing “aticonfig --initial” didnt do the job, i had to do SaX2 -r -m 0=fglrx in order to get it working

Thanks for your help !!!

Just one last stupid thing, how can i launch ATI Catalyst Control Center?


Glad it all worked out. The whole sax2 thing bothers me, though. Some folks can’t live without it; AMD says don’t do it. I wish they had the story straight.