ATI Catalyst graphics driver install failure in SuSE 11.3


I tried to install the ATI proprietary driver for an HD 5800 (Catalyst for Linux 64 bit, v. 10.8).

The two main instruction sites are:

SDB:Configuring graphics cards - openSUSE

SDB:ATI drivers - openSUSE

I chose the hard way method. I downloaded the driver. Restarted SuSE 11.3 in mode 3. And as SU followed the method above, including adding the zypper programmes (which found some already installed and which installed a whole lot more).

When I then attempted to run the install (sh ./ and selected automatic mode. It completed 82% and stalled attempting to install “Postprocessing Kernel Module”.

I pressed control c to kill the process and attempted to re-install using the manual mode and then using the build mode. In both instances, same outcome.

When I rebooted, and entered my password, the desktop did not load but sent me back to the username/password page. I can’t get back in. Does not matter as I have backed up my docs.

Before I ask my question, here is some context. First, I decided to install the proprietary driver because the colours on the desktop corrupt after the 2nd boot following a clean install. i.e. on the initial boot the colours are fine. Second, this is the 3rd effort I have made to install the driver after a clean install of SuSE 11.3 and there is no change in outcome.

So, my question: anyone any suggestion what is going on and how I can install the driver successfully? Or, do I not understand the new regime in SuSE 11.3 and should I not attempt to install a new driver. (Frankly, I admit, I don’t understand the new driver regime, but I would like to better understand).

I hope I have given enough info. I’m somewhat nackered after the efforts (like banging head against brick wall).

Many thanks for the help.


Ensure you have no rpm with fglrx already installed when you do this. If you do then remove that rpm.

Before executing the

sh ./ --buildpkg SuSE/SUSE113-AMD64

[or what ever it is for your PC - my example is for a 64-bit openSUSE-11.3 install] ensure you have first installed kernel-source, kernel-syms, gcc and make.

Also, execute that command with root permissions from a full screen run level 3 direct boot (and not via the GUI terminal nor with X running). Note it could take a LONG time with the “Postprocessing Kernel Module” message, so give it some time. A lot of time (ie a number of minutes if need be).

Hello, Oldcpu,

Many thanks for your kind reply. I appreciate how busy you are.

I have some questions shortly, but in the meantime here is what I have done. I restarted the sh ./ process from init 3. I selected the automatic install. As predicted, at 82% the system hung (or at least showed no progression) for over an hour.

I then attempted to select the build option. However, it would not let me select SuSE and would only let me select RedHat. Any ideas why? (I tried everything - shift; control shift; alt shift; arrow keys; and so on). The RedHat option remained X’ed and I could not get it to select the SuSE option. Any suggestions how to correct this (command line option perhaps?).

I ended up tonight reinstalling SuSE 11.3.

My questions, if you have time (and apologies if they appear a bit simplistic (I am still, and forever will be, learning))

(1) how do I determine if I have an rpm with FGLRX installed?
(2) I enquired what buildpkg supports and it responded with SuSE 11.3 AMD64 and IA32. I have an Intel 1366 chip. Does this suggest it is not supported?
(3) If the answer to (2) is that the Intel 1366 is supported, what option should I use after “–buildpkg”?
(4) How long does the postprocessing kernel module process take? Is an hour without any advance beyond 82% suggestive that there is another prroblem?
(5) Executing your code (sh ./ --x-AMD64) resulted in an RPM package being built. Assuming the -AMD64 is the correct code option for an i1366 processor and SuSE 11.3 64, do I execute the RPM package simply by typing RPM -i packagename.rpm? Then what?
(6) I have always attempted to execute the ati-driver from init 3. And I followed the zypper instructions in the forums links as recommended. It installed a lot of extras after identifying that many of the apps were at their proper level. Does this suggest there was a problem in my blind use of zypper?
(7) Finally, desktop effects are not selected. When selected, a message appears saying desktop effects can’t be initiated. Does this suggest something? After all, I have a very powerful video card.

I have never purchased a powerful video card before this purchase. Now, I regret buying it. I always relied on the video chipset on the MB. Never had a problem before. Now, seems I have no end of problems.

Just to remind you that the reason I sought to install a new driver was because the colours on the desktop corrupted on the 2nd boot. This corruption occurred again on tonight’s reinstall of the o/s.

Many thanks for any suggestions.


If you know how to
[li]exit X or boot in runlevel 3[/li][li]copy/paste the code I’ll post here and save it into in a file. Let’s call this file atiupgrade[/li][li]execute this script either[/li][LIST]
[li]by typing: bash atiupgrade [/li][li]or by making it executable with chmod 755 atiupgrade and then run it by typing ./atiupgrade[/li][/ul]

If you want to
[li]install (and/or package into a rpm) the latest Catalyst driver (10.9)[/li][/ul]

If you have
[li] a ATI HD Radeon graphic card[/li][li] an internet connection (as the script will download the file from ATI website)[/li][/ul]

Then you can try this script (I did post it already but could not find where.)

#! /bin/bash

# --------------------------------------------------------------
# What This script does the following :
# - unload fglrx if needed
# - make a copy of /etc/X11/xorg.conf (if any)
# - download ATI Catalyst 10.9 for your architecture
# - deinstall the repo driver (x11-video-fglrxG02 ) if it was previously installed
# - run the ATI installer  
# as always ... yuou're using it at your own risk.
# $ Agnelo de la Crotche - 31.08.2010
# --------------------------------------------------------------

mach=`uname -m`

# define x86_64 and i686  installer

# don't run in X
[ "$DISPLAY" ] && exec echo "this script cannot be run in X"

# unload fglrx 
lsmod | grep -q fglrx && modprobe -r fglrx

# exit if fglrx is still loaded 
lsmod | grep -q fglrx && exec echo "fglrx is still loaded"

# save /etc/X11/xorg.conf (just in case)
[ -f /etc/X11/xorg.conf ] && cp /etc/X11/xorg.conf{,.pta}

# make sure wget is installed
which wget > /dev/null 2>&1 || zypper in wget

# get the ATI installer for your architecture (i686 or x86_64)
wget ${!mach}

# look for the ATI installer in the current directory
ati_install=(`find . -name "ati-driver*$"`)

# cancel script if 0 or more than 1 installer found
if [ ${#ati_install[li]} -gt 1 ] ; then[/li]	exec echo "several versions of the ATI installer found. Script aborted."
elif [ ${#ati_install[li]} -eq 0 ] ; then[/li]	exec echo "no ATI installer found. Script aborted."

# let's doublecheck ! :-)
AtiInstall=`basename ${ati_install[0]}`
[ -f ./$AtiInstall ] || exec echo "no ATI installer found. Script aborted."

# uninstall x11-video-fglrxG02
rpm -qa | grep -q x11-video-fglrxG02 && zypper rm x11-video-fglrxG02

# run ATI installer if x11-video-fglrxG02 successfully removed
rpm -qa | grep -q x11-video-fglrxG02 || sh ./$AtiInstall

It will detect/uninstall any previous installed fglrx, get the run file from ATI and execute it. I you choose to create a rpm (that’s what I do), just give /tmp as the install path, select openSUSE and version 11.3. It will create an rpm package in the current directory. The latest it created for me was fglrx64_7_5_0_SUSE113-8.771-1.x86_64.rpm

Once the ATI script is done, all you have to do is to install the rpm with this command:
rpm -ivh fglrx64_7_5_0_SUSE113-8.771-1.x86_64.rpm (notice that the name of this file might be slightly different).
Then start X or reboot in runlevel 5.

Notice that atiupgrade doesn’t mean that you must have another Catalyst version already installed. The script works in both cases (install or upgrade).

Please report if it works (or not), It does for me.

  • I think the ATI run file is the same for x86_64 and i686 architectures. But I’ve been using my script only on 64bit system. If you’re on AMD64, you’re fine.

Sorry man, it doesn’t work for me. I have 64 bit 11.3 version and I’ve run your code (./atiupgrade) and the code does great it does what it’s supposed to do, but when I reboot my system I get no changes in graphics. ATI Catalyst Control Center is however installed, but when try running it, CCC doesn’t start.

I have now tried to install driver with rpm, just as you explained. And now i get this message: (package “kernel-source” needs to be installed by yast2 first!). But I installed kernel-source before I tried to install rpm and I had even reinstalled it and still nothing!

Please, what is the output of:

rpm -qa '*kernel*'

I forgot to write all that it said when I tried to install the package. So here it is:

Package “kernel-source” needs to be installed by YaST2 first!

Building/installation of fglrx kernel module failed! Try again
by calling “/usr/bin/” manually.

Please read “/usr/share/doc/packages/fglrx/README.SuSE” for
configuration details when using SaX2.

About the output:


If you wish to build a driver then it is important that the source code is the same version as that of your kernel. Clearly that is NOT the case, and I think what I have highlighted above should illustrate that to you. You need to update your kernel-source and kernel-syms so that those versions match that of your kernel-desktop.

I’ve heard so many times, that kernal packages need to match up:shame:. Jesus I feel so stupid:P So I’ve tried to update those two packages, and I couldn’t because those packages are the latest versions. What now?

So than I decided to update kernel-desktop package in yast, and at first it didn’t say that thare is any latest version available, but I updated it anyway and it worked! But now there is a new problem. It instlled new driver, but when I went to see the version of Catalyst driver it said that it is 10.6 not 10.9! Is that just a small mistake, or my driver didn’t install properly?

It’s a mistake. I see that too. If you did create and install a rpm using my script, you have the latest driver.
rpm -qa | grep fglrx says fglrx64_7_5_0_SUSE113-8.771-1.x86_64
however amdcccle reports:
Driver Packaging Version: 8.741-100527a-100955C-ATI
I don’t understand that either, but I think it’s a mistake.

Hello PTA,

Many thanks for the kind and very fulsome reply.

I ran your script in mode 3 as root and, as with my experience in manually installing the ATI driver, it did two things. First, I attempted to create an rpm package by using the ‘advanced’ mode and attempting to select SuSE. However, the default was RedHat and I could not for the life of me change the default to SuSE. I highlighted SuSE with by using the down arrow key, but that is as far as I got. When I pressed enter, the RedHat option engaged and presented its options.

I then restarted the script, and let the automatic (recommended) mode work. However, as with my manual effort, earlier, it stuck on “installing 82% postprocessing kernel mode”. I left it for about an hour. No change. I have an intel 1366 processor with 6GB of ram, so I expect this is not a waiting game but some fault.

I know that when I attempt to re-boot, it will not go into graphics mode as whatever was the default graphics driver, it will have been removed.

I am now considering reverting back to SuSE 11.0.

Any thoughts as to what is happening and what else I can try?



If you read the comments in my script, you’ll see that it does nothing extraordinary.

Basically it only deinstalls a previous installed fglrx rpm package (but it doesn’t remove the files of a manual installation. I should probably add that), downlads the ATI installer and executes it.
What you describe doesn’t occur within my script (at this point, it has already completed its job) but in the ATI installer. It means you would have had the same problem if you had run the ATI installer from the command line. I didn’t have this issue while creating a rpm, I was able to choose openSUSE and the version 11.3, finally got a rpm in current directory and installed it. I don’t know

  • why you wasn’t presented that choice (maybe you just hit Redhat and not openSUSE ? )
  • why you got stuck at 82% (but there is obviously something wrong). Before invesigate further, I would download the ATI installer again and run it from command line (you don’t need to run my script twice, as it already deinstalled fglrx).

Notice that the script doesn’t install the kernel sources for you. I should add that too.

I assume that there is no answer, that the fault is with the installer or with SuSE as the hardware is ATI.

It sounds as if there is no solution as no one else appears to have a problem selecting SuSE as a build option in the installer or actually installing the driver.

Just to make it clear, the installer will not let me choose SuSE as an advanced installation option. The “X” remains on the Red Hat option. I cannot move it to either SuSE or “Other”. I can move the highlighting with the cursor key but that does not select the option. I cannot press alt X or alt S or alt u as this cancels the installation. Simply pressing s or u or e does not assist either.

I have no idea if there is a clue in the fact the SuSE build option cannot be selected, but I suspect there is. But the bottom line is that the graphics on SuSE 11.3 on a new build corrupt on the 2nd reboot after installation and the ATI prop driver can’t be installed. I think the only solution may be to return to SuSE 11.0.


What’s the checksum of the ati installer you have ?
**md5sum **
I should be : 546fb626b1f1ea69f9b3d9b8d54c2576

and what does gcc point to :
readlink /usr/bin/gcc

From root in init 3, checksum accords with yours.

There is no output or error message using readlink /usr/bin/gcc The command line simply appears blank.

What are you expecting as the output?

Many thanks for the kind help.


I expected : gcc-4.5
As strange as it might sound, I did notice on i686 systems (only) that /usr/bin/gcc pointed to gcc-4.3 (which has never been installed). As a consequence, in this particular case, the VirtualBox module could not compile and I assume it would have been the same with the fglrx module (assuming the ATI installer uses gcc … but I’m not sure if it actually compiles fglrx).

Thanks. Clearly, then, does this say I do not have gcc installed? Do I need it?


to heseltine

yes, you do need gcc installed as well as kernel headers. Please read this thread openSUSE Lizards » ATI HD57xxx fglrx drivers under 11.3. It will give a complete list of requirements to install ATI drivers.

To All,

and I need some guidance myself.
I’ve installed ATI drivers using the scrip posted here (except I had the drivers on my HDD already so I amended the script to take drivers from my HDD and not to download).

What I did - I’ve run the scrip as root after booting to runlevel 3 for Dektop Kernel. Drivers installed correctly on my desktop kernel, but I also have xen kernel installed and drivers do not work with xen kerlen.

I have tried booting to runlevel 3 with xen kernel and run the script again, hoping it will compile drivers for xen kernel, but it didn’t. Instead, it has disabled (desktop effects, no 3D) desktop kernel drivers.

Then I rebooted to runlevel 3 with desktop kernel and run the script again. That has restored ATI drivers to desktop kernel but now I cannot boot with xen kernel to runlevel 5 anymore. I get blank screen.

How do I get ATI drivers functioning on desktop and xen?

thank you in advance.