ATI Catalyst/Fglrx Config Assistance please

Or at least I hope the issue is with my config.

I received a Radeon HD 3450 for Christmas just a few days ago, I’ve been trying since then to get it working properly.

Drivers installed from the installer on ATI’s site.

Fgl_glxgears output is

Using GLX_SGIX_pbuffer
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

I get something similar when I try to run amdcccle, and when I run glxinfo | grep direct

Xorg.conf:


# /.../
# SaX generated X11 config file
# Created on: 2009-12-29T08:33:05-0500.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [SaX2] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
	Identifier     "Layout[all]"
	Screen      0  "Screen[0]" 0 0
	InputDevice    "Keyboard[0]" "CoreKeyboard"
	InputDevice    "Mouse[1]" "CorePointer"
EndSection

Section "Files"
	InputDevices   "/dev/gpmdata"
	InputDevices   "/dev/input/mice"
	FontPath     "/usr/share/fonts/misc:unscaled"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/75dpi:unscaled"
	FontPath     "/usr/share/fonts/100dpi:unscaled"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/URW"
	FontPath     "/usr/share/fonts/Speedo"
	FontPath     "/usr/share/fonts/PEX"
	FontPath     "/usr/share/fonts/cyrillic"
	FontPath     "/usr/share/fonts/latin2/misc:unscaled"
	FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
	FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
	FontPath     "/usr/share/fonts/latin2/Type1"
	FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
	FontPath     "/usr/share/fonts/baekmuk:unscaled"
	FontPath     "/usr/share/fonts/japanese:unscaled"
	FontPath     "/usr/share/fonts/kwintv"
	FontPath     "/usr/share/fonts/truetype"
	FontPath     "/usr/share/fonts/uni:unscaled"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/ucs/misc:unscaled"
	FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
	FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/misc:unscaled"
	FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
	FontPath     "/usr/share/fonts/hellas/Type1"
	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
	FontPath     "/usr/share/fonts/xtest"
	FontPath     "/opt/kde3/share/fonts"
EndSection

Section "Module"
	Load  "dbe"
	Load  "freetype"
	Load  "extmod"
	Load  "glx"
	Load  "dri"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
	Option	    "AllowMouseOpenFail" "on"
	Option	    "IgnoreABI" "on"
	Option	    "ZapWarning" "on"
EndSection

Section "InputDevice"
	Identifier  "Keyboard[0]"
	Driver      "kbd"
	Option	    "Protocol" "Standard"
	Option	    "XkbLayout" "us"
	Option	    "XkbModel" "microsoftpro"
	Option	    "XkbRules" "xfree86"
EndSection

Section "InputDevice"
	Identifier  "Mouse[1]"
	Driver      "mouse"
	Option	    "Buttons" "5"
	Option	    "Device" "/dev/input/mice"
	Option	    "Name" "Aiptek International Tablet"
	Option	    "Protocol" "explorerps/2"
	Option	    "Vendor" "Sysp"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "Modes"
	Identifier     "Modes[0]"
EndSection

Section "Monitor"
	Identifier   "Monitor[0]"
	VendorName   "HWP"
	ModelName    "HP MONITOR"
	UseModes     "Modes[0]"
	DisplaySize  340	270
	HorizSync    30.0 - 62.0
	VertRefresh  43.0 - 60.0
	Option	    "CalcAlgorithm" "XServerPool"
	Option	    "DPMS"
	Option	    "PreferredMode" "1280x1024"
EndSection

Section "Device"
	Identifier  "Device[0]"
	Driver      "fglrx"
	VendorName  "ATI"
	BoardName   "ATI Radeon HD 3450"
	Option	    "Capabilities" "0x00000000"
	Option	    "VideoOverlay" "on"
	Option	    "OpenGLOverlay" "off"
	Option	    "XAAnoOffscreenPixmaps" "off"
	Option	    "Centermode" "off"
	Option	    "TexturedVideoSync" "on"
	Option	    "UseFastTLS" "1"
	Option	    "Textured2D" "on"
	Option	    "BackingStore" "on"
	Option	    "FSAAEnable" "off"
	Option	    "FSAAScale" "0"
	BusID       "PCI:3:0:0"
EndSection

Section "Screen"
	Identifier "Screen[0]"
	Device     "Device[0]"
	Monitor    "Monitor[0]"
	DefaultDepth     24
	SubSection "Display"
		Depth     15
		Modes    "1280x1024" "1024x768" "800x600" "768x576"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes    "1280x1024" "1024x768" "800x600" "768x576"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1024x768" "800x600" "768x576"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes    "1280x1024" "1024x768" "800x600" "768x576"
	EndSubSection
EndSection

Section "DRI"
	Group        "video"
	Mode         0660
EndSection

Section "Extensions"
	Option	    "RENDER" "Enable"
	Option	    "DAMAGE" "Enable"
	Option	    "Composite" "Enable"
EndSection

I’d greatly appreciate any help. I’ve been on Linux since February, however previous to now, I’ve only used nVidia and Intel GPU’s.

Why don’t you try the drivers from the ATI repo. I use it and have no problems.
If you really want the drivers from ati site then are you sure you have installed all the needed dependencies. Because if you haven’t there could be unusual behavior

Hoshikage,

First of all it looks it did not install correctly. How did you install your ATI driver? Have you first generated an rpm package, or have you installed it straight from the ati package? Please have a look at the install log file, you find it at:
/usr/share/ati/fglrx-install.log
Please report here what it says.
Which version of the ati driver did you install?

Secondly your xorg.conf file possibly contains too much information. But that is step 2.

Regards

I did not generate RPM’s, I installed straight from ATI’s package.

install log

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kern
el module now.
AMD kernel module generator version 2.1
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h
[Error] Kernel Module : Failed to compile kernel module - please consult readme.

I could have sworn that the installer said that it installed successfully… suppose not. Checking, I don’t have a /usr/src/linux, getting a kernel sources package would give me a /usr/src/linux directory, but would I have to build a new kernel? I’d prefer not to because my processor isn’t the fastest, the last time I built a kernel, it took about an hour and half.

You will require the kernelheaders and a number of other packages to be able to compile the driver and the kernel module (you don’t need to compile your complete kernel, however).
Maybe it is best to first try the ATI repo as mentioned by siminin. You will have to add this repo to the repositories using Yast. Just add http://www2.ati.com/suse/11.2 to you repositories. Then install the kernelmodule
ati-fglrxG02-kmp-default or ati-fglrxG02-kmp-desktop, depending on your kernel, and the driver x11-video-fglrxG02
After installation execute the command in a ternimalwindow on the commandline (as root, command without the quotes)
‘aticonfig --install --input-/etc/X11/xorg.conf’
Then you should testart you’re computer, and it should work.

Good luck!

Admo

When you use the repository you don’t need to use aticonfig command. Just logout/restart and it’s ready.
If you want to install it from ati’s site read https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_cat86-inst.html and ATI - openSUSE
Hmm, the previous ATI HOWTO page was better. There was a list of all the needed dependencies. Anyway, install the packages listed as dependencies from those two links and their devel packages. It’s easier to do it in yast than zypper :slight_smile: After that you should be ready to go and enjoy 3D.

I installed from the repo, and now my mouse and keyboard are unusable in X. I can boot to init 3 though.

There we found your mistake already.
I’ve never made any good experiences with the downloadable driver, it generally just messes things up :silly:
That’s the same in all distros I’ve tried, not just here.

My recommendation is to only install the driver from the repositories!
I’m using the repo driver here, and it works fine :good:
Just do as admoel said, add the repo and install the packages, that’s it.

Well, a fresh install of 11.1 later (I’d read something somewhere that led me to believe I’d have an easier time doing this on 11.1), and installing from the repos, I now get a white screen when I boot. I do have auto-login turned on, as I’m the only user on this computer, and so it could be a problem with gnome/compiz, in which case, I don’t know how to disable compiz from the terminal.

Are you using the same xorg.conf file as you presented in your previous mail?

If so, you have a lot of information in there that is not required by the fglrx driver at all, or maybe even wrong.

Start up in runlevel 3. Login as root.

Please check the xorg log file for errors (/var/log/Xorg.0.log)

If you don understand the error messages (lines starting with (EE), you can post them here and maybe I can help.

You can certainly try the following:

Remove all options from the “Device” section (or comment them out) from the xorg.conf file. Also remove all options from the “Extensions” section.

Remove the file /etc/ati/amdpcsdb (this file contains the settings that are actually used by the driver. You should get rid of those).

Now reboot your computer.

The new Xorg.conf didn’t have an Extensions section, and no options in device (By options, I assume you mean it actually saying options, followed by an option and a value)

Deleted amdpcsdb, and restarted, same white screen after the OS loads.

I did forget to check the Xorg.0.log, so I’ll do that now and then edit this post with any errors it reports.

EDIT:
ran less /var/log/xorg.0.log | grep EE, got nothing back.

I hope you did a grep on /var/log/Xorg.0.log, not on /var/log/xorg.0.log as you last line suggests?

Is there anything in in this log-file at all? Is the fglrx driver being used? Check if the kernelmodule is loaded with the command ‘lsmod | grep fglrx’. It should return ‘fglrx’.

Is there maybe a /var/log/Xorg.0.log.old ? If so, have a look at that one, please.

Did you already try to start xorg manually from runlevel 3? If not, try to start it in runlevel 3 from the commandline with ‘startx’. Do you have any messages then?

Admoel

I have found that the ATI drivers from AMD are actually the best to use. My advise to installing and using them is to follow the very detailed installation instructions on the same page as the Download link. Follow them to the letter and you should have no problem (especially if you totally remove any previously installed drivers).

PS I am not the greatest fan of using proprietary software but these do make such a difference to my desktop experience… I’m a sucker for Google Earth!!!lol!

Heh, were it not for a performance hit, I’d be using all Open Source everything. I mainly want these enabled so I can have full 3D acceleration, I want to take another stab at doing 3D graphics now that I have hardware better suited for it.

Running lsmod | grep fglrx gives

 fglrx 1996828 0
agpgart 32148 1 fglrx

And then I did another check of the xorg log, I get

(II) Loading extension MIT-SCREEN-SAVER
(EE) FGLRX(0): [FB] Can not get FB MC address range

I’m almost certain that starting X through startx will give me the same thing, but I’ll try it anyway and have it output everything to a file.

Relevant parts of the file are

(WW) fglrx:No matching Device section for instance (BusID PCI:0@3:0:1) found
(EE) fglrx(0): [FB] Can not get FB MC address range

So, if I understand that first error properly, which I’ve a feeling that I don’t, it’s trying to use a card that’s not there, and so I need to figure out what BusID to use with my card. It’s in my only PCI-E x16 slot, if that could assist with getting this working properly.

If you run the command ‘lspci’ as root, you will get a list of all bus-id’s on the PCI-bus. On my PC bus 1:0:0 identifies my ATI card. So if you still use a busid in your xorg.conf insert the value that is used by your card on your PC.

Admoel

ran lspci, it gave me the busid 03:00:0.0, put that into my xorg.conf, same white screen. Checked both the Xorg.0.log and had startx output everything to a file, neither had any errors.

Xorg.0.log did have a warning that there was no device section for a bus ID 03:00:0.1, which is the HDMI audio on my card, and I don’t have any devices that can use HDMI, so it’s not a big deal to me… unless I need that set up in order to get this all working.

Decided to try again to build the drivers myself, so I removed the ones from the repo, and ran the build script myself.

Somehow, It’s working near perfectly now. I can’t seem to get it to not clone my second monitor, but I’ll just play with the settings some until it works.

Thanks a ton for assisting me, admoel, have a happy new year.