ATI Catalyst causing invisible cursor

I am currently running OpenSuse 11.2 on my HP laptop with an ATI Mobility Radeon 4500 Series Graphics card. Whenever I go to the ATI/AMD site and install Catalyst for 64-bit Linux, then restart the computer, the mouse cursor disappears.

Does anybody know how to fix this?

Thanks in advance,
Matt


Graphics: ATI Mobility Radeon 4500 Series
Driver: ATI Catalyst 10.2 Proprietary Linux x86 Display Driver

I’m having the exact same issue with an HD4850, using 64-bit Catalyst drivers. :frowning:

I can’t wait to just switch to Nvidia.

Same for me with ATI Radeon HD2400 - ATI catalyst worked fine with suse 10.3. upgraded to 11.2 both 64 bit

Tried 1 click install - broken install
Tried repository install - broken checksum
Downloaded ATI Catalyst from AMD tested both custom and auto install - both installed screen resolution is perfect but the cursor works but is invisible - any ideas?

Download issues reported in another thread

I had the same problem with my Radeon HD5750. Then I install Ati Catalyst driver version 10.1. After that, cursor visible and everything working excellent :).

Dare

I just installed the 10.1 driver and the desktop and mouse are fine. However, OpenGL is not enabled. Any suggestions?

I don’t know what’s wrong. In may case everything work fine.

Dare

I had this problem. After many formats I think i’ve fixed it.

I installed the ati drivers from console, before startx (init3), then i ran the command aticonfig --initial

I then ran startx.

I now have a visible mouse pointer. Hope it stays this way!

Hope this helps.

Further to this, I note ATI in their release notes for the 10.2 Catalyst driver recommend openSUSE users do NOT use sax2 to configure the xorg.conf but rather they recommend use of the “aticonfig --initial”.

So I just have to install / configure the ATI drivers in command prompt (runlevel 3) and it will work? I guess I’ll try that out.
Also, did the OpenGL drivers install too, or just the basic drivers and Catalyst?

There seems to be a problem with this: whenever I try to switch to runlevel 3, the screen will freeze and weird lines and colours will begin appearing. This also happens when I shutdown. Could this be a monitor resolution issue?

EDIT:
Booted into failsafe mode and was able to install the drivers. But now there’s no mouse again.

Also, when I still don’t have OpenGL working… even with the invisible cursor.

I think it’s the kernel.
I’m using an HD 4850 with newest catalyst 10.2. that I just bought because my x1900 (that worked fine with 11.1) wouldn’t work with openSUSE 11.2 at all.

I was having the same problem with the invisible cursor until I downgraded to the originally installed kernel, “kernel-desktop 2.6.31.5-0.1.1-x86_64” and now it works great. Although I’d prefer to stay current with the distro updates.

I tried:
kernel-desktop 2.6.31.12-0.1.1-x86_64 = invisible cursor
kernel-desktop 2.6.31.8-0.1.1-x86_64 = invisible cursor

I haven’t tried:
kernel-default, vanilla, rt, or any newer versions like 2.6.32. If anyone knows one that works or a fix please post…

I have recently installed opensuse and i am having this problem too. When i install the drivers from ati, i lose the mouse cursor and there is a massive performance drop, it can barely handle scrolling down a web page. If i could just get this working i wouldn’t have any use for windows at all!
I have a 4850x2, im using 11.2(64) and whatever the current drivers are on the ati driver page

I find the performance is much better with the default driver (radeonhd). The ‘radeonhd’ driver was just updated recently (today, I think) and those weird lines (when moving windows) have disappeared. I think I’m gonna stay away from catalyst/fglrx for awhile until the driver is out of testing stage for my graphics card.

I’m starting to think that the only solution to this is for ATI/AMD to release an updated, more compatible driver.

If anyone finds an alternate solution or third-party ATI drivers, let me know.

Matt

Reference other packaged radeon drivers, there is post#11 in this thread:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

I didn’t catch the “1” in the 10.1 the other night with my bloodshot eyes and invisible mouse, but it works great for my HD4850, even after updating the kernel.

To download catalyst 10.1 copy the url from ATI’s site for the 10.2 version, paste it in your address bar then change it where it says “10-2” to “10-1” and hit enter.

A week and a half, two video cards, and numerous reinstalls later… ATI/AMD graphic chips WILL NOT be my first choice next time around.

Actually… i had the same problem. Turned out i forgot to install kernel-desktop-devel…

Wooops… Anyway, init 3, run the installer, aticonfig --initial

Yeah, i think that should do it.

Take a look at post#38 here:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Does that help?

I had this problem too. It happened after a kernel update was applied, and the kernel-mode driver couldn’t be loaded. (There is a message in /var/log/Xorg.0.log about “DRI initialization failed!” and telling you that the module could not be loaded.)

I rebuilt the kernel module like this:

cd /lib/modules/fglrx/build_mod
./make.sh
cd /lib/modules/fglrx
./make_install.sh

…then I restarted X, and it worked.

If you need to rebuild the kernel driver, e.g. after a kernel upgrade:

  1. From the login screen, login to a command line (click on “Menu” at the bottom and select it) as root
  2. Enter init 3 to switch to text mode.
  3. Then enter fglrx-kernel-build.sh to rebuild the kernel driver.
  4. After it is done, enter init 6 to reboot. That’s it.