ATI Catalyst 9.12 -- X blank screen

Hey all,

I installed the new 9.12 cat drivers in the usual way (init 3; rpm -e the old drivers; generate new rpm; rpm -i new drivers; init 5), but instead of starting like I expected, I got a blank screen and what appeared to be a hard lock (keyboard lights don’t toggle, Ctrl + Alt + Backspace and Ctrl + Alt + F1 don’t do anything).

I switched back to radeonhd, but I’d like to get the proprietary drivers working if possible.

The usual listings

[nathan@ebisu ~] lsmod | grep fgl
fglrx                2323096  0
[nathan@ebisu ~] modprobe -l | grep fgl

Looks like the driver loaded OK…

[nathan@ebisu ~] dmesg | grep fgl
    4.541203] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    4.576368] [fglrx] Maximum main memory to use for locked dma buffers: 3798 MBytes.
    4.578443] [fglrx]   vendor: 1002 device: 9442 count: 1
    4.578823] [fglrx] ioport: bar 4, base 0xb000, size: 0x100
    4.579046] [fglrx] Kernel PAT support is enabled
    4.579063] [fglrx] module loaded - fglrx 8.68.2 [Nov 24 2009] with 1 minors

[nathan@ebisu /var/log] sudo cat messages | grep fgl
Dec 19 10:37:25 ebisu kernel:   568.481429] fglrx_pci 0000:01:00.0: irq 30 for MSI/MSI-X
Dec 19 10:37:25 ebisu kernel:   568.481936] [fglrx] Firegl kernel thread PID: 10736
Dec 19 10:37:26 ebisu kernel:   569.212297] [fglrx] Gart USWC size:1236 M.
Dec 19 10:37:26 ebisu kernel:   569.212303] [fglrx] Gart cacheable size:491 M.
Dec 19 10:37:26 ebisu kernel:   569.212309] [fglrx] Reserved FB block: Shared offset:0, size:1000000
Dec 19 10:37:26 ebisu kernel:   569.212313] [fglrx] Reserved FB block: Unshared offset:fc21000, size:3df000
Dec 19 10:37:26 ebisu kernel:   569.212318] [fglrx] Reserved FB block: Unshared offset:1fffb000, size:5000
Dec 19 10:37:26 ebisu kernel:   569.374309] Modules linked in: vboxdrv snd_pcm_oss snd_mixer_oss snd_seq snd_seq_device edd nfs lockd fscache nfs_acl auth_rpcgss sunrpc cpufreq_conservative cpufreq_userspace cpufreq_powersave acpi_cpufreq fuse loop dm_mod snd_hda_codec_atihdmi snd_hda_codec_analog ohci1394 joydev sr_mod i2c_i801 pcspkr sg fglrx(P) skge cdrom iTCO_wdt iTCO_vendor_support serio_raw sky2 ieee1394 asus_atk0110 intel_agp snd_hda_intel button snd_hda_codec snd_hwdep snd_pcm snd_timer snd snd_page_alloc ext4 jbd2 crc16 fan processor ide_Dec 19 10:38:18 ebisu kernel: imklog 4.4.1, log source = /proc/kmsg started.

I did find another interesting thing in /var/log/messages which is unquestionably related:

Dec 19 10:26:12 ebisu kdm[1472]: X server died during startup
Dec 19 10:26:12 ebisu kdm[1472]: X server for display :0 cannot be started, session disabled
Dec 19 10:26:12 ebisu kernel:    12.115458] BUG: scheduling while atomic: Xorg/1506/0x00000002

Googling on that last line didn’t reveal anything enlightening, unfortunately.

Something appears to have eaten Xorg.0.log and Xorg.0.log.old is zero-length, but I looked through it before it got stomped and didn’t see anything that looked like a smoking gun. The last line was “Backtrace:” with nothing after it, making it look like it tried to write a stack dump and couldn’t for whatever reason. There weren’t any EE lines that looked fglrx related.

[nathan@ebisu /etc/X11] cat xorg.conf.fglrx 
Section "ServerLayout"                          
        Identifier     "Layout[all]"            
        Screen      0  "Screen[0]" 0 0          
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"    
        Option      "Clone" "off"                  
        Option      "Xinerama" "off"               

Section "Files"
        InputDevices   "/dev/gpmdata"
        InputDevices   "/dev/input/mice"

Section "Module"
        Load  "dbe"
        Load  "freetype"
        Load  "extmod"  
        Load  "glx"     
        Load  "dri"     
        Load  "GLcore"  

Section "ServerFlags"
        Option      "AllowMouseOpenFail" "on"
        Option      "ZapWarning" "on"        

Section "InputDevice"
        Identifier  "Keyboard[0]"
        Driver      "kbd"        
        Option      "Protocol" "Standard"
        Option      "XkbLayout" "us"     
        Option      "XkbModel" "microsoftpro"
        Option      "XkbRules" "xfree86"     

Section "InputDevice"
        Identifier  "Mouse[1]"
        Driver      "mouse"   
        Option      "Buttons" "5"
        Option      "Device" "/dev/input/mice"
        Option      "Name" "Microsoft Wheel Mouse Optical"
        Option      "Protocol" "explorerps/2"             
        Option      "Vendor" "Sysp"                       
        Option      "ZAxisMapping" "4 5"

Section "Modes"
        Identifier     "Modes[0]"
        ModeLine     "1920x1200" 154.0 1920 1968 2000 2080 1200 1203 1209 1235 -hsync +vsync

Section "Monitor"
        Identifier   "Monitor[0]"
        VendorName   "BNQ"
        ModelName    "BENQ G2400W"
        UseModes     "Modes[0]"
        DisplaySize  517        323
        HorizSync    30.0 - 94.0
        VertRefresh  43.0 - 85.0
        Option      "CalcAlgorithm" "XServerPool"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1920x1200"

Section "Device"
        Identifier  "Device[0]"
        Driver      "fglrx"
        Option      "VideoOverlay" "on"
        Option      "OpenGLOverlay" "off"
        Option      "mtrr" "on"
        Option      "UseFastTLS" "2"
        Option      "UseInternalAGPGART" "no"
        Option      "BlockSignalsOnLock" "on"
        Option      "no_accel" "no"
        Option      "no_dri" "no"
        Option      "TripleBuffer" "true"
        BusID       "PCI:1:0:0"

Section "Screen"
        Identifier "Screen[0]"
        Device     "Device[0]"
        Monitor    "Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24

Section "DRI"
        Group        "video"
        Mode         0660

Let me know if you need more info or have an idea about what I could be doing wrong.


After oS-11.2 was out, and those Catalyst drivers came out, I looked for download. It was a little buried, so I checked in the feedback, and saw number of issues. There was a thread on here, wondering if they’d been pulled.

I decided to put that on back burner, I wasn’t bothered too much with 9.11 which ppl had got working before.

Your problem sounds like some of the issues I saw reported.

I looked around in the Hardware forum and didn’t see anything that looked apropos…if you can point me to the thread you mentioned, I’d appreciate it.

Sorry I realise now what I said applies to the 9.11 & 9.10 drivers, not the new 9.12 ones.

The drivers often come out very late in month, I guess they plan to have time off for Christmas or something :\

Those ones only came out on 17th, so you’re in the early adopter club. Guess the forum will build experience on these ones. It might be worth checking back after the weekend.

If you get hard lock, it’s worth trying the Magic SysRq key combos, to put keyboard in Raw mode, kill programs, sync disks and unmount (BUSIER backwards). Often the system is not as wedged as it looks, though logging in over network to reboot can help, when keyboard is truly non-responsive at the lowest level.

Another failure

I could not see that “Bug” scheduling while atomic before, it was partially obscured. That suggests you ought to try reporting it to ATI/AMD and see what they have to say, may be post in their feedback section.

It means (I think) that the driver was pre-empted by scheduler, when it was apparently asking to be in non-preemptible mode.

I haven’t had a lot of luck when reporting bugs to ATI in the past, but I’ll give it a shot. Thanks for looking into it.

Same as you, perfectly good 9.11 graphics hosed.

will advise here if i run into a solution.

I tried the method in
Generating catalyst 9.11 rpm’s on openSUSE 11.2 - openSUSE Forums

using a modified version of specfying catalyst_912 and 12 wherever I thought sensible.

Created an rpm successfully but wouldn’t install

Catalyst 9.12 works really well for me (opensuse 11.2 64bit).

I have installed it with ati’s installer (not rpm).

Hint: Remove /etc/ati/amdpcsdb if you have a previous version installed.

Unfortunately this method didn’t work for me and hosed my 9.11 installation. I managed to get things working again using 1-click (using rpm variant discussed in other posts didn’t work). Guess I get to sit tight until 9.13.

BTW is there any chance that the “1 click” variant is turning off Compositing by default?

Or until 10.1 - Cat driver naming convention is year/month.

Unfortunately that is the only advice regarding cat drivers I can offer at this stage.

I’m new to opensue 11.2 + KDE and was wondering if there is any benefit at all in using cat 9.12 vs 9.11?

According to their release notes, there is supposed to be alot more support for those using TVs etc.

I was hoping that I would get some resolution/playback improvement for normal use (3d stuff, flash movies, avi, wmv etc) as from what I saw subjectively in various forums, the 9.10 and 9.11 drivers were panned for poor quality

FWIW, the Catalyst 10.1 drivers released yesterday seem to fix this problem, but they still don’t fix the slow repaint bug with 3D/Compositing enabled (described here).

I swear, Intel needs to start making PCI graphics cards again. Those things just freaking worked in Linux.